DIY Turbo Discussion greddy on a 1.8? homebrew kit?
Sponsored by:
Sponsored by:

HELP! Uncontrollable idle

 
Old 07-22-2018, 04:35 PM
  #1  
Newb
Thread Starter
 
Join Date: Jul 2018
Posts: 6
Total Cats: 0
Default HELP! Uncontrollable idle

Hi, i have a 1997 miata that i just turboed. Its tuned on megasquirt gen 2. Once I finished installing everything i started it and the idle kept climbing about to redline. So i switched it back to the stock ecu to see if it was a tuning problem, same outcome, so i read forums for awhile and everone said IAC so i replaced that and of course same thing was happening. I finally had the genius idea of disconnecting the wastegate rod to see what would happen, on the stock ecu it idles really rough and stalls out with no throttle, with the wastegate rod connected it revs up. On megasquirt with the rod on or off it revs up. My assumption is its catching boost at idle and just starts revving the **** out of itself because i can hear it spooling up even with the throttle closed. Any ideas on what i can do? Thanks!
ColeMadsen is offline  
Old 07-22-2018, 08:25 PM
  #2  
Senior Member
 
Join Date: Mar 2014
Location: Jacksonville, FL
Posts: 1,195
Total Cats: 145
Default

What injectors are you running? Stock ecu idles rough as it's probably running pig rich on those injectors.

post more details on your setup and a log when the crazy revving is happening. And post your tune file.
borka is offline  
Old 07-23-2018, 10:46 AM
  #3  
Newb
Thread Starter
 
Join Date: Jul 2018
Posts: 6
Total Cats: 0
Default

Originally Posted by borka View Post
What injectors are you running? Stock ecu idles rough as it's probably running pig rich on those injectors.

post more details on your setup and a log when the crazy revving is happening. And post your tune file.
Im running rx-8 yellows 420cc. I had the injectors in before i turboed the car and it ran rich but performed just fine. I actually had someone tune it for me so i dont have the log but it was sent to megasquirt for review and they said everything looked fine.
ColeMadsen is offline  
Old 07-23-2018, 10:50 AM
  #4  
Senior Member
iTrader: (1)
 
Join Date: Dec 2010
Location: Farmington Hills, MI
Posts: 1,146
Total Cats: 152
Default

Air leak. Boost won't rev up a motor if the throttle is closed and there's no other way for air to get by.
acedeuce802 is online now  
Old 07-23-2018, 12:42 PM
  #5  
Newb
Thread Starter
 
Join Date: Jul 2018
Posts: 6
Total Cats: 0
Default

Originally Posted by acedeuce802 View Post
Air leak. Boost won't rev up a motor if the throttle is closed and there's no other way for air to get by.
yea ill have to look for one. I have the skunk 2 racing intake manifold so itís possible its leaking out of where it splits in half for cleaning and that would be a big enough leak so ill have to check that out.
ColeMadsen is offline  
Old 07-23-2018, 03:10 PM
  #6  
Senior Member
iTrader: (1)
 
Join Date: Jul 2014
Location: Kensington, MD
Posts: 569
Total Cats: -20
Default

What is your wideband saying?
huesmann is offline  
Old 07-23-2018, 03:58 PM
  #7  
Newb
Thread Starter
 
Join Date: Jul 2018
Posts: 6
Total Cats: 0
Default

Originally Posted by huesmann View Post
What is your wideband saying?

Its very lean but i think my wideband is messed up because everytime i let off the gas (before turbo) it would read 22.4 i dont know if its supposed to do that but i dont think it is.
ColeMadsen is offline  
Old 07-23-2018, 04:03 PM
  #8  
Senior Member
 
Join Date: Mar 2014
Location: Jacksonville, FL
Posts: 1,195
Total Cats: 145
Default

Originally Posted by ColeMadsen View Post


Its very lean but i think my wideband is messed up because everytime i let off the gas (before turbo) it would read 22.4 i dont know if its supposed to do that but i dont think it is.
thats normal, you let off the gas, ecu cuts fuel and lets the car coast to save you gas money.

what does the boost gauge show after you start the car and it starts to climb toward redline?
borka is offline  
Old 07-24-2018, 03:07 PM
  #9  
Newb
Thread Starter
 
Join Date: Jul 2018
Posts: 6
Total Cats: 0
Default

Originally Posted by borka View Post
thats normal, you let off the gas, ecu cuts fuel and lets the car coast to save you gas money.

what does the boost gauge show after you start the car and it starts to climb toward redline?
it shows vaccume but you can hear the turbo slpooling up which is weird
ColeMadsen is offline  
Old 07-26-2018, 10:49 AM
  #10  
Junior Member
 
Join Date: Oct 2015
Location: Utah
Posts: 70
Total Cats: 3
Default

Change idle from closed loop to open loop or vise versa, sounds like a setting problem with your iacv.
1991 is offline  
Old 07-28-2018, 10:24 AM
  #11  
Newb
Thread Starter
 
Join Date: Jul 2018
Posts: 6
Total Cats: 0
Default

Originally Posted by 1991 View Post
Change idle from closed loop to open loop or vise versa, sounds like a setting problem with your iacv.
Thats what i thought too but it still has the problem on the stock ecu
ColeMadsen is offline  
Old 07-28-2018, 03:33 PM
  #12  
Senior Member
iTrader: (1)
 
Join Date: Feb 2015
Posts: 933
Total Cats: 137
Default

Man this reeks of a massive intake leak after the TB, and you have a megasquirt get the laptop hooked up and see what's going on. You're literally putting a blindfold on and trying to fix this thing without looking at the ECM while you diagnose it.
Bronson M is offline  
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
leboeuf
Race Prep
39
04-09-2016 10:09 AM
dale
MSPNP
8
01-04-2016 11:32 AM
hustler
MEGAsquirt
7
08-11-2012 04:04 PM
Valentinik
MEGAsquirt
6
02-20-2011 06:30 PM
Faeflora
General Miata Chat
18
08-24-2010 11:35 AM


Thread Tools
Search this Thread
Quick Reply: HELP! Uncontrollable idle


Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.