ISIS T25/T28 turbo: time will tell - Page 4 - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


DIY Turbo Discussion greddy on a 1.8? homebrew kit?

Reply
 
 
 
LinkBack Thread Tools
Old 06-29-2013, 10:24 PM   #61
Hittin' Boost & Cones
Thread Starter
iTrader: (2)
 
240_to_miata's Avatar
 
Join Date: May 2007
Location: Cromwell, Connecticut
Posts: 2,572
Total Cats: 11
Default

Finally got VICS hooked up and a slightly better tune on there. Timing isn't too agressive IMO.

VICS made quite a difference in spool. Apparently I had it stuck in the open position before, so no "long runner" low end torque. I hit 10PSI @ about 3800-4000 now. Still not good, but better.

Logs will come eventually when I stop being ghey.
240_to_miata is offline   Reply With Quote
Old 10-09-2013, 06:05 PM   #62
Senior Member
iTrader: (6)
 
Join Date: Sep 2007
Posts: 1,085
Total Cats: 30
Default

So this would be a pretty poor replacement to my SR20 T25 on a 1.6. Thanks for the review! Will hold out for a GT2560r
albumleaf is offline   Reply With Quote
Old 10-09-2013, 06:17 PM   #63
Hittin' Boost & Cones
Thread Starter
iTrader: (2)
 
240_to_miata's Avatar
 
Join Date: May 2007
Location: Cromwell, Connecticut
Posts: 2,572
Total Cats: 11
Default

It would not be a good upgrade, but it still holds as a good brand new turbo for roughly the price of a rebuild & balance.

So far I have about 4 autox's, 1 HPDE, and 1500 street miles on it. Running strong, just miss my low end! lol
240_to_miata is offline   Reply With Quote
Old 10-09-2013, 07:24 PM   #64
Senior Member
iTrader: (6)
 
Join Date: Sep 2007
Posts: 1,085
Total Cats: 30
Default

Of all the days not to have a T3 manifold so I could pick up Brain's chinacharger. I don't think there's a good cheap alternative to the 2650r (Nissan ones pop up now and then but I keep missing them, argh). There's a 2554r locally for cheap-ish that would be a bit nicer for spool but nothing on the top end.
albumleaf is offline   Reply With Quote
Old 11-17-2013, 02:29 AM   #65
Newb
 
Join Date: Mar 2012
Location: Edmonton
Posts: 2
Total Cats: 0
Default

what did you end up using for turbo feed?

I am ordering this turbo right now for my build, just curious what route you took for oil feed, enjuku mentions to use -3an line only, but everything seems difficult to find in -3an. Im thinking of just running -4an and using a restrictor such as:
http://www.summitracing.com/int/part...0287/overview/
would you run .060, .045 or . 030


also, are these the correct fittings for water and drain?
http://www.summitracing.com/int/part...0229/overview/
http://www.summitracing.com/int/part...7070/overview/

I would like to order the correct parts the first time and help would would be great.

Last edited by stuff; 11-17-2013 at 03:59 AM.
stuff is offline   Reply With Quote
Old 11-17-2013, 02:39 AM   #66
I'm a terrible person
iTrader: (19)
 
FRT_Fun's Avatar
 
Join Date: Apr 2009
Location: Arizona
Posts: 7,293
Total Cats: 180
Default

Bros! if anyone is looking for a 2871 china charger I'm selling one! It's the godspeed one many people have had good results from. Comes with a bunch of random fittings, no idea if they will work though.

/thread jack
FRT_Fun is offline   Reply With Quote
Old 11-17-2013, 10:16 AM   #67
Elite Member
iTrader: (5)
 
Join Date: Aug 2011
Location: South Jersey
Posts: 1,523
Total Cats: 30
Default

Quote:
Originally Posted by stuff View Post
what did you end up using for turbo feed?

I am ordering this turbo right now for my build, just curious what route you took for oil feed, enjuku mentions to use -3an line only, but everything seems difficult to find in -3an. Im thinking of just running -4an and using a restrictor such as:
http://www.summitracing.com/int/part...0287/overview/
would you run .060, .045 or . 030


also, are these the correct fittings for water and drain?
http://www.summitracing.com/int/part...0229/overview/
http://www.summitracing.com/int/part...7070/overview/

I would like to order the correct parts the first time and help would would be great.
I just went with Artech oil/water lines.

Attached Thumbnails
ISIS T25/T28 turbo: time will tell-20131002_163639_zps47426214.jpg  
BTMiata is offline   Reply With Quote
Old 11-17-2013, 10:19 AM   #68
Hittin' Boost & Cones
Thread Starter
iTrader: (2)
 
240_to_miata's Avatar
 
Join Date: May 2007
Location: Cromwell, Connecticut
Posts: 2,572
Total Cats: 11
Default

I used the same -3 stuff and coolant kit I had on my sr20 t25. Think I got them from tunertoys but they are long gone.
240_to_miata is offline   Reply With Quote
Old 11-28-2013, 02:22 PM   #69
Junior Member
iTrader: (1)
 
Meeners's Avatar
 
Join Date: Jul 2008
Posts: 194
Total Cats: 0
Default

If it is truly a t28 hybrid, it won't "shine" until around 13psi... Granted it's a generic one, from messing around with Nissans for a grip, the compromise you get in the slightly later spool is a little better efficiency up top... Hoping to hear back after you tune and up boost a little.
Meeners is offline   Reply With Quote
Old 10-21-2014, 11:06 PM   #70
Elite Member
iTrader: (5)
 
Join Date: Aug 2011
Location: South Jersey
Posts: 1,523
Total Cats: 30
Default

Figured I'd bring this back from the dead... My car is alive with this turbo but I won't have it tuned until next week.. For now I'm just buttoning up the small things. I'll update with how it feels after next Tuesday once I can wipe the grin off my face and get out of the car haha
BTMiata is offline   Reply With Quote
Old 04-01-2015, 05:06 PM   #71
Elite Member
iTrader: (5)
 
Join Date: Aug 2011
Location: South Jersey
Posts: 1,523
Total Cats: 30
Default

Few thousand miles on this turbo now. I started to hear a faint noise today that could either be the turbo or a coupler loose... It is only audible in higher RPM's and when it reaches full boost (Only 10psi for me). Hopefully its just a coupler or something else stupid. If this thing dies I'll probably throw a used garrett on it
BTMiata is offline   Reply With Quote
Old 04-01-2015, 05:22 PM   #72
Hittin' Boost & Cones
Thread Starter
iTrader: (2)
 
240_to_miata's Avatar
 
Join Date: May 2007
Location: Cromwell, Connecticut
Posts: 2,572
Total Cats: 11
Default

No problems or issues for me yet. Then again I've driven about 3 miles since November. The car has ms3 now with ebc so I'll be tuning up to 16-18psi And find out where she runs out of breath
240_to_miata is offline   Reply With Quote
Old 04-01-2015, 05:25 PM   #73
Elite Member
iTrader: (5)
 
Join Date: Aug 2011
Location: South Jersey
Posts: 1,523
Total Cats: 30
Default

Quote:
Originally Posted by 240_to_miata View Post
No problems or issues for me yet. Then again I've driven about 3 miles since November. The car has ms3 now with ebc so I'll be tuning up to 16-18psi And find out where she runs out of breath
Any idea how many miles you have on it since installing it?
BTMiata is offline   Reply With Quote
Old 04-01-2015, 05:29 PM   #74
Hittin' Boost & Cones
Thread Starter
iTrader: (2)
 
240_to_miata's Avatar
 
Join Date: May 2007
Location: Cromwell, Connecticut
Posts: 2,572
Total Cats: 11
Default

About 5000 miles , 2 track days at 10 psi and the rest at about 14 psi with a mbc
240_to_miata is offline   Reply With Quote
Old 04-01-2015, 05:32 PM   #75
Elite Member
iTrader: (5)
 
Join Date: Aug 2011
Location: South Jersey
Posts: 1,523
Total Cats: 30
Default

Quote:
Originally Posted by 240_to_miata View Post
About 5000 miles , 2 track days at 10 psi and the rest at about 14 psi with a mbc
Nicee i'm really hoping mine is just a coupler or a boost leak somewhere... Really dont want to spend $$ on a turbo. I have been on the fence with the Wilwood BBK on Fab9's site so i'd much rather spend money there haha
BTMiata is offline   Reply With Quote
Old 04-26-2015, 09:01 PM   #76
Newb
 
Join Date: Apr 2015
Posts: 21
Total Cats: 0
Default

Quote:
Originally Posted by 240_to_miata View Post
I haven't gotten to drive the car much yet. My wideband was giving me **** so I am in the middle of replacing it...Then I need to retune.

I did do one autox on Memorial day and it was great. I had NO issues falling off boost even with the shitty spool of this turbo. I am still at the wastegate pressure of 10 PSI.

More to come next week I hope
I'm having thoughts about purchasing a kit from begi so is this the same Churbo from begi
Gt2554 or the gt2560?
Minosum is offline   Reply With Quote
Old 05-07-2015, 10:04 AM   #77
Hittin' Boost & Cones
Thread Starter
iTrader: (2)
 
240_to_miata's Avatar
 
Join Date: May 2007
Location: Cromwell, Connecticut
Posts: 2,572
Total Cats: 11
Default

Well, time has told ...

Blew the turbo today. Side to side shaft play and bad noises when entering boost. It happened during a track day.

Street miles : 5000
track days: 8-10 20 min sessions
boost:10-15 street, 10 track
oil: 15/40 Rotella.
Feed: -3 an
bov: shitty greddy type rs


Track oil Temps got to 250 during a session. I know the 15/40 isn't great for high oil temps so I'll be changing to another oil. That may have had something to do with this.

Oh well. Time to buy a real turbo. At least I cought it before it blew into pieces and went into my motor.
240_to_miata is offline   Reply With Quote
Old 05-07-2015, 10:08 AM   #78
Elite Member
iTrader: (5)
 
Join Date: Aug 2011
Location: South Jersey
Posts: 1,523
Total Cats: 30
Default

I hear a howling noise in boost in 3rd gear or higher up to redline... I wonder if mine is doomed for the same fate. I checked the shaft and it literally had 0 play. I better start saving for a Garrett lol
BTMiata is offline   Reply With Quote
Old 05-07-2015, 10:15 AM   #79
Elite Member
iTrader: (5)
 
Join Date: Aug 2011
Location: South Jersey
Posts: 1,523
Total Cats: 30
Default

And it might be more of a "Whine" than a "howl".... You can kind of hear the noise here. Its been like this for a while and didn't think much of it until now because there is no shaft play or anything. Maybe I'm just crazy and the noise is normal I dont know lol

BTMiata is offline   Reply With Quote
Old 05-07-2015, 10:18 AM   #80
Hittin' Boost & Cones
Thread Starter
iTrader: (2)
 
240_to_miata's Avatar
 
Join Date: May 2007
Location: Cromwell, Connecticut
Posts: 2,572
Total Cats: 11
Default

Yeah I checked shaft play last week and had none. I checked last night when I got home and had no front to back but Was able to find side to side. It was stiff though which explains why I was able to drive home and not have an issue. It was only when I pushed pretty good that I was able to move side to side.
240_to_miata is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Project Gemini - Turbo Civic on the Cheap Full_Tilt_Boogie Build Threads 58 12-13-2017 10:04 PM
My solution for Oiltemp and Oilpressure input into Megasuirt (MS3) Zaphod MEGAsquirt 41 01-24-2016 01:25 PM
WTB MP62 (Hotside) (NB2) Rick02R WTB 3 01-03-2016 08:18 PM
Expected intake temps on the track? tazswing Race Prep 20 10-03-2015 12:04 PM
Time to start learning and play with tuning The Gleas MEGAsquirt 3 10-01-2015 10:30 AM


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 04:28 AM.