LINK EBC troubleshooting - electrical help please - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


DIY Turbo Discussion greddy on a 1.8? homebrew kit?

Reply
 
 
 
LinkBack Thread Tools
Old 01-11-2008, 04:14 PM   #1
Elite Member
Thread Starter
iTrader: (5)
 
m2cupcar's Avatar
 
Join Date: Jan 2005
Location: Atlanta
Posts: 7,247
Total Cats: 291
Default LINK EBC troubleshooting - electrical help please

Finally got around to searching for the problem with LINK electronic boost control today. My circuit outside of the ecu box is good. So I'm on the inside now, and I think I've found the problem. The driver rail that the EBC driver is mounted too, has five other drivers of the same spec mounted to it- the BUK555-100a mosfet transistor. I tested from the gate pin to the center drain pin on the other five and got a positive on continuity, yet on the EBC I get nothing. Would you say that justifies replacement?

Here's the ecu trace showing the driver rail and circuit trace for the EBC and the driver spec sheet:


Last edited by m2cupcar; 01-11-2008 at 06:16 PM.
m2cupcar is offline   Reply With Quote
Old 01-14-2008, 01:48 PM   #2
Elite Member
Thread Starter
iTrader: (5)
 
m2cupcar's Avatar
 
Join Date: Jan 2005
Location: Atlanta
Posts: 7,247
Total Cats: 291
Default How to test the LINK ebc mosfet

1. Pull the cpu
2. Build a test light. Run a dash size incandescent bulb (or led w/resistor) in place of the solenoid on the EBC leads
3. Turn the ignition on. This will turn on your cooling fan AND power the EBC circuit- so your LED/test light should come on.
4. Now run put the Gate pin on the mosfet to ground. Your test light should turn off. Then put a +5v to the Gate pin and the test light should turn on. That shows a working Mosfet (and diodes). If not, it's either the software settings or a bad cpu.
m2cupcar is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Raleigh: Fiberglass headlight scope, 1.6L ECU, AFM, Hardtop latches, more bigmackloud Miata parts for sale/trade 13 09-22-2017 01:34 PM
Buzzing from driver side of engine bay? (MS3 install) nick470 MEGAsquirt 7 06-16-2017 02:53 PM
Missing/knock at idle, can someone point me in the right direction? Mikel MEGAsquirt 4 09-28-2015 05:46 PM
why is my car running like pewp? (tune/datalog) itsMikey MSPNP 3 09-28-2015 07:40 AM


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 06:41 PM.