Turbonetics External Wastegate-overboost - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


DIY Turbo Discussion greddy on a 1.8? homebrew kit?

Reply
 
 
 
LinkBack Thread Tools
Old 06-10-2008, 03:02 PM   #1
Senior Member
Thread Starter
iTrader: (4)
 
Join Date: Oct 2006
Location: Tampa
Posts: 780
Total Cats: 0
Default Turbonetics External Wastegate-overboost-fixed

I have a 9psi spring, but the MS is registering a little above 200kpa, around 12psi. So, I am hitting the soft cut that I set in the MS overboost. Yay for that working as it should. Guys, what do I need to look at on the wastegate? I do not see an adjustment screw at the top. Just two vacuum ports, and the allen screws that hold the EWG together. The vacuum ports are as follows:
Compressor to lower port on the wastegate, and from the wastegate back into the vacuum line from the cruise control. There arent any leaks. I did some searches, but nothing really popped up that was really related to the issue.

Last edited by 96rdstr; 06-10-2008 at 08:07 PM.
96rdstr is offline   Reply With Quote
Old 06-10-2008, 03:06 PM   #2
Miotta FTW!
iTrader: (24)
 
Splitime's Avatar
 
Join Date: Jun 2006
Location: Chicagoland, IL
Posts: 4,292
Total Cats: 26
Default

200kpa is ~14ish psi I believe.. (kpa x .145)-14.7[1bar] = psi

So you T'd into the comp->lower wg port line for the cruise?

FWIW... we had issues with the turbonetic gates creeping on my friends setup and they seem to be known for it. Switched to a tial 38mm gate and all was perfect.
Splitime is offline   Reply With Quote
Old 06-10-2008, 03:18 PM   #3
Senior Member
Thread Starter
iTrader: (4)
 
Join Date: Oct 2006
Location: Tampa
Posts: 780
Total Cats: 0
Default

Quote:
Originally Posted by Splitime View Post
200kpa is ~14ish psi I believe.. (kpa x .145)-14.7[1bar] = psi

So you T'd into the comp->lower wg port line for the cruise?

FWIW... we had issues with the turbonetic gates creeping on my friends setup and they seem to be known for it. Switched to a tial 38mm gate and all was perfect.
no, no. The Evolution has two vacuum ports. One(lower) connects directly to the Compressor, no tees. The other(upper) is connected to the cruise. But, I just went through the manual yet again and I think that is where the problem may lie. The upper port either gets capped off or fed back into the intake post filter. I mis-red it and just tapped the CC line and teed it in. I will cap it off and see. 12 or 14psi, whatever, it is a freaking hoot....

Man, it slams you back into your seat...until the boost cut kicks in. The Megasquirt freaking rocks!
96rdstr is offline   Reply With Quote
Old 06-10-2008, 03:23 PM   #4
Boost Czar
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 72,814
Total Cats: 1,780
Default

just leave the top port open.
Braineack is online now   Reply With Quote
Old 06-10-2008, 03:26 PM   #5
Miotta FTW!
iTrader: (24)
 
Splitime's Avatar
 
Join Date: Jun 2006
Location: Chicagoland, IL
Posts: 4,292
Total Cats: 26
Default

Upper port should be left open unless you are running a particular style of EBC.
Splitime is offline   Reply With Quote
Old 06-10-2008, 03:43 PM   #6
Senior Member
Thread Starter
iTrader: (4)
 
Join Date: Oct 2006
Location: Tampa
Posts: 780
Total Cats: 0
Default

I have a Turbonetics MBC that uses both ports that I may hook it up to. I didnt want to use it until I got the newly cleaned and flowed injectors(thanks Inj Rehab) in and running good. The AFR's were actually good at that psi. They were running around 11.9 at full boost prior to fuel cut. I am going to do some more datalog runs this evening.

Thanks for the help guys, it is always appreciated.
96rdstr is offline   Reply With Quote
Old 06-10-2008, 08:06 PM   #7
Senior Member
Thread Starter
iTrader: (4)
 
Join Date: Oct 2006
Location: Tampa
Posts: 780
Total Cats: 0
Default

Fixed, and I am back to running a nice 11psi.


Splitime and Brain. Thanks for your help.
96rdstr is offline   Reply With Quote
Old 06-10-2008, 09:37 PM   #8
Miotta FTW!
iTrader: (24)
 
Splitime's Avatar
 
Join Date: Jun 2006
Location: Chicagoland, IL
Posts: 4,292
Total Cats: 26
Default

Np. Just as a note. Typically the upper port is designed to be used with an electronic boost controller. It allows the controller to open up and send boost/pressure into the top of the WG, this allows it to keep it closed, control boost onset and regulate boost.

I don't know of any mbc that uses it... heck the MS ebc is just an inline setup like a mbc.
Splitime is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
OTS Bilstein to motorsports ASN conversion stoves Suspension, Brakes, Drivetrain 5 04-21-2016 04:00 PM
Miata new person and a what's it worth! Model192 Meet and Greet 16 09-29-2015 09:50 PM
help me decide on a new turbo airbrush1 DIY Turbo Discussion 27 08-29-2007 02:08 PM
Help with friends DIY turbo civic. Fireindc DIY Turbo Discussion 8 04-30-2007 01:54 PM


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 11:23 AM.