1.6 ecu pinout schematic - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


E-Manage Post your questions about greddy e-manage installation and tuning here.

Reply
 
 
 
LinkBack Thread Tools
Old 08-16-2007, 09:20 AM   #1
Junior Member
Thread Starter
 
Join Date: Jun 2006
Location: scotland/Houston
Posts: 127
Total Cats: 0
Default 1.6 ecu pinout schematic

As title
anyone have/a link to a pin out diagrahm of a stock 1.6 ecu.

Also is anyone aware of any differences between the pinout of a european mx5, Eunos roadster and a US spec Miata?

Reason i ask is i have a EMB plug n play harness (from US supplier) - but it appears there are possibley some subtle wiring /pinout differences between the two ECU,s- when plugged in the car (not mine) wont rev over 2000rpm.

Any help appreciated
rockdoc is offline   Reply With Quote
Old 08-16-2007, 10:10 AM   #2
Senior Member
 
steelrat's Avatar
 
Join Date: Jul 2005
Posts: 514
Total Cats: 0
Default

Cut the TPS wire. Most of the 1.6 ECUs (except the autos) have on/off TPS. The autos and the 1.8's have a variable TPS.

It's a known issue.... Stop feeding the EMB the TPS, and it will be fine.

Dave,
steelrat is offline   Reply With Quote
Old 08-16-2007, 10:54 AM   #3
Boost Czar
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 72,854
Total Cats: 1,788
Default

Braineack is offline   Reply With Quote
Old 08-16-2007, 02:48 PM   #4
Junior Member
Thread Starter
 
Join Date: Jun 2006
Location: scotland/Houston
Posts: 127
Total Cats: 0
Default

cheers chaps
rockdoc is offline   Reply With Quote
Old 08-16-2007, 07:29 PM   #5
Junior Member
 
Join Date: Aug 2007
Location: England
Posts: 124
Total Cats: 0
Default

Yeah, thanks, will come in handy.
jim-NA is offline   Reply With Quote
Old 08-17-2007, 09:20 AM   #6
Junior Member
Thread Starter
 
Join Date: Jun 2006
Location: scotland/Houston
Posts: 127
Total Cats: 0
Default

Quote:
Originally Posted by steelrat View Post
Cut the TPS wire. Most of the 1.6 ECUs (except the autos) have on/off TPS. The autos and the 1.8's have a variable TPS.

It's a known issue.... Stop feeding the EMB the TPS, and it will be fine.

Dave,
Thanks Dave
So am i correct in thinking the 1.8 or autos DONT need the TPS wire cut to the EMB- as they have variable sensors?
rockdoc is offline   Reply With Quote
Old 08-17-2007, 10:20 AM   #7
Senior Member
 
steelrat's Avatar
 
Join Date: Jul 2005
Posts: 514
Total Cats: 0
Default

Yeah, that's the understanding I have. Without the variable TPS, the reading in the EMB throw the maps off.

Of course you could always upgrade to the autotune in the car, then get the O2 signal into the EM B through the TPS input.

Dave,
steelrat is offline   Reply With Quote
Old 08-17-2007, 12:40 PM   #8
Junior Member
Thread Starter
 
Join Date: Jun 2006
Location: scotland/Houston
Posts: 127
Total Cats: 0
Default

Quote:
Originally Posted by steelrat View Post
Yeah, that's the understanding I have. Without the variable TPS, the reading in the EMB throw the maps off.

Of course you could always upgrade to the autotune in the car, then get the O2 signal into the EM B through the TPS input.

Dave,
Thanks Dave
rockdoc is offline   Reply With Quote
Old 10-27-2007, 01:34 PM   #9
Junior Member
Thread Starter
 
Join Date: Jun 2006
Location: scotland/Houston
Posts: 127
Total Cats: 0
Default

Thread revival here

still havn,t put this to bed yet, managed to get the car running,idling ,revving above 2000rpm .Problem now is -on the eman software although i can access and manipulate the fuelling and timing maps- nothing is physically happening/changing.
On the logs i cant see rpm, or duty cycle- so i thinking it hinges on this.
I can see the afm votlages and boost voltages though.

The ecu unit code is B64F , This pnp harness is turning out to be plug and not so play.

Does anyone think i should be following this drawing for altering the emb end/plugs of the boomslang?- i wouldnt have thought so - but i had to snip the TPS signal to get it to rev past 2k rpm(which isnt mentioned on the schematic)
image002.jpg

Anyone point me in the right direction?

Last edited by rockdoc; 10-27-2007 at 04:59 PM.
rockdoc is offline   Reply With Quote
Old 10-29-2007, 04:30 AM   #10
Junior Member
Thread Starter
 
Join Date: Jun 2006
Location: scotland/Houston
Posts: 127
Total Cats: 0
Default

Bump- Anyone?
rockdoc is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Raleigh: Fiberglass headlight scope, 1.6L ECU, AFM, Hardtop latches, more bigmackloud Miata parts for sale/trade 13 09-22-2017 01:34 PM
Going back to stock. Need some 1.6 parts. Trent WTB 2 10-01-2015 01:15 PM
Are my coils failing? viriiguy General Miata Chat 5 09-28-2015 08:39 PM


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 03:07 PM.