Injector warning!!! - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


E-Manage Post your questions about greddy e-manage installation and tuning here.

Reply
 
 
 
LinkBack Thread Tools
Old 08-08-2007, 03:21 PM   #1
Junior Member
Thread Starter
 
Join Date: Aug 2007
Location: The Netherlands
Posts: 49
Total Cats: 0
Thumbs down Injector warning!!!

Quote:
Well I got everything ready today and I thought I would give it a try. But the car won't start, with or without the EMU. Probably the increased size of the injectors to 550cc is the problem. I could smell the gasoline, so I think the injectors work. The only thing is that I hear a high pitch comming from the area of the injectors. Don't know if that's normal. Didn't pay attention regarding such a sound with the 'old' injectors. Has anyone a working map for a 1999 with 550cc injectors?

Well I checked the partnumber off the injectors I used. They are RX-7 injectors with partnumber 195500-1370. Last time I checked they were hight imp injectors, but according to this tread https://www.miataturbo.net/showthread...ht=195500-1370 there are high and low imp versions off the injectors with the same partnumber.

So I guess I have to measure the resistance of the injectors. (Was not the easiest part of the project, removing the fuelrail.) Can anyone tell me, if the injectors are low imp. How likely is it that I will have any damage to the electrical system (ECU/EMU)? I tried to start about 5 times and I had the ignition on for about 5 minutes for adjusting the EMU.
Today I removed my intake manifold and checked the injectors. Well they appeared to be 2.6 Ohms so they are low impedance I'm not very happy because I did my research before installing them, so I didn't double check. I hope that I didn't fry my ECU or EMU. I'm posting this message so I can warn you guys... DOUBLE CHECK the injectors with partnumber 195500-1370. I have the purple ones, so colour can be deceiving.
MX5Kuro is offline   Reply With Quote
Old 08-08-2007, 03:57 PM   #2
:(
iTrader: (7)
 
Join Date: Jul 2006
Location: nowhere
Posts: 8,281
Total Cats: 2
Default

Yep ive done that as well no damage that i know off.
magnamx-5 is offline   Reply With Quote
Old 08-08-2007, 05:04 PM   #3
Elite Member
iTrader: (5)
 
m2cupcar's Avatar
 
Join Date: Jan 2005
Location: Atlanta
Posts: 7,236
Total Cats: 288
Default

I thought the color differences in the tops where fairly obvious.
I've had at least 16 of the red/purple tops. They all looked like the first example below and were all high ohm.


here's what the low ohm by the same number is supposed to look like
m2cupcar is offline   Reply With Quote
Old 08-08-2007, 05:57 PM   #4
Newb
 
Join Date: Aug 2007
Posts: 4
Total Cats: 0
Default

interesting, im using those same injectors in the build on my 1.8L BP turbo Ford Festiva project along with an EMU, good thing ive been lurking the turbo miata forums or i may have missed this
idealsociety is offline   Reply With Quote
Old 08-08-2007, 06:27 PM   #5
Elite Member
iTrader: (3)
 
Mach929's Avatar
 
Join Date: Oct 2004
Location: lansdale PA
Posts: 2,500
Total Cats: 0
Default

yeah i always check impedence when i get new injectors, that way i know if it's worth it to send them out or not to be cleaned, it could either be open or no resistance either way broken.
Mach929 is offline   Reply With Quote
Old 08-08-2007, 11:22 PM   #6
Newb
 
Join Date: Aug 2007
Posts: 4
Total Cats: 0
Default

you can still use low impedence injectors right? just need resistors?
idealsociety is offline   Reply With Quote
Old 08-09-2007, 12:21 AM   #7
I'm Miserable!
iTrader: (-1)
 
Join Date: May 2007
Location: West Sacramento Ca
Posts: 948
Total Cats: 0
Default

Quote:
Originally Posted by idealsociety View Post
you can still use low impedence injectors right? just need resistors?
Correct. And someitme their not direct fitted, so you need the clips and solder them.
Slidin'Miata916 is offline   Reply With Quote
Old 08-09-2007, 01:41 AM   #8
Newb
 
Join Date: Aug 2007
Posts: 4
Total Cats: 0
Default

yeah mine are the squared off clips, since the festiva uses the rounded like the BP factory ones i rerouted the festiva injector harness to work on the BP since the clips were the same. i did get the pigtails for em so im all good when i switch over, snagged an extra set of 330cc's from a n old turbo 626 as backup just in case the 550's were crap, got the 550's for 75$

ill be starting a new thread soon in here about some questions i have about using the EMU with resistors and some other stuff BP specific...
idealsociety is offline   Reply With Quote
Old 08-09-2007, 12:11 PM   #9
Junior Member
 
Join Date: Mar 2007
Location: Denver, CO
Posts: 50
Total Cats: 0
Default

Don't the high imp have different connectors than the low imp ones?
SMRACER is offline   Reply With Quote
Old 08-09-2007, 02:23 PM   #10
Elite Member
iTrader: (5)
 
m2cupcar's Avatar
 
Join Date: Jan 2005
Location: Atlanta
Posts: 7,236
Total Cats: 288
Default

That can/do - depends on the model injector, and that's where the confusion starts. Those two injectors in my post above, has the same part number and came in the same year rx7 yet Mazda had running change where they went to a low ohm injector. The only visible difference is the color top. Good advice = check 'em with a meter.
m2cupcar is offline   Reply With Quote
Old 08-17-2007, 04:33 AM   #11
Junior Member
Thread Starter
 
Join Date: Aug 2007
Location: The Netherlands
Posts: 49
Total Cats: 0
Default

Quote:
Originally Posted by m2cupcar View Post
That can/do - depends on the model injector, and that's where the confusion starts. Those two injectors in my post above, has the same part number and came in the same year rx7 yet Mazda had running change where they went to a low ohm injector. The only visible difference is the color top. Good advice = check 'em with a meter.
And the color of the low imp when it's new is far more purple than shown on the picture above. So be sure it's the purple kind that is almost red .

I've soldered the resistors, and will be soldering new connectors, to be sure to have good connections.

I hope the car will start.
MX5Kuro is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Project Gemini - Turbo Civic on the Cheap Full_Tilt_Boogie Build Threads 57 07-19-2017 05:11 PM
My solution for Oiltemp and Oilpressure input into Megasuirt (MS3) Zaphod MEGAsquirt 41 01-24-2016 01:25 PM
Changing from 460cc to flow force 610cc in diypnp 90 Turbo MEGAsquirt 19 10-19-2015 04:23 PM
Going back to stock. Need some 1.6 parts. Trent WTB 2 10-01-2015 01:15 PM
Time to start learning and play with tuning The Gleas MEGAsquirt 3 10-01-2015 10:30 AM


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 12:50 AM.