cruise control Q.... - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


ECUs and Tuning Discuss Engine Management, Tuning, & Programming

Reply
 
 
 
LinkBack Thread Tools Search this Thread
Old 09-06-2011, 10:10 AM   #1
Junior Member
Thread Starter
 
Join Date: Mar 2008
Location: Hernando, FL
Posts: 116
Total Cats: 0
Default cruise control Q....

hello kids...

i have a Q...

when y'all replaced the computer for a MS, did your cruise control stop working?

i had CC on my car, and considering i put about 500 miles weekly on my car, i'd like it back...lol.

but after i put MS standalone on the car, my cruise light (lil switch by the mirror switch) comes on, but nothing happens.

Tim and i checked the actual controller in the engine bay and it works, but we couldn't contort gymnastically enough to test the wiring on the CC computer thing to see if that works. we did, however, replace it with a working one and nada....

any ideas?

the only variable was that the 'DONOR' car didn't have any aftermarket parts, just a stock C pkg....

any ideas would be greatly appreciated...
MapaX5 is offline   Reply With Quote
Old 09-06-2011, 10:17 AM   #2
Moderator
iTrader: (11)
 
sixshooter's Avatar
 
Join Date: Nov 2008
Location: Tampa, Florida
Posts: 15,653
Total Cats: 1,559
Default

I thought somebody said once that CC would work with Megasquirt, but I don't know for sure.

I don't use it that often, but it is nice to have on 7 hour interstate road trips. I would like to retain it when I add my Megasquirt as well. I'm in for a definitive answer if anyone knows for sure.
sixshooter is offline   Reply With Quote
Old 09-06-2011, 10:53 AM   #3
Senior Member
iTrader: (10)
 
Join Date: Apr 2007
Location: Ohio
Posts: 800
Total Cats: 3
Default

In for more info on this. I've been considering going standalone but not if I lose the cruise. PITA if it won't work; then I have to figure out what to do about the CEL. The LINK "turn on with the ignition" trick works without the stock ECU, but not with it installed, as far as I can figure.

.....this just got me thinking...maybe the LINK trick WILL work if I cut the CEL light wire at the ecu??
soloracer is offline   Reply With Quote
Old 09-06-2011, 10:57 AM   #4
Tour de Franzia
iTrader: (6)
 
hustler's Avatar
 
Join Date: Jun 2006
Location: Republic of Dallas
Posts: 29,114
Total Cats: 351
Default

Cruise contral is a seperate system that reads speedo cable rpm and uses vacuum to open the throttle plate. It works with any computer.
hustler is offline   Reply With Quote
Old 09-06-2011, 11:09 AM   #5
Senior Member
iTrader: (10)
 
Join Date: Apr 2007
Location: Ohio
Posts: 800
Total Cats: 3
Default

Quote:
Originally Posted by hustler View Post
Cruise contral is a seperate system that reads speedo cable rpm and uses vacuum to open the throttle plate. It works with any computer.
I knew the vac portion would be OK, but why is the OP having trouble?
soloracer is offline   Reply With Quote
Old 09-06-2011, 11:28 AM   #6
Tour de Franzia
iTrader: (6)
 
hustler's Avatar
 
Join Date: Jun 2006
Location: Republic of Dallas
Posts: 29,114
Total Cats: 351
Default

Wait, is this for an NB? It works just fine on my 1.6 chassis car.
hustler is offline   Reply With Quote
Old 09-06-2011, 11:29 AM   #7
Elite Member
iTrader: (24)
 
chriscar's Avatar
 
Join Date: Dec 2007
Location: Carrollton TX
Posts: 1,702
Total Cats: 13
Default

No problem with it here. I have factory cruise retrofitted to my 94 R-Package (all the wiring was already on the car from the factory), and it works fine with the MS. Have you verified that the actuator diaphragm is good? I don't know if it's true or not, but I was concerned that boost could blow it out, so I installed a 1 way check valve in the vac line that feeds it.

C
chriscar is offline   Reply With Quote
Old 09-07-2011, 02:03 AM   #8
Elite Member
iTrader: (2)
 
triple88a's Avatar
 
Join Date: Apr 2006
Location: Chicago, IL
Posts: 9,131
Total Cats: 598
Default

Running adaptronic here however no issues with the CC either. OP did you check the vac lines going to the cc? Are you turning the **** on the wheel to engage the CC?

Check the throttle cable on the pedal.
triple88a is offline   Reply With Quote
Old 09-10-2011, 09:53 PM   #9
Elite Member
iTrader: (2)
 
triple88a's Avatar
 
Join Date: Apr 2006
Location: Chicago, IL
Posts: 9,131
Total Cats: 598
Default

I just figured this out yesterday, there is a plug right next to the stock ECU. I unplugged it for ease of installation. Forgot to plug it in my cc didnt work either. Plugged it in cc works. Check the wiring on yours as it might have come off or something.

Attached Thumbnails
cruise control Q....-dscf0009.jpg  
triple88a is offline   Reply With Quote
Old 09-12-2011, 06:45 PM   #10
Elite Member
iTrader: (7)
 
jeff_man's Avatar
 
Join Date: May 2007
Location: Dallas, Tx
Posts: 3,056
Total Cats: 103
Default

[QUOTE=triple88a;769925]I just figured this out yesterday, there is a plug right next to the stock ECU. I unplugged it for ease of installation. Forgot to plug it in my cc didnt work either. Plugged it in cc works. Check the wiring on yours as it might have come off or something.QUOTE]

I had the same problem with my mirrors, but i knew they were not ecu controlled
jeff_man is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Another Cast Manifold Corky Bell Prefabbed Turbo Kits 18 11-22-2016 10:01 PM
My solution for Oiltemp and Oilpressure input into Megasuirt (MS3) Zaphod MEGAsquirt 41 01-24-2016 01:25 PM
1991 special edition with hard top full part out JC, NJ russian Miata parts for sale/trade 6 10-08-2015 04:01 PM
Time to start learning and play with tuning The Gleas MEGAsquirt 3 10-01-2015 10:30 AM
Got bad Crank Angle Sensor and Random Misfire codes, but runs fine. Greasyman General Miata Chat 2 09-28-2015 11:44 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 04:27 AM.