First drive with turbo and ms. Sputters and backfires at 4k - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


ECUs and Tuning Discuss Engine Management, Tuning, & Programming

Reply
 
 
 
LinkBack Thread Tools Search this Thread
Old 10-06-2011, 07:08 PM   #1
Junior Member
Thread Starter
iTrader: (3)
 
Join Date: Apr 2010
Location: Cary, NC
Posts: 494
Total Cats: 6
Default First drive with turbo and ms. Sputters and backfires at 4k

Went for my first drive on brains base maps and above 4k rpm it sputters and backfires and won't accelerate any above 4000 rpm. Rev limit is 7100. Overboost set to 10psi. Will add video shortly. Also I noticed the center led is lit up on my ms now and it never used to.

edit: wont let me upload iphone video but what do i need to log/take screenshot of to be of any benefit to yall?

Last edited by rigidbigelsworth; 10-06-2011 at 07:20 PM.
rigidbigelsworth is offline   Reply With Quote
Old 10-06-2011, 07:42 PM   #2
Boost Czar
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 72,809
Total Cats: 1,780
Default

(Posting from my phone.)

Log.
Braineack is offline   Reply With Quote
Old 10-06-2011, 08:18 PM   #3
Elite Member
iTrader: (17)
 
Join Date: Aug 2007
Location: Fort Myers, FL
Posts: 2,790
Total Cats: 128
Default

Like Brain says, datalog and see what's going on that's going to tell you more than any video or picture ever could.

As for the problem, my guesses...

1. Overboost is coming on. Do you have a boost gauge? What is it showing? If it's near 10psi, that's likely your problem

2. Air/Fuel Ratio is overly rich or lean. What is your wideband reading at idle? Under acceleration? Have you adjusted the fuel map at all?

3. Spark Blowout. What are your spark plugs gapped at? Did you go 1 range cooler on the plugs? If the first 2 have been fixed, pull the plugs and decrease the gap.

I've had similar problems to what you describe under all 3 circumstances. When I loaded the basemap on both my cars it was WAYYY off. Unless you're just plain lucky, you've got a good deal of tuning ahead of you.
pdexta is offline   Reply With Quote
Old 10-06-2011, 09:08 PM   #4
Junior Member
Thread Starter
iTrader: (3)
 
Join Date: Apr 2010
Location: Cary, NC
Posts: 494
Total Cats: 6
Default

I'll have to get a log up tomorrow

As far as your questions pdexta
1: max psi is around 7 as I have my wastegate set, gauge confirms it
2: idle is around 11 for the most part under hard acceleration it's around 13.5
3: still have stock plugs. What kind of gap should I be aiming for? And what does ' one plug cooler' mean?

Thanks for the quick response
rigidbigelsworth is offline   Reply With Quote
Old 10-06-2011, 09:31 PM   #5
Elite Member
iTrader: (1)
 
Join Date: May 2009
Location: Jacksonville, FL
Posts: 4,682
Total Cats: 216
Default

Needs more fuel in boost, you are detonating.

Are you sure the right basemap is on there? Typically a basemap would be overly rich, not lean.
Full_Tilt_Boogie is offline   Reply With Quote
Old 10-06-2011, 10:05 PM   #6
Junior Member
Thread Starter
iTrader: (3)
 
Join Date: Apr 2010
Location: Cary, NC
Posts: 494
Total Cats: 6
Default

here are my fuel map, spark map, and req fuel value

on the req fuel calculator, it asks for AFR, it is listed as 14.7 should i lower that to like 12 or 13?
Attached Thumbnails
First drive with turbo and ms. Sputters and backfires at 4k-base-maps.jpg  
rigidbigelsworth is offline   Reply With Quote
Old 10-06-2011, 10:34 PM   #7
Elite Member
iTrader: (10)
 
Join Date: Oct 2008
Location: Seattle, Wa
Posts: 1,780
Total Cats: 30
Default

Quote:
Originally Posted by rigidbigelsworth View Post
on the req fuel calculator, it asks for AFR, it is listed as 14.7 should i lower that to like 12 or 13?
No. Req_Fuel is simply used to scale the fuel table values when calculating injector pulsewidth. You simply need more fuel (higher values) in your VE table under load, and less around idle.

You are either
1. Detonating due to a lean condition. You seriously need more fuel under load. Idle should be 15:1 - 14.5:1 and under boost you should be 12:1-11.5:1 at those boost levels. You adjust these by raising and lowering the values in the VE table NOT the target AFR table (seen this a few times)
or
2. You have spark blowout due to incorrectly gapped plugs. Try lowering your gap to .022-.025 IN ADDITION TO adding more fuel.

Cooler plugs refers to how much heat the spark plug dissipates into the head. Hotter plugs dissipate less than cooler plugs. Hotter plugs tend to run cleaner (not foul as often) but as they are a source of heat in the combustion chamber, then can cause detonation in an already lean mixture or under high load/pressure. I can't remember the plug numbers right now since I haven't bought any in a while, but perhaps someone else can chime in with that.

Good rule of thumb is 1 step colder plug for every additional 100whp btw.
Jeff_Ciesielski is offline   Reply With Quote
Old 10-06-2011, 10:45 PM   #8
Junior Member
Thread Starter
iTrader: (3)
 
Join Date: Apr 2010
Location: Cary, NC
Posts: 494
Total Cats: 6
Default

So instead of a like 16 plug go with like 17?or 18?

What's a reasonable step to bump my fuel table by?
rigidbigelsworth is offline   Reply With Quote
Old 10-06-2011, 10:47 PM   #9
Senior Member
iTrader: (4)
 
Join Date: Jan 2008
Location: Falls Church, VA
Posts: 1,367
Total Cats: 16
Default

Stock plugs are NGK BKR5E, you want BKR7E. If your FLAPS doesn't carry them, you can get a set on ebay for $10-12 delivered.
ScottFW is offline   Reply With Quote
Old 10-06-2011, 10:50 PM   #10
Junior Member
Thread Starter
iTrader: (3)
 
Join Date: Apr 2010
Location: Cary, NC
Posts: 494
Total Cats: 6
Default

Can y'all tell from looking at my fuel map if I'm starving for gas in boost? They are just a bunch of numbers to me haha

I'll have to start tuning my fuel map tomorrow. Whats a reasonable step size to adjust my fuel values by? 1?5?10?

Thanks for the suggestions

Last edited by rigidbigelsworth; 10-07-2011 at 12:57 AM.
rigidbigelsworth is offline   Reply With Quote
Old 10-07-2011, 12:57 AM   #11
I'm a terrible person
iTrader: (19)
 
FRT_Fun's Avatar
 
Join Date: Apr 2009
Location: Arizona
Posts: 7,293
Total Cats: 180
Default

Quote:
Originally Posted by rigidbigelsworth View Post
I'll have to get a log up tomorrow

As far as your questions pdexta
1: max psi is around 7 as I have my wastegate set, gauge confirms it
2: idle is around 11 for the most part under hard acceleration it's around 13.5
3: still have stock plugs. What kind of gap should I be aiming for? And what does ' one plug cooler' mean?

Thanks for the quick response
Yes you need more fuel under boost. And less fuel at idle. You are going to blow your **** up.
FRT_Fun is offline   Reply With Quote
Old 10-07-2011, 08:40 AM   #12
Boost Czar
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 72,809
Total Cats: 1,780
Default

still waiting for the log file...
Braineack is offline   Reply With Quote
Old 10-07-2011, 09:01 AM   #13
Antisaint
iTrader: (17)
 
Vashthestampede's Avatar
 
Join Date: Feb 2007
Location: Danbury, CT
Posts: 4,659
Total Cats: 54
Default

I was having a similar issue at one point in time and it was my spark plugs.

Like ScottFW said, BKR7E and gap them accordingly.
Vashthestampede is offline   Reply With Quote
Old 10-07-2011, 10:45 AM   #14
Junior Member
Thread Starter
iTrader: (3)
 
Join Date: Apr 2010
Location: Cary, NC
Posts: 494
Total Cats: 6
Default

Brain you just want one if those tooth logs?
rigidbigelsworth is offline   Reply With Quote
Old 10-07-2011, 10:50 AM   #15
I'm Miserable!
 
Join Date: Jun 2009
Location: albany, ga
Posts: 1,869
Total Cats: 3
Default

in tunerstudio at the top
Datalogging > start
save log file, drive around
datalogging > stop

then upload file and tune to here
Techsalvager is offline   Reply With Quote
Old 10-07-2011, 10:54 AM   #16
Boost Czar
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 72,809
Total Cats: 1,780
Default

* drive around and make event occur.
Braineack is offline   Reply With Quote
Old 10-07-2011, 11:06 AM   #17
Junior Member
Thread Starter
iTrader: (3)
 
Join Date: Apr 2010
Location: Cary, NC
Posts: 494
Total Cats: 6
Default

im kinda hesitant to log while purposely hitting a spot that is potentially detonation...
also when looking at my table vs a table brain posted, i have more fuel at high rpm/high boost, and less at low rpm/low boost already...

as far as i know brain is on similar fueling system, stock fuel pump, 460's
am i missing something?

my map is on the left, one brain posted in another thread is on the right
Attached Thumbnails
First drive with turbo and ms. Sputters and backfires at 4k-myfuel-vs-brainfuel.jpg  
rigidbigelsworth is offline   Reply With Quote
Old 10-07-2011, 11:09 AM   #18
Boost Czar
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 72,809
Total Cats: 1,780
Default

I mean it's possibly you're getting way too rich but the looks of that fuel map. You're adding 20% more fuel within 3psi of boost. But I wouldn't know without seeing a log. Then i can see what the MS is acutally doing and what your inputs (wbo2) are looking like.
Braineack is offline   Reply With Quote
Old 10-07-2011, 11:16 AM   #19
Elite Member
iTrader: (10)
 
Join Date: Oct 2008
Location: Seattle, Wa
Posts: 1,780
Total Cats: 30
Default

Quote:
Originally Posted by rigidbigelsworth View Post
im kinda hesitant to log while purposely hitting a spot that is potentially detonation...
also when looking at my table vs a table brain posted, i have more fuel at high rpm/high boost, and less at low rpm/low boost already...

as far as i know brain is on similar fueling system, stock fuel pump, 460's
am i missing something?

my map is on the left, one brain posted in another thread is on the right
Fuel maps mean absolutely ****. Post a log.
Jeff_Ciesielski is offline   Reply With Quote
Old 10-07-2011, 11:17 AM   #20
Junior Member
Thread Starter
iTrader: (3)
 
Join Date: Apr 2010
Location: Cary, NC
Posts: 494
Total Cats: 6
Default

alright ill go log a run. fingers crossed my engine doesnt blow up :/
rigidbigelsworth is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Garrett Turbo, 1.8 Oil Pan, & Misc. Stuff nbdooey Miata parts for sale/trade 9 08-30-2017 10:50 PM
Another Cast Manifold Corky Bell Prefabbed Turbo Kits 18 11-22-2016 10:01 PM
My solution for Oiltemp and Oilpressure input into Megasuirt (MS3) Zaphod MEGAsquirt 41 01-24-2016 01:25 PM
Are my coils failing? viriiguy General Miata Chat 5 09-28-2015 08:39 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 04:07 AM.