FM Link ECU Knock Sensor Problem - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


ECUs and Tuning Discuss Engine Management, Tuning, & Programming

Reply
 
 
 
LinkBack Thread Tools Search this Thread
Old 02-20-2011, 02:40 PM   #1
Newb
Thread Starter
 
Join Date: May 2009
Location: Victoria, BC, Canada
Posts: 12
Total Cats: 0
Default FM Link ECU Knock Sensor Problem

I bought my car a year ago with the Link already installed and have just gotten around to datalogging. I was horrified to find I had no knock signal showing in the logs. The display when checked shows a zero level of knock at all times. The wiring from the knock sensor to the ECU tests okay with an ohmeter. I took the knock sensor off the motor mount, connected it to the ecu and tried tapping on it - still 0 levels on the display. I tried connecting an audio source, an mp3 player, directly to the RCA jack on the ECU and still the display reads 0. It seems as if the knock circuit in the ECU is hooped. What is the next step? I guess I can open up the ECU and look for something obvious like a broken wire. Any other suggestions?

Cliff
ccornish is offline   Reply With Quote
Old 02-20-2011, 02:44 PM   #2
AFM Crusader
iTrader: (18)
 
olderguy's Avatar
 
Join Date: Oct 2004
Location: Wayne, NJ
Posts: 4,438
Total Cats: 84
Default

When you get it corrected, move the knock sensor to one of the other, more forward tapped holes in the block and put the correct screw in the motor mount. The Link knock sensor engages only a couple of threads in the few applications I have seen and can strip out easily when in the motor mount screw hole.
olderguy is offline   Reply With Quote
Old 02-21-2011, 09:40 AM   #3
Elite Member
iTrader: (5)
 
m2cupcar's Avatar
 
Join Date: Jan 2005
Location: Atlanta
Posts: 7,244
Total Cats: 291
Default

It's the same bosch sensor that was used on a gazillion GMs/saabs. I picked up a spare at the pullapart for $2... or eBay for $10 delivered:
http://cgi.ebay.com/Volvo-240-Saab-9...item3f078d3648
m2cupcar is offline   Reply With Quote
Old 04-05-2011, 11:06 PM   #4
Junior Member
iTrader: (3)
 
Join Date: Mar 2009
Location: Birmingham, AL
Posts: 254
Total Cats: 3
Default

did you ever find the problem with your knock sensor
kww502 is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
My solution for Oiltemp and Oilpressure input into Megasuirt (MS3) Zaphod MEGAsquirt 41 01-24-2016 01:25 PM
Back to Stock Part Out!! Turbo Parts, MS2 Enhanced 01-05, Suspension, and MOAR! StratoBlue1109 Miata parts for sale/trade 16 10-02-2015 10:39 AM
Leaky Wilwoods mx592 Suspension, Brakes, Drivetrain 1 10-01-2015 01:45 AM
Got bad Crank Angle Sensor and Random Misfire codes, but runs fine. Greasyman General Miata Chat 2 09-28-2015 11:44 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 05:29 AM.