RPMs drop slow to idle and rev pulsing - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


ECUs and Tuning Discuss Engine Management, Tuning, & Programming

Reply
 
 
 
LinkBack Thread Tools Search this Thread
Old 10-24-2011, 03:55 PM   #1
Newb
Thread Starter
 
Join Date: Jun 2011
Posts: 5
Total Cats: 0
Default RPMs drop slow to idle and rev pulsing

Hi all! I'm new to the turbo forum but I've been creepin around here for a while just gathering info. I'm currently on my third miata!

So, I have the BEGi S2 kit on my '95 NA now. I have a MS setup and some larger injectors to put back in the car after I pass smog. For the time being I have the stock ecu and injectors. Don't worry I'm not driving it hard!

Currently when driving around town and I take it out of gear the idle will drop or raise to around 1750 and stay there for about 10 seconds and then drop down to normal 800 range. Not sure why, but it really annoys me and I've never had my previous miatas do this. They were not turbo though.

The other problem is the pulsing revs. Occasionally, when the car is out of gear, it will bump up to that 1750 mark and pulse up and down between 1000 and 1750 about 3 or 4 times and then settle back down to normal idle.

I'm guessing it is some kind of sensor that isn't reading right but I would like to get some input before I start prodding around and make a mess of things.

I appreciate any help you can give!
Cheers!
strappinglad is offline   Reply With Quote
Old 10-24-2011, 03:56 PM   #2
Boost Czar
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 72,908
Total Cats: 1,793
Default

Bov?
Braineack is offline   Reply With Quote
Old 10-24-2011, 04:21 PM   #3
Newb
Thread Starter
 
Join Date: Jun 2011
Posts: 5
Total Cats: 0
Default

its a recirculating setup. What would be the problem with it? Broken or leaking?
strappinglad is offline   Reply With Quote
Old 10-25-2011, 12:31 AM   #4
Newb
Thread Starter
 
Join Date: Jun 2011
Posts: 5
Total Cats: 0
Default

Fixed it! Idle was adjusted too high. Many hours of searching to resolve this problem!
strappinglad is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Back to Stock Part Out!! Turbo Parts, MS2 Enhanced 01-05, Suspension, and MOAR! StratoBlue1109 Miata parts for sale/trade 16 10-02-2015 10:39 AM
Time to start learning and play with tuning The Gleas MEGAsquirt 3 10-01-2015 10:30 AM
Low oil pressure after 1.8 swap and new turbo setup JesseTheNoob DIY Turbo Discussion 15 09-30-2015 03:44 PM
Are my coils failing? viriiguy General Miata Chat 5 09-28-2015 08:39 PM
Another Alternator thread ihiryu General Miata Chat 9 09-28-2015 11:22 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 03:04 PM.