99AE knock sensor question - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


Engine Performance This section is for discussion on all engine building related questions.
Sponsored by:
Sponsored by:

Reply
 
 
 
LinkBack Thread Tools Search this Thread
Old 04-15-2012, 02:09 PM   #1
Senior Member
Thread Starter
 
Join Date: Apr 2011
Location: Martin, Slovakia
Posts: 513
Total Cats: 71
Default 99AE knock sensor question

The stock knock sensor on my car has gone open. Previously I think I measured it at 560 k ohms.

Does the stock ecu pull timing as a safety measure when the knock sensor circuit is open?

I think I read that 7 degrees can be pulled by knock control? If there is some corrective action for open knock sensor then would it be throughout the entire rpm range or step in at a particular value?

I need to get a new sensor but they are not stock items here. Has any one used a substitute knock sensor to replace the stock one?

Any suggestions welcomed.
sturovo is offline   Reply With Quote
Old 04-16-2012, 04:14 PM   #2
Elite Member
 
Join Date: Mar 2010
Location: Detroit
Posts: 1,524
Total Cats: 27
Default

That's a good question.

I was messing around with my upstream 02 when I first installed my emb a couple years ago. I was trying to see if I could lock the ecm into a base map by unplugging the up o2 and using my piggyback to change values so I would not be fighting with 14.7:1 afr when transitioning into/out of boost.

It didn't work, I got a bunch of knock in the upper rpm range regardless of how much timing I pulled on the emb. After plugging the o2 back in, the problem went away instantly.

If anyone has more info about the nb knock sensor I'd like to hear more about it.
flounder is offline   Reply With Quote
Old 04-20-2012, 03:40 AM   #3
Elite Member
 
Join Date: Jul 2005
Posts: 6,454
Total Cats: 80
Default

My guess is the factory ECU doesn't pull timing when the knock sensor is bad.

Did it throw a check engine light?
JasonC SBB is offline   Reply With Quote
Old 04-20-2012, 03:32 PM   #4
Senior Member
Thread Starter
 
Join Date: Apr 2011
Location: Martin, Slovakia
Posts: 513
Total Cats: 71
Default

Quote:
Originally Posted by JasonC SBB View Post
My guess is the factory ECU doesn't pull timing when the knock sensor is bad.

Did it throw a check engine light?
I think you might be right.
I tried using a 560 k ohm resistor instead of the knock sensor. As far as I can tell it runs the same with and without the resistor supporting your idea that the ECU does not pull timing when the knock sensor is bad.

It is hard to verify as I have no way of logging timing afaik with high tech EMB pictured below.

No CELs....but I have an obd1 set up that seems to never throw CELs or have any faults when I check with a diode. (If I pull ABS fuses or TPS plug the CEL comes on so I guess it is working.)

Attached Thumbnails
99AE knock sensor question-p1040800.jpg  
sturovo is offline   Reply With Quote
Old 04-22-2012, 09:53 PM   #5
Elite Member
 
Join Date: Mar 2010
Location: Detroit
Posts: 1,524
Total Cats: 27
Default

Nice spot for the mbc.

I used to have that one, then I switched over to a ball and spring type and the boost response is way better. It hits your desired boost level quicker and harder than that style one.
flounder is offline   Reply With Quote
Old 04-24-2012, 04:09 AM   #6
Senior Member
Thread Starter
 
Join Date: Apr 2011
Location: Martin, Slovakia
Posts: 513
Total Cats: 71
Default

Quote:
Originally Posted by flounder View Post
Nice spot for the mbc.

I used to have that one, then I switched over to a ball and spring type and the boost response is way better. It hits your desired boost level quicker and harder than that style one.
You are right, this one is not so good! It overshoots by around 3 psi dips and then settles out just in time for the next gear change. I will probably try the ball spring type too.
sturovo is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
My solution for Oiltemp and Oilpressure input into Megasuirt (MS3) Zaphod MEGAsquirt 41 01-24-2016 01:25 PM
MSPNPPro-MM0105: Coolant Temperature Output slomiata MEGAsquirt 5 10-07-2015 02:11 PM
Back to Stock Part Out!! Turbo Parts, MS2 Enhanced 01-05, Suspension, and MOAR! StratoBlue1109 Miata parts for sale/trade 16 10-02-2015 10:39 AM
Got bad Crank Angle Sensor and Random Misfire codes, but runs fine. Greasyman General Miata Chat 2 09-28-2015 11:44 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 04:23 AM.