Engine mounts - Page 2 - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


Engine Performance This section is for discussion on all engine building related questions.
Sponsored by:
Sponsored by:

Reply
 
 
 
LinkBack Thread Tools Search this Thread
Old 02-02-2012, 01:29 AM   #21
Elite Member
Thread Starter
iTrader: (2)
 
triple88a's Avatar
 
Join Date: Apr 2006
Location: Chicago, IL
Posts: 9,131
Total Cats: 598
Default

Shock mounts check out okay with no play, anti-sway bar bushings check out with no play however they are dry as far as lube goes.
triple88a is offline   Reply With Quote
Old 02-02-2012, 08:45 AM   #22
Elite Member
iTrader: (12)
 
Join Date: Sep 2007
Location: Charlotte, NC
Posts: 6,868
Total Cats: 66
Default

When dry, they will squeak, but not thump. I'd try getting under the car with a 17mm (or is it a 19mm?) and try tightening the LCA nuts to see if any move.
Doppelgänger is offline   Reply With Quote
Old 05-29-2012, 04:13 AM   #23
Elite Member
Thread Starter
iTrader: (2)
 
triple88a's Avatar
 
Join Date: Apr 2006
Location: Chicago, IL
Posts: 9,131
Total Cats: 598
Default

So this thing is still happening.. left bearing was replaced.. still happening. I'm getting buzzing while decelerating so i'm suspecting something with the exhaust.. all bolts are as tight as i can get them. I'm suspecting 2 problems.. one of them with the exhaust, the other with the springs..

The thumping could also be the helper springs collapsing fully because it mainly happens when the front end is loaded a tiny bit but not at max load (hard rights while braking).

Helper springs are not fully compressed at rest.
triple88a is offline   Reply With Quote
Old 05-29-2012, 09:37 PM   #24
Senior Member
iTrader: (14)
 
Join Date: Oct 2006
Location: South East Florida
Posts: 690
Total Cats: 6
Default

Not sure if your issues are mounts or not, but this is the experience I had:

Stock mounts at 170k. Vibrating metallic sound that convinced me it was my exhaust rubbing somewhere. Exhaust shop reccommended i look at mounts after describing the issue. Occurred under deceleration and making right turns (if I recall, and mostly at slow speeds).

Both of my mounts were completely shot and had separated. Replaced with the competition mounts, and could not have been happier (excluding this https://www.miataturbo.net/diy-turbo-discussion-14/turbo-ruined-56181/). NVH increase is minimal and acceptable for a street car.
94mx5red is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Project Gemini - Turbo Civic on the Cheap Full_Tilt_Boogie Build Threads 57 07-19-2017 05:11 PM
Changing from 460cc to flow force 610cc in diypnp 90 Turbo MEGAsquirt 19 10-19-2015 04:23 PM
Expected intake temps on the track? tazswing Race Prep 20 10-03-2015 12:04 PM
Back to Stock Part Out!! Turbo Parts, MS2 Enhanced 01-05, Suspension, and MOAR! StratoBlue1109 Miata parts for sale/trade 16 10-02-2015 10:39 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 05:42 AM.