Freeze plug popping out under boost. - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


Engine Performance This section is for discussion on all engine building related questions.
Sponsored by:
Sponsored by:

Reply
 
 
 
LinkBack Thread Tools Search this Thread
Old 05-22-2011, 11:18 PM   #1
Senior Member
Thread Starter
iTrader: (7)
 
Join Date: Aug 2007
Location: Southern Indiana
Posts: 1,371
Total Cats: -1
Default Freeze plug popping out under boost.

So, I have about 3k miles on this engine and a few months ago, it popped a freeze plug out when rolling into boost. Once the weather got warm, I put it back in and it blew out again. I performed a leakdown test and it showed 30% 40% 45% 50% front to back. Seeing that, I replaced the headgasket. However, that did not fix my issue. Came into boost a couple of times and POP! Coolant exits engine. It is the freeze plug right above the oil filter. I put black RTV on it the first time and the second time I used high tack gasket sealer. Any ideas?

Thanks in advance!
wes65 is offline   Reply With Quote
Old 05-22-2011, 11:29 PM   #2
Elite Member
iTrader: (4)
 
MartinezA92's Avatar
 
Join Date: Aug 2009
Location: Mountain View, CA
Posts: 1,702
Total Cats: 28
Default

Fix your cylinder leakage.
MartinezA92 is offline   Reply With Quote
Old 05-22-2011, 11:33 PM   #3
Elite Member
iTrader: (8)
 
Join Date: Aug 2007
Location: Bellingham, Wa
Posts: 2,732
Total Cats: 3
Default

I see no mention of post headgasket leak down numbers. You probably have a cracked bore or head.
wayne_curr is offline   Reply With Quote
Old 05-22-2011, 11:34 PM   #4
y8s
2 Props,3 Dildos,& 1 Cat
iTrader: (8)
 
y8s's Avatar
 
Join Date: Jun 2005
Location: Fake Virginia
Posts: 19,038
Total Cats: 407
Default

rtv wont hold a freeze plug in either. it's probably too small for one.

and for two, indian head shellac is the bomb.

y8s is offline   Reply With Quote
Old 05-22-2011, 11:36 PM   #5
Tour de Franzia
iTrader: (6)
 
hustler's Avatar
 
Join Date: Jun 2006
Location: Republic of Dallas
Posts: 29,114
Total Cats: 351
Default

Seal 'em Freeze Plug
hustler is offline   Reply With Quote
Old 05-23-2011, 09:23 AM   #6
Boost Czar
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 72,895
Total Cats: 1,792
Default

black RTV is for oil. Ultra Grey is what you should have tried.

but it sounds like youre still pressurizing the coolant system and that's the weak link.
Braineack is online now   Reply With Quote
Old 05-23-2011, 02:17 PM   #7
Supporting Vendor
iTrader: (31)
 
Savington's Avatar
 
Join Date: Nov 2006
Location: Sunnyvale, CA
Posts: 14,367
Total Cats: 1,332
Default

Check for hydrocarbons in cooling system pleaze.
Savington is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Buzzing from driver side of engine bay? (MS3 install) nick470 MEGAsquirt 7 06-16-2017 02:53 PM
Back to Stock Part Out!! Turbo Parts, MS2 Enhanced 01-05, Suspension, and MOAR! StratoBlue1109 Miata parts for sale/trade 16 10-02-2015 10:39 AM
Bad head gasket or ? shooterschmidty Engine Performance 8 09-30-2015 11:28 PM
01-05 Fab9 PNP COPs (used) FrankB Miata parts for sale/trade 6 09-30-2015 12:48 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 01:17 PM.