04 MSM Cooling Fans (A/C Trigger fail) - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


General Miata Chat A place to talk about anything Miata

Reply
 
 
 
LinkBack Thread Tools
Old 05-24-2013, 11:33 AM   #1
Junior Member
Thread Starter
iTrader: (2)
 
Join Date: Apr 2008
Location: Gainesville, FL
Posts: 77
Total Cats: -2
Default 04 MSM Cooling Fans (A/C Trigger fail)

Okay, so a friend and myself just bought a 2004 MSM.

What we started with was a discharged A/C system - so we proceeded to search for a leak - replaced the two valve cores and filled the system with dye and refrigerant.

So, what we have now is an A/C system that turns on and operates (the magnetic clutch engages and the blower fan works, the A/C switch lights up green).

So - everything appears to be working, except the cooling fans do NOT come on.

The cooling fans do appear to come on for the coolant temp - but they do not acknowledge the A/C system being engaged.

We have tested everything we can come up with using ALLDATA. All the relays, switches, fuses, everything looks good.


Of course we are still studying and trouble shooting here, but any advice - idea's or knowledge of this problem would be super helpful!

We did test the A/C fan circuit coming from the PCM - and it looks like the PCM is sending out the signal for the fans to come on when the A/C is turned on, the signal just isn't reaching the fans.

I will update my post as we make progress, but this is a project we're working on at the autoshop between customers in downtime, so progress is slow.


P.S - I will be posting in the WTB section soon with a list of things we need for the car. Just for starters we're looking for both sun visors, and the stock Bose cd player/radio(silver 6 disc)
Turbobarber is offline   Reply With Quote
Old 05-24-2013, 11:36 AM   #2
Murderator
iTrader: (76)
 
18psi's Avatar
 
Join Date: Apr 2008
Posts: 36,199
Total Cats: 2,584
Default

have you tested the actual fan motor?
18psi is offline   Reply With Quote
Old 05-24-2013, 01:29 PM   #3
Junior Member
Thread Starter
iTrader: (2)
 
Join Date: Apr 2008
Location: Gainesville, FL
Posts: 77
Total Cats: -2
Default

Yes. The fan itself works It comes on with the coolant temp, but doesn't acknowledge when the AC system kicks on.
Turbobarber is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Expected intake temps on the track? tazswing Race Prep 20 10-03-2015 12:04 PM
Are my coils failing? viriiguy General Miata Chat 5 09-28-2015 08:39 PM
Another Alternator thread ihiryu General Miata Chat 9 09-28-2015 11:22 AM


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 04:19 AM.