Can anyone post a pic of a 94-95.5 coil harness plug? - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


General Miata Chat A place to talk about anything Miata

Reply
 
 
 
LinkBack Thread Tools
Old 12-15-2017, 11:29 PM   #1
Elite Member
Thread Starter
iTrader: (10)
 
IcantDo55's Avatar
 
Join Date: Apr 2007
Location: VA Beach
Posts: 1,775
Total Cats: 18
Default Can anyone post a pic of a 94-95.5 coil harness plug?

Can anyone post a pic of a 94-95.5 coil harness plug?
Is this it? Or is is 4 wire like the 4 pin plug on the coils?
I'm chasing an issue.
Attached Thumbnails
Can anyone post a pic of a 94-95.5 coil harness plug?-tach.jpg  
IcantDo55 is offline   Reply With Quote
Old 12-16-2017, 09:03 AM   #2
mkturbo.com
iTrader: (24)
 
shuiend's Avatar
 
Join Date: May 2006
Location: Charleston SC
Posts: 13,838
Total Cats: 1,134
Default

That is only 3 wire. 94-95.5 coil harness is 4 wire.
shuiend is online now   Reply With Quote
Old 12-16-2017, 01:45 PM   #3
Elite Member
Thread Starter
iTrader: (10)
 
IcantDo55's Avatar
 
Join Date: Apr 2007
Location: VA Beach
Posts: 1,775
Total Cats: 18
Default

Quote:
Originally Posted by shuiend View Post
That is only 3 wire. 94-95.5 coil harness is 4 wire.
Than how you explain this. Just got this all stock unmolested 95 that had a 4 pin coil pack. And that 3 wire plug plugged into it. It was built 3/95 so should be early 95 an a 4 wire configuration. Also there is no obd2 port under dash.

The issue is the car starts and runs for 2 seconds than dies. Dash shows no tach signal. I read that the 95 95.5 ECU shut down injectors in 2 seconds if it does not see a tach signal. So that sounds like my issue.
​​​​​Have tried....
2 CAS
2 ECMs
3 coils (2 4 pin and a 3 pin)
Fuel pressure is good and pump has been replaced.
Can be fed with eather and will run for ever on that.
IcantDo55 is offline   Reply With Quote
Old 12-16-2017, 01:51 PM   #4
Elite Member
Thread Starter
iTrader: (10)
 
IcantDo55's Avatar
 
Join Date: Apr 2007
Location: VA Beach
Posts: 1,775
Total Cats: 18
Default


Built 3/95
Should be obd1 right? Whats cut off in 1995?
IcantDo55 is offline   Reply With Quote
Old 12-16-2017, 02:08 PM   #5
Cpt. Slow
iTrader: (25)
 
curly's Avatar
 
Join Date: Oct 2005
Location: Oregon City, OR
Posts: 12,136
Total Cats: 522
Default

Quick search gave me this thread:

https://forum.miata.net/vb/showthread.php?t=251759

which says post vin 5130 (so yours) is obd2.
curly is offline   Reply With Quote
Old 12-16-2017, 02:16 PM   #6
Elite Member
Thread Starter
iTrader: (10)
 
IcantDo55's Avatar
 
Join Date: Apr 2007
Location: VA Beach
Posts: 1,775
Total Cats: 18
Default

Quote:
Originally Posted by curly View Post
Quick search gave me this thread:

https://forum.miata.net/vb/showthread.php?t=251759

which says post vin 5130 (so yours) is obd2.
Good find.
So who ever before me put wrong coil in it and wrong ECU......maybe.
Hope we on to something.this little issue getting old.
Time to search out a 3 pin coil and a 95.5 97 ECU.
Still does not explain why it has no OBD2 port.....
IcantDo55 is offline   Reply With Quote
Old 12-16-2017, 03:22 PM   #7
Boost Czar
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 73,139
Total Cats: 1,824
Default

96-97 harness is 3-plug.

looks like you have the wrong ECU:


Quote:
Early 95 BPL9 sub part number BPL9 18 881
95 1/2 BPL9 sub part number BPL9 18 881B

Not much different and hard to tell the difference, but they are not interchangeable. The BPL9 is set up for the 4 wire coil system and gets it's tach signal from the coil packs. The BPL9 B is set up for the 3 wire coil packs and gets it's tach signal from the cam angle sensor.
but if the ecu is driving the tach, that's not the reason it's not running. the car should run without a tach.


read from post #8: https://forum.miata.net/vb/showthread.php?t=372862


I would use diagram here:



and figure out every difference between the above and your actually wiring into the ECU -- then we can figure out how to make it work.
Braineack is offline   Reply With Quote
Old 12-16-2017, 11:12 PM   #8
Elite Member
Thread Starter
iTrader: (10)
 
IcantDo55's Avatar
 
Join Date: Apr 2007
Location: VA Beach
Posts: 1,775
Total Cats: 18
Default

Quote:
Originally Posted by Braineack View Post
96-97 harness is 3-plug.

looks like you have the wrong ECU:




but if the ecu is driving the tach, that's not the reason it's not running. the car should run without a tach.


read from post #8: https://forum.miata.net/vb/showthread.php?t=372862


I would use diagram here:



and figure out every difference between the above and your actually wiring into the ECU -- then we can figure out how to make it work.

Well good find. Checked and I think I have what is referred to as the OBD 1 1/2 model. 3 wire coil and no OBD2 port. Strange. I checked and its the wrong ECU and the wrong coil.
So looks like I need a BPL9-18-881B, I got a 3 wire coil here already.
Owe ya another beer sir.
IcantDo55 is offline   Reply With Quote
Old 12-17-2017, 11:05 AM   #9
Boost Czar
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 73,139
Total Cats: 1,824
Default

im sure you could re-pin harness for the few wire differences.
Braineack is offline   Reply With Quote
Old 12-31-2017, 01:18 PM   #10
Elite Member
Thread Starter
iTrader: (10)
 
IcantDo55's Avatar
 
Join Date: Apr 2007
Location: VA Beach
Posts: 1,775
Total Cats: 18
Default

Well for all you on the edge of your seats and the future searchers......here is the answer.
The 3/95 is a late model build. It uses what some refer to as a "OBD 1.5" it has one O2 sensor and no OBD2 port yet uses the 3 pin coil pack and a specific ECU with a "B" at the end of model number.
BPL9 sub part number BPL9 18 881B
So swapped in right ECU and right coil pack and it fired right up.

Thanks for all the help.

Anyone looking to buy a RUNNING 95 with 70K on it all stock. Clean.
IcantDo55 is offline   Reply With Quote
Old 12-31-2017, 01:18 PM   #11
Elite Member
Thread Starter
iTrader: (10)
 
IcantDo55's Avatar
 
Join Date: Apr 2007
Location: VA Beach
Posts: 1,775
Total Cats: 18
Default

Well for all you on the edge of your seats and the future searchers......here is the answer.
The 3/95 is a late model build. It uses what some refer to as a "OBD 1.5" it has one O2 sensor and no OBD2 port yet uses the 3 pin coil pack and a specific ECU with a "B" at the end of model number.
BPL9 sub part number BPL9 18 881B
So swapped in right ECU and right coil pack and it fired right up.

Thanks for all the help.

Anyone looking to buy a RUNNING 95 with 70K on it all stock. Clean.
IcantDo55 is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
[Fab9 Coil on Plug (COP) Kit] and [1999 OE Coil Pack and Wires] Carloverx Miata parts for sale/trade 15 01-13-2018 12:57 PM
Plug and Play coil on plug kit for a 90-93 Wade5k Miata parts for sale/trade 2 03-22-2017 09:44 AM
Plug and Play Toyota Coil-On-Plug Setup Savington Group Buys and Member Discounts 274 11-15-2014 11:01 PM
FS: 96/97 coil pack + coil harness plug orion4096 Miata parts for sale/trade 6 08-01-2010 09:44 PM
WTB: 94-95 coil pack harness plug orion4096 WTB 3 03-19-2010 06:18 PM


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 07:23 PM.