CEL code 18 - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


General Miata Chat A place to talk about anything Miata

Reply
 
 
 
LinkBack Thread Tools
Old 09-28-2007, 01:46 AM   #1
Senior Member
Thread Starter
iTrader: (7)
 
nicacus's Avatar
 
Join Date: Jul 2006
Location: SLC UT
Posts: 1,133
Total Cats: 0
Default CEL code 18

my check engine light doesnt come on, unless I put the engine into test mode.
I was adjusting my timing and noticed that my CEL was flashing.
I get one long light, then 8 short lights...
so code 18 right??
WTF is code 18?
the haynes manual doesnt have anything for a code 18
and no it is not a code 17, though that would make sense..
nicacus is offline   Reply With Quote
Old 09-28-2007, 09:58 AM   #2
Boost Czar
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 72,838
Total Cats: 1,787
Default

sure its not 1 and 8, or 10 and 8?

10 and 8 would make sense as they both deal with the AFM specifically
Braineack is offline   Reply With Quote
Old 09-29-2007, 05:00 AM   #3
Senior Member
Thread Starter
iTrader: (7)
 
nicacus's Avatar
 
Join Date: Jul 2006
Location: SLC UT
Posts: 1,133
Total Cats: 0
Default

I watched it repeat like 15 times.
one long light, then eight short.
I changed the 02 sensor for the hell of it (figured it wouldnt hurt) my a/f ratio is stoich at cruise and idle now, and it goes to 12.5 under boost, but my car shuts off if I go full throttle for more than 5 or 6 seconds.. would it have anything to do with that??
nicacus is offline   Reply With Quote
Old 09-29-2007, 03:39 PM   #4
Boost Czar
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 72,838
Total Cats: 1,787
Default

one long is 10, followed by 8 short could be 18 (but 18 is not a code)

so eight short will be simply code of 8.

10 is air intake sensor, so that specfically deals with your air flow meter.
8 is air flow sensor, so again the AFM is to blame.

had you ever tried starting the car with it remove accidently and the code stored? you wouldn't be able to drive the car without or with a failed one.

the problem you're having code very well be related to a bad AFM....

on a sidenote: your problem suggests starting a new thread.
Braineack is offline   Reply With Quote
Old 09-29-2007, 05:31 PM   #5
Senior Member
Thread Starter
iTrader: (7)
 
nicacus's Avatar
 
Join Date: Jul 2006
Location: SLC UT
Posts: 1,133
Total Cats: 0
Default

that would probably be it.. I started it with the AFM unplugged.. I will go clear it out and see if it comes back.

Thanks man...
nicacus is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Got bad Crank Angle Sensor and Random Misfire codes, but runs fine. Greasyman General Miata Chat 2 09-28-2015 11:44 AM
Help multi issues here! ReallyRottenTurbo MEGAsquirt 4 09-22-2015 01:49 PM
First to get it out of the way main Meet and Greet 2 09-05-2015 02:03 PM
First to get it out of the way main Meet and Greet 1 09-05-2015 01:39 PM
Okay, so it's not an O2 problem... bripab007 General Miata Chat 9 08-17-2007 10:35 AM


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 12:31 PM.