Electrical gremlin getting worse :( - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


General Miata Chat A place to talk about anything Miata

Reply
 
 
 
LinkBack Thread Tools
Old 11-30-2008, 08:28 PM   #1
Senior Member
Thread Starter
iTrader: (2)
 
Join Date: Jun 2006
Location: Springfield, NJ
Posts: 670
Total Cats: 0
Default Electrical gremlin getting worse :(

A few months ago my radio stopped working. Then the OEM keyless entry, interior overhead light, and OBD power (where I plug in my code scanner) all stopped working. Tonight, my windshield wipers and wiper clean fluid thingy also stopped working. Yet the car drives fine, headlights/taillights work, blinkers work, all gauges work, including the WB and my CB radio.

What the hell???

I don't have another car to drive to work, so I'm getting really worried now.
evank is offline   Reply With Quote
Old 11-30-2008, 08:52 PM   #2
Elite Member
iTrader: (15)
 
patsmx5's Avatar
 
Join Date: Aug 2007
Location: Houston, TX
Posts: 8,797
Total Cats: 248
Default

Trouble shoot the problem.
patsmx5 is offline   Reply With Quote
Old 11-30-2008, 08:58 PM   #3
Senior Member
Thread Starter
iTrader: (2)
 
Join Date: Jun 2006
Location: Springfield, NJ
Posts: 670
Total Cats: 0
Default

Gee, thanks....

Tomorrow I plan to disconnect the radio and check all the fuses. But all of these things are on different fuses; it's not like they would all spontaneously die. I would consider going to an auto electrical shop - just too concerned they'd go anyplace near the Megasquirt wiring (which works fine, for now...)
evank is offline   Reply With Quote
Old 11-30-2008, 09:01 PM   #4
Elite Member
iTrader: (15)
 
patsmx5's Avatar
 
Join Date: Aug 2007
Location: Houston, TX
Posts: 8,797
Total Cats: 248
Default

Trouble shoot the problem. Are you blowing fuses on the affected circuits? Would any of your aftermarket items happen to be wired into these affected circuits? IE-is the MS and CB wired into the windshield washer circuit and the UEGO wired into the interior light?
patsmx5 is offline   Reply With Quote
Old 11-30-2008, 09:10 PM   #5
Senior Member
Thread Starter
iTrader: (2)
 
Join Date: Jun 2006
Location: Springfield, NJ
Posts: 670
Total Cats: 0
Default

Yeah, I know what you meant, just expressing frustration .... sorry man.

CB is wired into the radio power, but it worked fine for a year before all this stuff happened. I forget where the WB gets power. MS - I'll let Paul answer that one.
evank is offline   Reply With Quote
Old 11-30-2008, 09:24 PM   #6
Elite Member
iTrader: (21)
 
paul's Avatar
 
Join Date: Jun 2006
Location: Point Pleasant, NJ
Posts: 2,957
Total Cats: 2
Default

well if they were tapped into those sources and caused the fuses to blow they wouldn't have power themselves so I'm gonna go ahead and rule that out.
paul is offline   Reply With Quote
Old 12-01-2008, 12:41 AM   #7
Elite Member
iTrader: (8)
 
Join Date: Oct 2007
Location: Dallas
Posts: 1,841
Total Cats: 0
Default

I hate electrical problems. It will make me sell a car.
I feel your pain. I'm trying to get fire to my plugs.
Toddcod is offline   Reply With Quote
Old 12-01-2008, 02:45 PM   #8
Senior Member
Thread Starter
iTrader: (2)
 
Join Date: Jun 2006
Location: Springfield, NJ
Posts: 670
Total Cats: 0
Default

Kind of funny ... the only "electrical gremlin" was my own stupidity.

- Radio not working is some undefined, unrelated problem
- Fuse for interior overhead light happened to blow (hopefully by coincidence, not by something * causing * it to blow)
- Mazda manual fails to mention in the owner's manual that the overhead light fuse ALSO controls the keyless entry :-)
- Wiper fuse was also blown. I replaced it, but when I pulled the washer fluid lever, it blew again! So I checked under the hood because I did remove the fluid bottle when I tightened the turbo outlet manifold bolt a couple of weeks ago. Truns out I forget to plug in the bottle's electrical connector .... which now was resting against something sharp and hot .... and probably short-circuited. So I have to fix that, but at least my wipers work as long as I don't pull the washer lever.
evank is offline   Reply With Quote
Old 12-01-2008, 03:49 PM   #9
Elite Member
iTrader: (15)
 
patsmx5's Avatar
 
Join Date: Aug 2007
Location: Houston, TX
Posts: 8,797
Total Cats: 248
Default

Quote:
Originally Posted by evank View Post
Kind of funny ... the only "electrical gremlin" was my own stupidity.
Huh. Would have never guessed. I was sure there was multiple issues with the factory wiring that had nothing to do with your intervention...
patsmx5 is offline   Reply With Quote
Old 12-01-2008, 03:55 PM   #10
Senior Member
Thread Starter
iTrader: (2)
 
Join Date: Jun 2006
Location: Springfield, NJ
Posts: 670
Total Cats: 0
Default

Quote:
Originally Posted by patsmx5 View Post
Huh. Would have never guessed. I was sure there was multiple issues with the factory wiring that had nothing to do with your intervention...
I have to admit, that was a good one. I absolutely recognize the humor in my initial overreaction to the "problem".
evank is offline   Reply With Quote
Old 12-01-2008, 07:59 PM   #11
Junior Member
iTrader: (3)
 
Join Date: Jul 2008
Location: Vancouver, B.C.
Posts: 112
Total Cats: 0
Default

Quote:
Originally Posted by Toddcod View Post
I hate electrical problems. It will make me sell a car.
I feel your pain. I'm trying to get fire to my plugs.
Extensive electrical issues are what finally made me sell my MGB. **** going over 4 miles of wire when the endpoints are fine.

When I first read the description I was thinking bad ground since car driving and WB etc working would point to the motor ground being alright but I can't remember now, lights are ground to the body at one common point arn't they?

Either way, good that it's fixed.
DragonsMaw is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Buzzing from driver side of engine bay? (MS3 install) nick470 MEGAsquirt 7 06-16-2017 02:53 PM
An Old Driver but a newbie in Miata Patriarca Meet and Greet 17 10-13-2015 02:34 PM
Complete BEGI S3 NB Kit, Full Enthuza 3" Exhaust, ACT HD Clutch, MS2 PNP, Wideband kronikker Miata parts for sale/trade 17 10-06-2015 11:18 PM
Old guy buys old Miata b&t Meet and Greet 3 09-22-2015 10:32 AM
Contradictory instructions Joe Perez Insert BS here 8 09-17-2015 11:33 AM


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 04:49 PM.