FM trailer hitch issue - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


General Miata Chat A place to talk about anything Miata

Reply
 
 
 
LinkBack Thread Tools
Old 03-15-2013, 09:44 PM   #1
Senior Member
Thread Starter
 
Join Date: Apr 2011
Location: Hollywood, FL
Posts: 525
Total Cats: 18
Default FM trailer hitch issue

Hey guys, anyone install a trailer hitch from FM? Am I not noticing something or are they making me drill new holes in the frame to attach the hitch? It says in the instructions that I need to drill out the existing factory "nutserts" that hold the tow hooks in place which I did. But when I went to bolt it up the pattern is not the same. Not even close actually. Drilling new holes would solve the issue but the pictures they provide online and in the instructions dont lead me to believe that. Tried calling them but they are closed for the weekend. Anyone know off hand if they sent me the wrong part or did they update the part and not the instructions? The car is a 95 and it what ordered for a 95 in case you are wondering.
hector is offline   Reply With Quote
Old 03-16-2013, 01:03 AM   #2
Newb
 
Join Date: Nov 2012
Posts: 5
Total Cats: 0
Default

Mine bolted up fine. I did have to drill out the nuts in the frame on the passenger side. Drivers side was fine though.

Can you post pictures?
wdd1040 is offline   Reply With Quote
Old 03-16-2013, 10:45 AM   #3
Senior Member
Thread Starter
 
Join Date: Apr 2011
Location: Hollywood, FL
Posts: 525
Total Cats: 18
Default

The more I think about it the more I believe they sent me a hitch for a NB which has the tow hooks on the back part of the bumper. Looking at the NB picture onlin of their hitch it looks more like what they sent me. In the instructions for the NA it says you wont use the top stud of the tow hook, just the lower one and the two threaded nut holes which you have to drill out. Well what they sent will bolt up to one of said fasteners they refer to in the instructions. So unless they changed the design, they sent me the wrong part.
Attached Thumbnails
FM trailer hitch issue-20130316_093410.jpg  
hector is offline   Reply With Quote
Old 03-16-2013, 10:54 AM   #4
Newb
 
Join Date: Nov 2012
Posts: 5
Total Cats: 0
Default

Yup. Definitely something wrong with that hitch.
wdd1040 is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Raleigh: Fiberglass headlight scope, 1.6L ECU, AFM, Hardtop latches, more bigmackloud Miata parts for sale/trade 13 09-22-2017 01:34 PM
Bizarre connection issue? nick470 MEGAsquirt 1 09-30-2015 11:32 PM
Bad head gasket or ? shooterschmidty Engine Performance 8 09-30-2015 11:28 PM
Odd Steering issue interestedofold Suspension, Brakes, Drivetrain 5 09-29-2015 02:42 PM


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 09:47 PM.