Idle Issue - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


General Miata Chat A place to talk about anything Miata

Reply
 
 
 
LinkBack Thread Tools
Old 09-11-2007, 01:27 AM   #1
Junior Member
Thread Starter
 
Join Date: Apr 2007
Posts: 46
Total Cats: 0
Default Idle Issue

Problem: Car barley idles, then shuts off, unless I continously give it gas. Backfires like crazy.

Attempted: Installed new Mass Air Meter

Just realized: Oil all over spark plugs/wires.

Could a bad valve cover gasket be the root of my problem? Or does the problem seem to go deeper than that?
350drft is offline   Reply With Quote
Old 09-11-2007, 01:09 PM   #2
Newb
 
Join Date: Dec 2005
Location: San Antonio
Posts: 29
Total Cats: 0
Default

Start with a new valve cover gasket. The oil on the plugs and wires will cause all kinds of issues to include degradation of the insulation. So long as you have it apart, it might be a good time to replace the plugs (cheap fix) and possibly the wires (depending upon how long they've been on the car).

Barry
BEGITechRep is offline   Reply With Quote
Old 09-11-2007, 02:23 PM   #3
Elite Member
iTrader: (3)
 
Join Date: May 2006
Location: Houston, TX
Posts: 2,900
Total Cats: 0
Default

This could be a number of things... the oil on the plugs may not be directly related to you root cause. Things to check.

1) Vacuum (may be a leak, but this test can also tell you if it's cam timing)
2) Cat (knock it with a rubber mallet and see if it rattles...)
3) Fuel Filter
4) Timing
5) Cam timing (gunna have to take the valve cover off to do it properly)
6) Compression

In that order. I've seen miatas with god awful compression on all 4 cylinders idle perfectly smooth... so that's really not likely.

Got any more details for us on how this started? Slowly/suddenly, after a boosted run @100 mph, etc. Any additional info you can give will help narrow down the search.
Arkmage is offline   Reply With Quote
Old 09-11-2007, 03:49 PM   #4
Elite Member
iTrader: (2)
 
Join Date: Jan 2007
Location: Lexington, SC
Posts: 2,084
Total Cats: 0
Default

why did you install a new mass air meter? that might be your problem too.
mazda/nissan is offline   Reply With Quote
Old 09-17-2007, 01:02 AM   #5
Junior Member
Thread Starter
 
Join Date: Apr 2007
Posts: 46
Total Cats: 0
Default

I tried a new mass air meter/ sensor becuase I figured the old one might be shot-not the case. I ordered a new valve cover gasket, lets see if this remedies the problem.
350drft is offline   Reply With Quote
Old 09-17-2007, 02:08 AM   #6
Senior Member
iTrader: (1)
 
Join Date: Dec 2005
Location: irvine, ca
Posts: 729
Total Cats: 0
Default

vc gasket and plug wires.
kung fu jesus is offline   Reply With Quote
Old 09-17-2007, 02:09 AM   #7
Elite Member
iTrader: (15)
 
patsmx5's Avatar
 
Join Date: Aug 2007
Location: Houston, TX
Posts: 8,797
Total Cats: 248
Default

yea, my valve cover gasket leaks too. When I get around 1" of oil in their, it starts missfiring. It's not enough to cause a check engine light, but it will run like hell till i fix it.
patsmx5 is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Back to Stock Part Out!! Turbo Parts, MS2 Enhanced 01-05, Suspension, and MOAR! StratoBlue1109 Miata parts for sale/trade 16 10-02-2015 10:39 AM
Time to start learning and play with tuning The Gleas MEGAsquirt 3 10-01-2015 10:30 AM
Bizarre connection issue? nick470 MEGAsquirt 1 09-30-2015 11:32 PM
Low oil pressure after 1.8 swap and new turbo setup JesseTheNoob DIY Turbo Discussion 15 09-30-2015 03:44 PM
Odd Steering issue interestedofold Suspension, Brakes, Drivetrain 5 09-29-2015 02:42 PM


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 12:22 PM.