New injectors in, now I have rich idle and clicking sounds. - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


General Miata Chat A place to talk about anything Miata

Reply
 
 
 
LinkBack Thread Tools
Old 06-29-2010, 06:03 PM   #1
Want fries with that?
Thread Starter
iTrader: (3)
 
Join Date: Oct 2009
Location: Twin Cities, Minnesota
Posts: 2,023
Total Cats: -1
Default New injectors in, now I have rich idle and clicking sounds.

I'm not to worried about the clicking sounds; I heard somewhere that it's normal with bigger injectors, but I thought I'd ask.

However, I've suddenly gone to ~11/12:1 at idle according to my LC1. If I hit the gas at all, it shoots back up to where it should be. (Around 15:1). What could be causing this? I used the TunertstudioMS required fuel calculator and burned it into the MS before I started. Should I not have used the calc?

Injectors are RX7 460ccs.
rider384 is offline   Reply With Quote
Old 06-29-2010, 06:11 PM   #2
Senior Member
iTrader: (4)
 
Join Date: Jan 2008
Location: Falls Church, VA
Posts: 1,367
Total Cats: 16
Default

The calculator gets you close but it's normal to still have to retune a bit.
ScottFW is offline   Reply With Quote
Old 06-29-2010, 06:14 PM   #3
Want fries with that?
Thread Starter
iTrader: (3)
 
Join Date: Oct 2009
Location: Twin Cities, Minnesota
Posts: 2,023
Total Cats: -1
Default

I wish I had a seatbelt so I could testdrive.
rider384 is offline   Reply With Quote
Old 06-29-2010, 09:16 PM   #4
Elite Member
iTrader: (13)
 
Join Date: Dec 2006
Location: Taos, New mexico
Posts: 5,703
Total Cats: 237
Default

Tune the idle cells.

Injector "clicking" is normal. Between injector and lifter tick on my car with an open hood it sounds like a time bomb. Which is probably is .
Fireindc is online now   Reply With Quote
Old 06-29-2010, 11:31 PM   #5
Elite Member
iTrader: (17)
 
Join Date: May 2007
Location: NY
Posts: 1,614
Total Cats: 2
Default

^good one, I lol'd a lil
TonyV is offline   Reply With Quote
Old 06-29-2010, 11:52 PM   #6
Want fries with that?
Thread Starter
iTrader: (3)
 
Join Date: Oct 2009
Location: Twin Cities, Minnesota
Posts: 2,023
Total Cats: -1
Default

Richness is fixed, my warmup settings got fucked up so it was constantly running warmup mode.

Taping noise is, I guess, normal

Also: VE Analyze live is ******* ****.
rider384 is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Project Gemini - Turbo Civic on the Cheap Full_Tilt_Boogie Build Threads 59 12-15-2017 09:00 PM
Changing from 460cc to flow force 610cc in diypnp 90 Turbo MEGAsquirt 19 10-19-2015 04:23 PM
Back to Stock Part Out!! Turbo Parts, MS2 Enhanced 01-05, Suspension, and MOAR! StratoBlue1109 Miata parts for sale/trade 16 10-02-2015 10:39 AM
Going back to stock. Need some 1.6 parts. Trent WTB 2 10-01-2015 01:15 PM
Time to start learning and play with tuning The Gleas MEGAsquirt 3 10-01-2015 10:30 AM


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 07:37 PM.