no spark - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


General Miata Chat A place to talk about anything Miata

Reply
 
 
 
LinkBack Thread Tools
Old 03-03-2013, 06:16 PM   #1
Newb
Thread Starter
 
Join Date: Mar 2013
Posts: 4
Total Cats: -7
Default no spark

ok so i have a 1990 miata has megasquirt pnp a turbo ok so my friend was driving it and it died so i towed it home checked some stuff out fuel pump is running plugs get wet no spark weird thing is that when i turn the key to on i get a spark and when i turn it to start and the engine cranks i get no spark so i checked out the ignition switch all is good cleaned it works figured it was the cas so i replaced it nothing changed checked all the relays all click and work unplugged igniter to see if the inital spark goes away and it dose so i figure that the igniter is fine it seems to me that the ecu is not getting the signal to fire the plugs im so confused some one help me out
hurleyed is offline   Reply With Quote
Old 03-03-2013, 06:42 PM   #2
Senior Member
 
Join Date: Aug 2010
Location: Arl. Texas
Posts: 937
Total Cats: 23
Default

Try, . ? !
Miater is offline   Reply With Quote
Old 03-04-2013, 01:40 PM   #3
Junior Member
 
Join Date: Mar 2012
Posts: 322
Total Cats: 23
Default

Quote:
Originally Posted by Miater View Post
Try, . ? !
Seriously, I couldn't follow that..
M.Adamovits is offline   Reply With Quote
Old 03-04-2013, 01:42 PM   #4
Boost Czar
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 72,900
Total Cats: 1,792
Default

actually, try:

try: ., ?, and !
Braineack is offline   Reply With Quote
Old 03-04-2013, 01:45 PM   #5
Elite Member
iTrader: (2)
 
Join Date: Aug 2012
Location: Indianapolis
Posts: 3,325
Total Cats: 235
Default

I took a deep breath when I was done because I imagined someone saying that all in one breath.
thenuge26 is offline   Reply With Quote
Old 03-07-2013, 11:43 PM   #6
Newb
Thread Starter
 
Join Date: Mar 2013
Posts: 4
Total Cats: -7
Default

wow really big help didnt no this was an english class
hurleyed is offline   Reply With Quote
Old 03-08-2013, 12:06 AM   #7
Newb
Thread Starter
 
Join Date: Mar 2013
Posts: 4
Total Cats: -7
Default

ok, so i figured out what was wrong. I have a MSD boost controller hooked up to my car and one of the capacitors fried in the circuit board. Upon closer inspection the vacume line that is supposed to hook up to the controller was capped and not plugged in. The car ran fine like that, im guessing because i have mega squirt pnp. so my question now is dose megasquirt retard the timing for the boost? or is the msd controller supposed to do that and if so how if it ran fine without it plugged into the vacuum? Isn't the vacuum line supposed to tell the controller when to retard the timing. anyway car starts and runs but the timing is messed up because i pulled the cas and put a different one in it. but as far as this post is looking dose not look like anyone is going to help because of their egos are to big for this post. so im wasting my time i guess but thats how these forums work hey. People are all I no more than you do nana nana boo boo
hurleyed is offline   Reply With Quote
Old 03-24-2013, 12:17 AM   #8
Newb
Thread Starter
 
Join Date: Mar 2013
Posts: 4
Total Cats: -7
Default

i fixed it and it runs awesome time to drift
hurleyed is offline   Reply With Quote
Old 03-24-2013, 12:36 AM   #9
Murderator
iTrader: (76)
 
18psi's Avatar
 
Join Date: Apr 2008
Posts: 36,206
Total Cats: 2,587
Default

please drift into a wall
18psi is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
FS/FT: 03.5 Mazdaspeed Protege leatherface24 Cars for sale/trade 15 10-16-2015 12:35 PM
Time to start learning and play with tuning The Gleas MEGAsquirt 3 10-01-2015 10:30 AM
01-05 Fab9 PNP COPs (used) FrankB Miata parts for sale/trade 6 09-30-2015 12:48 PM
In need of AEM guidance W/pics E=MC^2 AEM 1 09-17-2015 01:34 PM
Obligatory "N00B" post! D_Breezy Meet and Greet 5 09-08-2015 06:37 PM


Tags
no spark dead

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 05:26 AM.