Question for those running 550cc RC Injectors - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


General Miata Chat A place to talk about anything Miata

Reply
 
 
 
LinkBack Thread Tools
Old 05-26-2009, 05:38 PM   #1
Junior Member
Thread Starter
iTrader: (4)
 
Join Date: Dec 2007
Location: Minneapolis
Posts: 415
Total Cats: 0
Default Question for those running 550cc RC Injectors

I have been fighting a vacuum leak with my Hydra install in my '01. The car idles/surges between 1800 and 2000 RPM.

I was pretty sure the leak was with the injectors so I pulled the 550's, put in the stock injectors and plugged the stock ECU back in and the car idles fine.

I measured the RC pintle and it is about .020 smaller than the stock injectors and the insulator is loose enough that it falls off with a gentle shake.

Attached is a pic of a 550cc RX 7 injector I plan to put in my 94 compared to the RC 550cc injector I am putting in my '01. You can see the diamter of the pintle on the RX7 injector is .375, same as stock, and it is .355 on the RC injector.

Have any of you had issues getting the RC injector to seat properly? I'm thinking about putting a small o-ring on and then putting on the insulator to see if I get a better seal.
Attached Thumbnails
Question for those running 550cc RC Injectors-rc-injector.jpg  
Scuba_Steve is offline   Reply With Quote
Old 05-26-2009, 06:50 PM   #2
Junior Member
iTrader: (12)
 
Join Date: Sep 2008
Location: Inland Empire So-Cal
Posts: 274
Total Cats: 0
Default

Quote:
Originally Posted by Scuba_Steve View Post
I have been fighting a vacuum leak with my Hydra install in my '01. The car idles/surges between 1800 and 2000 RPM.

I was pretty sure the leak was with the injectors so I pulled the 550's, put in the stock injectors and plugged the stock ECU back in and the car idles fine.

I measured the RC pintle and it is about .020 smaller than the stock injectors and the insulator is loose enough that it falls off with a gentle shake.

Attached is a pic of a 550cc RX 7 injector I plan to put in my 94 compared to the RC 550cc injector I am putting in my '01. You can see the diamter of the pintle on the RX7 injector is .375, same as stock, and it is .355 on the RC injector.

Have any of you had issues getting the RC injector to seat properly? I'm thinking about putting a small o-ring on and then putting on the insulator to see if I get a better seal.
try using various o-rings to make it snug..
james399 is offline   Reply With Quote
Old 05-26-2009, 10:05 PM   #3
Senior Member
iTrader: (10)
 
Join Date: Feb 2007
Location: South Eastern Wisconsin
Posts: 1,282
Total Cats: 0
Default

I used two O-rings per injector and used two washers to lower the rail to get my RC550s to seal, but they are a tight fit now. They would not seal with the factory seals. I'll try to see if I can find the part number for the o-rings I bought.
ApexOnYou is offline   Reply With Quote
Old 05-26-2009, 10:26 PM   #4
Junior Member
Thread Starter
iTrader: (4)
 
Join Date: Dec 2007
Location: Minneapolis
Posts: 415
Total Cats: 0
Default

Quote:
Originally Posted by ApexOnYou View Post
I used two O-rings per injector and used two washers to lower the rail to get my RC550s to seal, but they are a tight fit now. They would not seal with the factory seals. I'll try to see if I can find the part number for the o-rings I bought.
Thank you, this is exactly the advice I am looking for. If you can find part numbers, that would be great.

When you say two o-rings and two washers, I assume the o-rings went on the pintle before the insulator, or was that instead of the insulator? I'm not sure what you mean by two washers. My fuel rail seams to seal tight against the o-ring on top of the injectors.
Scuba_Steve is offline   Reply With Quote
Old 05-26-2009, 10:50 PM   #5
Senior Member
iTrader: (3)
 
Join Date: Aug 2005
Location: Gig Harbor, WA
Posts: 504
Total Cats: 3
Default

The FM install instructions show using 2 o-rings instead of the insulator. Its in their turbo install instructions.
TurboRoach is offline   Reply With Quote
Old 05-27-2009, 05:02 PM   #6
Elite AbsurdFlow Member
 
Laur3ns's Avatar
 
Join Date: Mar 2008
Location: Enschede, NL
Posts: 2,058
Total Cats: 11
Default

I run RC 550s, do I have a leak possibly? I used the BEGI RC kit...
Laur3ns is offline   Reply With Quote
Old 05-27-2009, 06:42 PM   #7
Junior Member
Thread Starter
iTrader: (4)
 
Join Date: Dec 2007
Location: Minneapolis
Posts: 415
Total Cats: 0
Default

Quote:
Originally Posted by TurboRoach View Post
The FM install instructions show using 2 o-rings instead of the insulator. Its in their turbo install instructions.
Actually they have a picture illustrating the use of two o-rings, which according to the instructions can be used if the OEM inulators are shot. FM uses the OEM insulators according to my conversation with Jeremy.

I did try the two ford o-rings and still had the leak, although I may have used the wrong size. Hopefully Apex-on-You can provide the correct part nbumber.

Quote:
Originally Posted by Spookyfish View Post
I run RC 550s, do I have a leak possibly? I used the BEGI RC kit...
Are you having issues, or just asking based on my post? If you car is running fine, you probably have no issue and I wouldn't worry about it. If you are having idle issues, it is a possibility. One way to check is to Carb Cleaner at the base of the injector, if your idle changes you have a leak.
Scuba_Steve is offline   Reply With Quote
Old 05-27-2009, 06:48 PM   #8
Elite Member
iTrader: (8)
 
Join Date: Oct 2007
Location: Dallas
Posts: 1,841
Total Cats: 0
Default

Quote:
Originally Posted by Spookyfish View Post
I run RC 550s, do I have a leak possibly? I used the BEGI RC kit...
Is your car idling fine, do you see gas around the injectors?
Toddcod is offline   Reply With Quote
Old 05-28-2009, 02:53 AM   #9
Senior Member
iTrader: (10)
 
Join Date: Feb 2007
Location: South Eastern Wisconsin
Posts: 1,282
Total Cats: 0
Default

Quote:
Originally Posted by Scuba_Steve View Post
Thank you, this is exactly the advice I am looking for. If you can find part numbers, that would be great.

When you say two o-rings and two washers, I assume the o-rings went on the pintle before the insulator, or was that instead of the insulator? I'm not sure what you mean by two washers. My fuel rail seams to seal tight against the o-ring on top of the injectors.
Sorry, I haven't had time to grab the box with the part number from the shop, I should be able to make it over there tomorrow.

I used two o-rings in place of the insulator - I did not reuse the factory seal/insulator. The two washers (x3) replaced the plastic fuel rail spacers that are sandwiched between the rail and the manifold, with the mounting bolts running through. That lowered the rail, with the factory spacers the injectors could move up and down and would not seal. I assumed the NB uses the same mounting location?
ApexOnYou is offline   Reply With Quote
Old 05-28-2009, 09:02 AM   #10
Elite AbsurdFlow Member
 
Laur3ns's Avatar
 
Join Date: Mar 2008
Location: Enschede, NL
Posts: 2,058
Total Cats: 11
Default

Quote:
Originally Posted by Toddcod View Post
Is your car idling fine, do you see gas around the injectors?
Idles ok normally, not always
I was in fact asking based on the first post.
Laur3ns is offline   Reply With Quote
Old 05-29-2009, 01:47 AM   #11
Senior Member
iTrader: (10)
 
Join Date: Feb 2007
Location: South Eastern Wisconsin
Posts: 1,282
Total Cats: 0
Default

Found the part number if you still need it - NAPA # 2-12093 / V07186. You'll need eight total, two per injector.
ApexOnYou is offline   Reply With Quote
Old 05-29-2009, 03:23 PM   #12
Former Vendor
 
Join Date: Jun 2006
Location: Bell Tuning & Performance
Posts: 1,338
Total Cats: -78
Default

We use Napa p/n 2-12076. Need 4 of them. I re-used the stock seals on my car with no problem, the first time. They have subsequently been changed to the Napa p/n.

If the leak is not at the injector, try your idle air controller.
Stephanie
Stephanie Turner is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
3rd Time's a Charm...hopefully. zephyrusaurai Meet and Greet 2 09-28-2015 11:59 PM
wiring wideband ground to battery terminal btabor ECUs and Tuning 10 09-28-2015 06:33 PM
VR6 to Miata Swap ScrapinMX5 Meet and Greet 8 09-28-2015 02:04 PM
Another Alternator thread ihiryu General Miata Chat 9 09-28-2015 11:22 AM
BP-6D on CAS only aidandj MEGAsquirt 14 09-25-2015 06:26 PM


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 04:11 PM.