Turbo Miata stutters at 4500-5k rpm, then pushes through and hits full boost - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


General Miata Chat A place to talk about anything Miata

Reply
 
 
 
LinkBack Thread Tools
Old 06-09-2016, 03:07 AM   #1
Junior Member
Thread Starter
 
Join Date: Dec 2011
Location: Seattle, WA
Posts: 102
Total Cats: 5
Default Turbo Miata stutters at 4500-5k rpm, then pushes through and hits full boost

Hello, I have a turbo 93 LE Miata with a built 94 1.8L motor. I've got a FM big fuel kit, and ID1000 injectors and Toyota COPs. I'm using a MSPNP pro. When I hit 4500 rpm I get a stutter, almost like my car is hitting launch control. If I stay steady on the throttle it will usually just keep hitting the stutter, however if i give it more throttle, it will eventually break through the stutter and immediately hit 14# of boost. If I am very light on the throttle, I can rev the motor without hitting the stutter. I have had a buddy look at my fuel map and my timing table, and he said they both looked fine to him. I even had him straighten out my map, however when I put the car on autotune, it develops a spike on the 3d fuel map. No matter what I do, the autotune keeps making the spike at 4500rpm. My AFR reads rich around 10 once it starts building boost at about 3500 RPM. It then reads really lean, about 16, once the stutter starts. Then once it pushes through, the AFR returns to being rich.

Any ideas what I might be causing what I am experiencing? I've done lots of searching for threads where people had similar issues, but keep coming to the same ones. Ive checked my grounds, replaced my COPs, replaced my spark plugs, checked my timing, I've tried gapping my plugs as low as .020. Nothing I do seems to make a difference.
alienmiata1 is offline   Reply With Quote
Old 06-09-2016, 04:06 AM   #2
Junior Member
iTrader: (2)
 
Join Date: Mar 2008
Location: Navarre, Fl
Posts: 203
Total Cats: 3
Default

I had a similar issue. It turned out to be vics control. Just a guess.
ericsbestshot is offline   Reply With Quote
Old 06-12-2016, 05:11 PM   #3
Junior Member
Thread Starter
 
Join Date: Dec 2011
Location: Seattle, WA
Posts: 102
Total Cats: 5
Default

I'm not really sure where I would find the VICS control. I don't think my car has VICS. Where would I find the settings at?
alienmiata1 is offline   Reply With Quote
Old 06-12-2016, 05:17 PM   #4
Boost Czar
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 72,892
Total Cats: 1,792
Default

you dont have a 99-00...
Braineack is offline   Reply With Quote
Old 06-12-2016, 06:00 PM   #5
Junior Member
Thread Starter
 
Join Date: Dec 2011
Location: Seattle, WA
Posts: 102
Total Cats: 5
Default

that's what I was thinking... Here is a log I took of a pull
Attached Files
File Type: msl 2016-05-22_16.53.14.msl 2.msl (416.2 KB, 32 views)
alienmiata1 is offline   Reply With Quote
Old 06-12-2016, 06:12 PM   #6
Elite Member
iTrader: (6)
 
Join Date: Feb 2013
Location: Staunton, Va
Posts: 2,407
Total Cats: 200
Default

Is it launch control? Goes lean, then stutters. Sounds like launch control.
ryansmoneypit is offline   Reply With Quote
Old 06-12-2016, 06:21 PM   #7
Junior Member
Thread Starter
 
Join Date: Dec 2011
Location: Seattle, WA
Posts: 102
Total Cats: 5
Default

It feels like launch control, but launch control is off
alienmiata1 is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Fuel Injector Clinic 900cc injectors TheProfessor Miata parts for sale/trade 9 06-09-2016 01:47 AM
cam signal error causing timing error/cut out Darbymx5 AEM 5 06-07-2016 04:11 PM
Rev MS3Enhanced, MSM, first run issues TheIglu MEGAsquirt 25 06-07-2016 11:43 AM
MS3Basic continuous fuel pump priming albumleaf MEGAsquirt 1 06-04-2016 09:11 PM
Cold air intake - running rich on de-throttle adryargument Engine Performance 2 06-02-2016 09:17 PM


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 07:32 AM.