weird dash problem - please help - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


General Miata Chat A place to talk about anything Miata

Reply
 
 
 
LinkBack Thread Tools
Old 02-27-2008, 11:30 PM   #1
Junior Member
Thread Starter
 
Join Date: Dec 2007
Location: Indianapolis
Posts: 167
Total Cats: 0
Default weird dash problem - please help

I put a smaller steering wheel on last week, it doesnt have an airbag. Since then my airbag light has been blinking on and off.
10 minutes ago I started my car, (an alarm goes off, I guess from the airbag???) rpms went up and suddenly down and stayed down. Tach is not working anymore, turn signals dont work, water and oil temp dont work and airbag light does not work anymore. The only gauges that work are the speed and fuel.
WTF???????
90turboMX5 is offline   Reply With Quote
Old 02-27-2008, 11:46 PM   #2
Elite Member
iTrader: (15)
 
patsmx5's Avatar
 
Join Date: Aug 2007
Location: Houston, TX
Posts: 8,796
Total Cats: 247
Default

Check the fuses.
patsmx5 is online now   Reply With Quote
Old 02-28-2008, 01:41 AM   #3
:(
iTrader: (7)
 
Join Date: Jul 2006
Location: nowhere
Posts: 8,281
Total Cats: 2
Default

Ignitor going bad or a bad dash fuse, also the airbag light fails in the full on position.
magnamx-5 is offline   Reply With Quote
Old 02-28-2008, 08:05 PM   #4
Junior Member
Thread Starter
 
Join Date: Dec 2007
Location: Indianapolis
Posts: 167
Total Cats: 0
Default

I changed the fuse and it got fixed but after 5 minutes it blew again. So I took the steering wheel off and this time followed the spring adjustment directions, I also unplugged the airbag and horn wires from the connector below the steering column, changed the fuse and it worked for 2 minutes and blew again.
I'm pretty sure I messed up the spring, can I just take it off or do I need a new one?
90turboMX5 is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
My solution for Oiltemp and Oilpressure input into Megasuirt (MS3) Zaphod MEGAsquirt 41 01-24-2016 01:25 PM
Leaky Wilwoods mx592 Suspension, Brakes, Drivetrain 1 10-01-2015 01:45 AM
Bizarre connection issue? nick470 MEGAsquirt 1 09-30-2015 11:32 PM
Odd Steering issue interestedofold Suspension, Brakes, Drivetrain 5 09-29-2015 02:42 PM
Are my coils failing? viriiguy General Miata Chat 5 09-28-2015 08:39 PM


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 01:03 AM.