What engine oil do YOU use? - Page 10 - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


General Miata Chat A place to talk about anything Miata

Reply
 
 
 
LinkBack Thread Tools
Old 06-30-2009, 07:07 PM   #181
Senior Member
iTrader: (1)
 
Join Date: May 2008
Location: south texas
Posts: 1,419
Total Cats: 9
Default

i noticed that recently. but i have been using the same oil. what has changed was the oil filter i was running. i have to use a certain filter due to the sandwich adapter plate that's connected to my oil cooler. the co. i was buying them from recently changed the filter (different part #) i think it no longer has an anti-drain back valve. i can restart the motor within a few minutes of turning it off and it registers on the gauge immediately. but if i start it cold (in the morning) or after a few hours parked, it takes a few seconds to show on the oil gauge.
spoolin2bars is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Project Gemini - Turbo Civic on the Cheap Full_Tilt_Boogie Build Threads 59 12-15-2017 09:00 PM
OTS Bilstein to motorsports ASN conversion stoves Suspension, Brakes, Drivetrain 5 04-21-2016 04:00 PM
Changing from 460cc to flow force 610cc in diypnp 90 Turbo MEGAsquirt 19 10-19-2015 04:23 PM
Expected intake temps on the track? tazswing Race Prep 20 10-03-2015 12:04 PM
Moroso Air Oil Separator Catch Can Aroundcorner Miata parts for sale/trade 2 10-01-2015 04:20 PM


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 11:10 AM.