Wierd Misfire/backfire question.... - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


General Miata Chat A place to talk about anything Miata

Reply
 
 
 
LinkBack Thread Tools
Old 02-05-2007, 03:12 AM   #1
I'm Miserable!
Thread Starter
 
Join Date: Oct 2005
Posts: 83
Total Cats: 0
Default Wierd Misfire/backfire question....

I have a 1990 FM2 kit and when i put it past 9-10 psi at WOT the whole car studders and makes a light poping noise. Its almost would feel ike if the car stalls for a split second. If i give it half throttle it doesent do it no matter what psi im at. The higher the RPM the worse/easier it is for it to happen. This happened like 4-5 months ago and i changed my spark plus wires and it went away, now its back. Any ideas?
Cheesefries is offline   Reply With Quote
Old 02-05-2007, 03:26 AM   #2
:(
iTrader: (7)
 
Join Date: Jul 2006
Location: nowhere
Posts: 8,281
Total Cats: 2
Default

coils fueling what does your wideband say? Have you been over your grounds?
magnamx-5 is offline   Reply With Quote
Old 02-05-2007, 08:56 AM   #3
AFM Crusader
iTrader: (18)
 
olderguy's Avatar
 
Join Date: Oct 2004
Location: Wayne, NJ
Posts: 4,438
Total Cats: 84
Default

AFM brushes
olderguy is offline   Reply With Quote
Old 02-05-2007, 09:29 AM   #4
Senior Member
iTrader: (1)
 
Join Date: Sep 2006
Location: Hong Kong
Posts: 523
Total Cats: 0
Default

It should be an OVER FUELING problem... just the matter of finding what's leading to your over fueling!! O2 Sensor? AFM brushes comment by Olderguy? Overlapping FMU ( like myself) haha!
Mimime is offline   Reply With Quote
Old 02-05-2007, 10:02 AM   #5
Elite Member
iTrader: (2)
 
Newbsauce's Avatar
 
Join Date: Jul 2006
Location: NoVA
Posts: 2,304
Total Cats: 2
Default

That happened to me when I was running out of fuel before (my pump died).... what kind of fuel setup do you have? Does it happen running full throttle at 8psi for example?
Newbsauce is offline   Reply With Quote
Old 02-05-2007, 10:19 AM   #6
Senior Member
 
steelrat's Avatar
 
Join Date: Jul 2005
Posts: 514
Total Cats: 0
Default

When the FP died in my car, on the way home from the track, the car would feel like it was going to stall. Kept it out of boost... but all of a sudden, no power. AFR gauge would go "black"....

Swapped out the FP for a 255 walbro... and it was all good. No poping or anything....

Popping sounds like silly rich.....

Dave,
steelrat is offline   Reply With Quote
Old 02-05-2007, 12:00 PM   #7
Junior Member
 
Join Date: Jun 2005
Posts: 52
Total Cats: 0
Default

FM2....datalog the Link and send it to us or FM.
13inches is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Confusing boost creep Sentic DIY Turbo Discussion 7 10-14-2013 05:37 PM
Wierd spool issue. Sentic DIY Turbo Discussion 7 10-17-2012 11:45 AM
Wierd noise at 6psi 90 Turbo General Miata Chat 9 11-02-2011 02:38 PM
engine acting wierd over 5psi.....Fuel or spark? p51hellfire Engine Performance 15 12-29-2010 12:10 AM
My FM2 is at 9psi...no matter what i do,i think i blew my turbo real wierd situation Cheesefries DIY Turbo Discussion 8 10-23-2006 08:49 PM


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 12:48 AM.