Woe is me... NA '90 fires up then dies, self inflicted... - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


General Miata Chat A place to talk about anything Miata

Reply
 
 
 
LinkBack Thread Tools
Old 08-13-2012, 05:49 PM   #1
Newb
Thread Starter
 
Join Date: Apr 2011
Posts: 28
Total Cats: 0
Default Woe is me... NA '90 fires up then dies, self inflicted...

I've got a 1990 Eunos Roadster 1.6, brief history is; bought as a clean non turbo to house my recently acquired Greddy TD05 turbo engine (stock 1.6, intercooler, FPR, retarded ignition, stock ECU). I chucked the turbo bits in and got it running at 6psi. All hanky dorey...

Bought a built DIY MS2 off ebay, got the car running badly, messed about with a few settings (didn't drive it), realised I'm way out of my depth, removed the MS to chuck standard parts back on and now it's not having any of it! Will fire up after cranking, run for a second or 2 then cut out. Chucked the MS back on and that has the same problem. So I'd imagine I can rule out the ECU being the problem...

Tried jumpering the fuel pump, same problem.

Tried a different MAF, same problem.

Coil pack, same problem.

CAS, same problem

Tried a fuel pump, same problem.

FPR, same problem.


Any ideas what I've bloody done?


I was wondering maybe I've fried the injectors asking it to do stupid things on tunerstudio? The FPR I tried is off a mates Saab, and when you take the fuel lines off it theres a large amount of fuel pressure in the lines, with the same regulator on my Roadster there isn't any pressure even after having the thing spin over and reading 3+ Bar of pressure in the system...


Any ideas greatly appreciated, Thanks, Ad
StuntmanAd is offline   Reply With Quote
Old 08-13-2012, 07:38 PM   #2
Senior Member
iTrader: (10)
 
Join Date: Jul 2009
Location: Oakdale, CA
Posts: 1,353
Total Cats: 66
Default

I would say you possibly fired the igniter. But I could be wrong, especially considering you say it'll start for 2 seconds then die out. Try an igniter anyways, might just work.
RyanRaduechel is offline   Reply With Quote
Old 08-14-2012, 06:01 PM   #3
Newb
Thread Starter
 
Join Date: Apr 2011
Posts: 28
Total Cats: 0
Default

It was the igniter! I've always known these as Ignition Amplifiers, or are they different things altogether?
StuntmanAd is offline   Reply With Quote
Old 08-14-2012, 09:02 PM   #4
Senior Member
iTrader: (10)
 
Join Date: Jul 2009
Location: Oakdale, CA
Posts: 1,353
Total Cats: 66
Default

I dont know what they are, all I know is I have burned up 3 personally. Glad you got it going
RyanRaduechel is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
1994 Spec Miata Race Car SM/SM2/SSM For Sale Quinn Cars for sale/trade 6 10-23-2016 08:58 AM
No spark while cranking? navalhawkeye MEGAsquirt 9 10-07-2015 08:10 PM
Are my coils failing? viriiguy General Miata Chat 5 09-28-2015 08:39 PM
Help multi issues here! ReallyRottenTurbo MEGAsquirt 4 09-22-2015 01:49 PM


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 10:24 AM.