Need a serial to USB adapter for Windows 7 - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


Insert BS here A place to discuss anything you want

Reply
 
 
 
LinkBack Thread Tools Search this Thread
Old 08-16-2011, 05:00 PM   #1
Junior Member
Thread Starter
 
Join Date: Apr 2009
Location: TX
Posts: 335
Total Cats: 5
Default Need a serial to USB adapter for Windows 7

I need one so my laptop can talk to MegaSquirt. So far I've gone through THREE different pieces of crap from Fry's, and NONE of them work with Windows 7 - in spite of the fact that two actually list Windows 7 on their compatibility list. Every one of these is supposed to be plug-n-play, but none of them are. When I plug them in, Windows automatically searches for a driver to install, but then it fails. If I try to troubleshoot and update the driver, it tells me the driver is already up to date. If I go to any of the manufacturer's websites to download a driver, every last one of them gives me the same driver (Prolific something-or-other). This driver doesn't work. The "Windows 7" driver on one of the discs doesn't work either. I'm all up-to-date on my Windoze patches and updates so I'm at the end of my rope with this crap. I want to severely beat Bill Gates about the head and face with a table leg at this point.

WTF???

Anybody advice/suggestions/recommendations are welcome.
trickyrix is offline   Reply With Quote
Old 08-16-2011, 05:15 PM   #2
Destroyer of Inconel
iTrader: (37)
 
EO2K's Avatar
 
Join Date: Apr 2010
Location: In ur driveway, abusin' ur WPA
Posts: 9,642
Total Cats: 954
Default

Go to RadioShack and pick up the cheap *** "GigaWare" one (or whatever the **** the RS house brand is called) and try it.
EO2K is offline   Reply With Quote
Old 08-16-2011, 05:15 PM   #3
I'm Miserable!
 
Join Date: Feb 2010
Posts: 584
Total Cats: 0
Default

Which three POC did you try out?
sjmarcy is offline   Reply With Quote
Old 08-16-2011, 05:33 PM   #4
Junior Member
Thread Starter
 
Join Date: Apr 2009
Location: TX
Posts: 335
Total Cats: 5
Default

Quote:
Originally Posted by sjmarcy View Post
Which three POC did you try out?
Here are the fantastic brands I tried:
PC Gearhead
Aluratek
Cables Unlimited

They can all suck it.
trickyrix is offline   Reply With Quote
Old 08-16-2011, 05:36 PM   #5
Destroyer of Inconel
iTrader: (37)
 
EO2K's Avatar
 
Join Date: Apr 2010
Location: In ur driveway, abusin' ur WPA
Posts: 9,642
Total Cats: 954
Default

I had the Cables Unlimited one for years, stopped working when I went from XP to 7 on my work laptop, so I threw it on the ground.

RatShack GigaWhatsit one works fine with my Win7 laptop, I use it at work for connecting to console ports on Cisco equipment.
EO2K is offline   Reply With Quote
Old 08-16-2011, 05:40 PM   #6
Junior Member
Thread Starter
 
Join Date: Apr 2009
Location: TX
Posts: 335
Total Cats: 5
Default

Is THIS the one you guys are talking about? $40 is fine if it works... and I guess I can take the SOB back if it doesn't.
trickyrix is offline   Reply With Quote
Old 08-16-2011, 05:43 PM   #7
Destroyer of Inconel
iTrader: (37)
 
EO2K's Avatar
 
Join Date: Apr 2010
Location: In ur driveway, abusin' ur WPA
Posts: 9,642
Total Cats: 954
Default

Quote:
Originally Posted by trickyrix View Post
Is THIS the one you guys are talking about? $40 is fine if it works... and I guess I can take the SOB back if it doesn't.
Yarp. Go in and pay cash, easier to return if I'm a liar
EO2K is offline   Reply With Quote
Old 08-16-2011, 08:10 PM   #8
Elite Member
iTrader: (7)
 
jeff_man's Avatar
 
Join Date: May 2007
Location: Dallas, Tx
Posts: 3,056
Total Cats: 103
Default

Quote:
Originally Posted by EO2K View Post
I had the Cables Unlimited one for years, stopped working when I went from XP to 7 on my work laptop, so I threw it on the ground.

RatShack GigaWhatsit one works fine with my Win7 laptop, I use it at work for connecting to console ports on Cisco equipment.
You have to boot vista and win 7 in to disable sigh driver check, then the cables unlimited one will work along with many others.
jeff_man is offline   Reply With Quote
Old 08-16-2011, 08:14 PM   #9
Ben
Supporting Vendor
iTrader: (33)
 
Ben's Avatar
 
Join Date: Jul 2006
Location: atlanta-ish
Posts: 12,689
Total Cats: 99
Default

Ben is offline   Reply With Quote
Old 08-16-2011, 08:15 PM   #10
Elite Member
iTrader: (7)
 
jeff_man's Avatar
 
Join Date: May 2007
Location: Dallas, Tx
Posts: 3,056
Total Cats: 103
Default

Quote:
Originally Posted by Ben View Post
that is the cables unlimited one that he bot local
jeff_man is offline   Reply With Quote
Old 08-16-2011, 08:19 PM   #11
Tour de Franzia
iTrader: (6)
 
hustler's Avatar
 
Join Date: Jun 2006
Location: Republic of Dallas
Posts: 29,114
Total Cats: 351
Default

Quote:
Originally Posted by Ben View Post
In this crew, with flawless operation.

Rick, you need to get some of those little pins to plug the IAT wires into the mass air sensor. I know DIY has them, not sure about Fry's.
hustler is offline   Reply With Quote
Old 08-16-2011, 08:26 PM   #12
Ben
Supporting Vendor
iTrader: (33)
 
Ben's Avatar
 
Join Date: Jul 2006
Location: atlanta-ish
Posts: 12,689
Total Cats: 99
Default

Quote:
Originally Posted by jeff_man View Post
that is the cables unlimited one that he bot local
It is a CU item, but they have a few different models. I've tested 2, and both worked fine. Though one of the models had a stupid thumbscrew design that was hard to use (it was operationally fine once you got it mounted). Stupid thumbscrew model is not the one we carry.

I use the USB2920 with a Win7 computer every day.
Ben is offline   Reply With Quote
Old 08-17-2011, 12:25 AM   #13
Junior Member
Thread Starter
 
Join Date: Apr 2009
Location: TX
Posts: 335
Total Cats: 5
Default

Quote:
Originally Posted by Ben View Post
That looks suspiciously like the Cables Unlimited piece of **** I bought today. I tried the driver DIY linked to but that was a no-go. Part of the problem is that ******* Windows 7 won't let me manually select the driver after I plug in the adapter. It happily auto-selects some random driver and then it fails. At that point, it won't even let me update the driver to something that I think might work.

Having said all that... I'll try that one.
trickyrix is offline   Reply With Quote
Old 08-17-2011, 12:33 AM   #14
Tour de Franzia
iTrader: (6)
 
hustler's Avatar
 
Join Date: Jun 2006
Location: Republic of Dallas
Posts: 29,114
Total Cats: 351
Default

Quote:
Originally Posted by trickyrix View Post
That looks suspiciously like the Cables Unlimited piece of **** I bought today. I tried the driver DIY linked to but that was a no-go. Part of the problem is that ******* Windows 7 won't let me manually select the driver after I plug in the adapter. It happily auto-selects some random driver and then it fails. At that point, it won't even let me update the driver to something that I think might work.

Having said all that... I'll try that one.
I'll bring mine over tomorrow and we can install the driver the same way I installed mine.
hustler is offline   Reply With Quote
Old 08-17-2011, 12:41 AM   #15
Junior Member
Thread Starter
 
Join Date: Apr 2009
Location: TX
Posts: 335
Total Cats: 5
Default

Sounds like a plan.
trickyrix is offline   Reply With Quote
Old 08-17-2011, 12:55 AM   #16
meatbag
iTrader: (50)
 
gospeed81's Avatar
 
Join Date: Nov 2008
Location: Houston, TX
Posts: 7,357
Total Cats: 26
Default

I've had the GigaWare from RadiosHack work on every OS I've used, including Win7 Beta.

I have one in the garage you can have since I haven't had a working MS in over a year.
gospeed81 is offline   Reply With Quote
Old 08-17-2011, 08:34 AM   #17
Boost Czar
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 72,899
Total Cats: 1,792
Default

**** i couldnt get the gigaware one to work on my win7 machine. I couldn't get the drivers to install and recognize it.

Last edited by Braineack; 08-17-2011 at 09:27 AM.
Braineack is offline   Reply With Quote
Old 08-17-2011, 09:17 AM   #18
Junior Member
Thread Starter
 
Join Date: Apr 2009
Location: TX
Posts: 335
Total Cats: 5
Default

I double checked just now and the CU unit is the USB-2920 model. Go figure...
trickyrix is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
UEFI boot help needed mgeoffriau Gaming 38 03-02-2016 04:59 PM
My solution for Oiltemp and Oilpressure input into Megasuirt (MS3) Zaphod MEGAsquirt 41 01-24-2016 01:25 PM
Bizarre connection issue? nick470 MEGAsquirt 1 09-30-2015 11:32 PM
MS3 Basic Connection Issues EErockMiata MEGAsquirt 6 09-24-2015 10:49 AM
SOLD-Rear knuckle/spindle upper spherical bearing adapter hi_im_sean Miata parts for sale/trade 1 09-16-2015 01:45 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 06:13 AM.