MEGAsquirt A place to collectively sort out this megasquirt gizmo
Sponsored by:
Sponsored by:

91 Miata v-TPS retrofit: No ADC values in TS

 
Old 04-25-2019, 10:26 AM
  #1  
Senior Member
Thread Starter
iTrader: (5)
 
Join Date: Nov 2013
Location: Wisconsin
Posts: 655
Total Cats: 67
Default 91 Miata v-TPS retrofit: No ADC values in TS

Long time no see.

I am assisting a friend who ordered and built his DIY PNP (MS2?) for his 91 miata. It has been running well for a couple years, but over the weekend he retrofit a variable TPS (the BMW model). TunerStudio is showing 0 ADC for the sensor, regardless of pedal position. I removed the jumper from TPS to ground with the 1000ohm resistor, and connected TPS to the proper pin on the DIY BOB (4L if I recall correctly? I don't have the document in front of me.)I also have tested continuity on the light green/yellow wire from the sensor to the TPS pin in megasquirt, and that looks good. I talked to the folks at Flyin Miata, who sold the sensor, and they say that the green wire is supposed to be 5v in, and the red wire is actually the signal wire for their sensor, and a youtube video mentioned flip-flopping the red and green wire, so we've done that. I have noticed however, that I do not see 5v across the 5v wire to ground (it fluctuates between ~0.3v up to maybe 1.5v and back down). And the other wire at the connector is 0v. I'm guessing this is an issue with the sensor not getting the 5v it needs, but am not sure which pin on the BOB that 5v is coming from so I can test, or if you have any other ideas on how to troubleshoot this issue.
mlev is offline  
Old 04-25-2019, 10:36 AM
  #2  
Senior Member
Thread Starter
iTrader: (5)
 
Join Date: Nov 2013
Location: Wisconsin
Posts: 655
Total Cats: 67
Default

It also occurred to me that I could possibly us a spare ESP32/Arduino to supply 5v to the sensor and pull the ADC value and display it with a serial.println(), would that work? To at least test if the sensor is working.

EDIT: Update, I heard from the good folks at DIY Auto Tune. The standard wiring does NOT handle 5v to that pin, and you have to pull it from vref on the DIY PNP. It should be continuous to pin 1N on the BOB.

I'll spend some quality time with my DMM and see what I can find.

Last edited by mlev; 04-25-2019 at 12:42 PM.
mlev is offline  
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Michael Bordelon
MEGAsquirt
3
04-17-2018 02:29 AM
jerrah
MEGAsquirt
4
03-21-2011 12:41 AM
TravisR
Adaptronic
2
07-30-2009 09:53 AM
91NApeewee
MEGAsquirt
3
05-14-2008 09:34 PM
Ben
MEGAsquirt
23
10-23-2007 03:36 PM


Thread Tools
Search this Thread
Quick Reply: 91 Miata v-TPS retrofit: No ADC values in TS


Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.