'92 1.6 begi shanghai S cuts out at 4k rpm - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


MEGAsquirt A place to collectively sort out this megasquirt gizmo

Reply
 
 
 
LinkBack Thread Tools
Old 05-10-2011, 05:45 PM   #1
I haz no trubo
Thread Starter
iTrader: (2)
 
Oscar's Avatar
 
Join Date: Jan 2007
Location: Bolton, UK
Posts: 3,021
Total Cats: 114
Default '92 1.6 begi shanghai S cuts out at 4k rpm

Car of a buddy of mine is at a dynoshop to get his MS sorted out. Problem is, car cuts out after 4k rpm. According to dynotuner dude, the car then has 120whp @10 psi. It's not overboost protection kicking in (set at 255kPa). Tune so far doesn't look weird to me (for a tune in progress). Any ideas?

Car is a 92 1.6. Begi Shanghai S with T25/T28 turbo, mild steel separated gases downpipe, full 2,5" catless exhaust, Innovate LC-1 WBO2, MSPNP 90-93 running MS1 029q code. RC 440cc injectors.

Current .msq attached, no log file (yet).
Attached Files
File Type: msq mx5nieuw.msq (34.9 KB, 55 views)
Oscar is offline   Reply With Quote
Old 05-11-2011, 10:59 AM   #2
Supporting Vendor
 
Matt Cramer's Avatar
 
Join Date: Sep 2006
Posts: 2,266
Total Cats: 51
Default

I suspect it has something to do with the fact that you're running only 6 degrees of spark timing at 10 psi.
Matt Cramer is offline   Reply With Quote
Old 05-11-2011, 11:08 AM   #3
I haz no trubo
Thread Starter
iTrader: (2)
 
Oscar's Avatar
 
Join Date: Jan 2007
Location: Bolton, UK
Posts: 3,021
Total Cats: 114
Default

Little update: apparently, tach drops to 0 after hitting 4k rpm and then comes back. They are suspecting coils or igniter and are sourcing a replacement.
Oscar is offline   Reply With Quote
Old 05-13-2011, 11:35 AM   #4
Supporting Vendor
 
Matt Cramer's Avatar
 
Join Date: Sep 2006
Posts: 2,266
Total Cats: 51
Default

If you could post a data log, that would be great.
Matt Cramer is offline   Reply With Quote
Old 05-13-2011, 11:42 AM   #5
Boost Czar
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 72,860
Total Cats: 1,788
Default

regap the spark plugs correctly and advance the timing.
Braineack is offline   Reply With Quote
Old 05-13-2011, 02:49 PM   #6
Junior Member
iTrader: (1)
 
Join Date: May 2009
Location: TN
Posts: 328
Total Cats: 4
Default

Take the car to a different dyno shop if they are that clueless.
southernmx5 is offline   Reply With Quote
Old 05-18-2011, 12:14 PM   #7
I haz no trubo
Thread Starter
iTrader: (2)
 
Oscar's Avatar
 
Join Date: Jan 2007
Location: Bolton, UK
Posts: 3,021
Total Cats: 114
Default

Little update: fresh coils apparently solved the 4k cut out. They also said the fuel pump was dying and they put in another one. Car now has 180-ish whp at 14.5 psi. Detonation is (was) present and timing up top is only around 6*. I feel more should be possible on this setup without detonation occurring.
This is what I'm told, so what gives?
Oscar is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
The "other" spool question stefanst DIY Turbo Discussion 44 09-28-2015 08:16 PM
Wastegate problems 90turboMX5 DIY Turbo Discussion 32 02-15-2008 12:05 PM
A proper setup for SCCA autocross The_Pipefather General Miata Chat 51 02-07-2008 09:49 PM
Motor went bad gotta sell Turbo Parts! akthor Miata parts for sale/trade 26 01-01-2008 03:15 AM
a/f ratio greenmachine DIY Turbo Discussion 19 11-27-2006 12:57 PM


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 04:25 AM.