92 1.6l MS2 Tach Input Problems - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


MEGAsquirt A place to collectively sort out this megasquirt gizmo

Reply
 
 
 
LinkBack Thread Tools
Old 10-17-2012, 11:18 PM   #1
Junior Member
Thread Starter
iTrader: (5)
 
Join Date: Nov 2010
Location: Originally from Germany. Now live in SoCal
Posts: 196
Total Cats: -5
Default 92 1.6l MS2 Tach Input Problems

Hey guys, I have a ms2 pcb3.0 I'm trying to run on a 92 1.6 miata.

It was running ms1 pcb3.0 (tach-in through hall circuit, msextra.com miata ms2) perfectly fine, but it would not receive tach-in after the ms2 upgrade. We sold the unit and attempted to try again, but I still can't get a clean tach signal to ms2 from the car, which is odd because I was able to with ms1. I decided to install the VR conditioner circuit because I believe it is a better tach input circuit, which I have also read online.

I now have CKP installed like this:
CKP to db37 pin 24
TACHSELECT to VRIN
VRIN to 1k Ohm to 5v Proto
VROUT to TSEL

and CMP installed like this:
CMP to IAC1A
IAC1A to js10
js10 to 470 ohm res
470 ohm res to 5v proto

I've tried TSEL to VROUT and VROUTINV, and I've also tried input capture to rising and falling and every combination i could think of, no change in anything. Just a tach signal that will show up for a few rotations and then disappear. VR pots are adjusted full ccw, and the bottom one turned 6 turns cw.

Using the VR tach input circuit, what jumpers/pullups does the ms2 require for the CKP signal to get to the processor? Does what I have look right to you guys? My hair is falling out.

The attachments were made using a JimStim 1.3.
Attached Files
File Type: zip DataLogs.zip (48.3 KB, 35 views)
MR.M!474 is offline   Reply With Quote
Old 10-18-2012, 09:55 AM   #2
Boost Czar
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 72,899
Total Cats: 1,792
Default

to change you ms1 to ms2 you need to simply do the following:





You can probably skip replacing r12.


I dont believe you can use the VR input unless you build something different for the cam input, as the polarities from both would be reversed. I suposse you could send the cam input through the hall-effect circuit...
Attached Thumbnails
92 1.6l MS2 Tach Input Problems-dsc_0001_mods.jpg   92 1.6l MS2 Tach Input Problems-dsc_0003_mods.jpg  
Braineack is offline   Reply With Quote
Old 10-18-2012, 01:53 PM   #3
Junior Member
Thread Starter
iTrader: (5)
 
Join Date: Nov 2010
Location: Originally from Germany. Now live in SoCal
Posts: 196
Total Cats: -5
Default

To clarify, the MS1 i had was working fine on the same 92 1.6l. I decided to upgrade it to an MS2 and i followed all of your guides to make the changes on the board in order to properly run the new MS2 Daughter Card. However, i never got it working correctly. Nothing i did changed the problem (no crank, crank, no crank, crank when trying to start the car).

So i sold the unit as a working MS1 and bought a new unassembled MS2 kit. Built it using the MS2 extra website and made the changes according to the miataturbo wiki page.

When i change the polarity on the JimStim i get accurate and smooth readings from cam and tach but in the low RPM range i get erratic and jumpy signals once again.

Is it possible that the ms2 daughter card is defective itself? I'm using the same daughter card i tried to use when upgrading the MS1 I had.

My friend will get into more detail with everything, he understands it better than i do and also wrote this thread for me.
MR.M!474 is offline   Reply With Quote
Old 10-18-2012, 02:22 PM   #4
Ben
Supporting Vendor
iTrader: (33)
 
Ben's Avatar
 
Join Date: Jul 2006
Location: atlanta-ish
Posts: 12,689
Total Cats: 99
Default

Have you tried the MS2 on a car? The stim does not replicate VR output perfectly.
Ben is offline   Reply With Quote
Old 10-18-2012, 03:04 PM   #5
Boost Czar
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 72,899
Total Cats: 1,792
Default

id like to see the the composite logger looks like...
Braineack is offline   Reply With Quote
Old 10-18-2012, 03:06 PM   #6
Junior Member
Thread Starter
iTrader: (5)
 
Join Date: Nov 2010
Location: Originally from Germany. Now live in SoCal
Posts: 196
Total Cats: -5
Default

Yea, i was cranking for days while my friend adjusted the VR pods on the board. Nothing. We switched to CAS 4/1 and got some spark but nothing when on 4g63. We tried a few different combinations to no avail. This was tested in my 92 1.6l which is the car this is being built for.
MR.M!474 is offline   Reply With Quote
Old 10-18-2012, 03:09 PM   #7
Junior Member
Thread Starter
iTrader: (5)
 
Join Date: Nov 2010
Location: Originally from Germany. Now live in SoCal
Posts: 196
Total Cats: -5
Default

Quote:
Originally Posted by Braineack View Post
id like to see the the composite logger looks like...
My friend has my stuff. I'm sure he can make a log today/tonight.
MR.M!474 is offline   Reply With Quote
Old 10-19-2012, 11:24 PM   #8
Junior Member
Thread Starter
iTrader: (5)
 
Join Date: Nov 2010
Location: Originally from Germany. Now live in SoCal
Posts: 196
Total Cats: -5
Default

We tested the MS2 DaughterBoard on a different MS2 unit. Its working fine so thats not it. We are going to take the stuff to my house and make a Comp. Log tonight and post it.
MR.M!474 is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Raleigh: Fiberglass headlight scope, 1.6L ECU, AFM, Hardtop latches, more bigmackloud Miata parts for sale/trade 13 09-22-2017 01:34 PM
My solution for Oiltemp and Oilpressure input into Megasuirt (MS3) Zaphod MEGAsquirt 41 01-24-2016 01:25 PM
Back to Stock Part Out!! Turbo Parts, MS2 Enhanced 01-05, Suspension, and MOAR! StratoBlue1109 Miata parts for sale/trade 16 10-02-2015 10:39 AM
Leaky Wilwoods mx592 Suspension, Brakes, Drivetrain 1 10-01-2015 01:45 AM
Are my coils failing? viriiguy General Miata Chat 5 09-28-2015 08:39 PM


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 02:43 AM.