94 DIYPNP V1.5B Questions about AC - Page 2 - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


MEGAsquirt A place to collectively sort out this megasquirt gizmo

Reply
 
 
 
LinkBack Thread Tools
Old 08-08-2013, 10:44 AM   #21
Boost Czar
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 72,842
Total Cats: 1,786
Default

my picture was to be used as illustrative purposes only.

r14 is not installed, it needs to be installed now. I didn't notice that before.
Braineack is online now   Reply With Quote
Old 08-08-2013, 10:55 AM   #22
Senior Member
Thread Starter
iTrader: (2)
 
Join Date: Jun 2012
Location: New Braunfels,TX
Posts: 1,141
Total Cats: 51
Default

Ok so I want to make sure I got this straight. Install 2.2k resistor on r14.

Jumper

1J&4s>Input 1 OUT
Input 1 IN> PA0
PE1>Relay 1 IN
Relay 1 OUT> 1Q

Is this correct?
ScottyP3821 is offline   Reply With Quote
Old 08-08-2013, 11:41 AM   #23
Boost Czar
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 72,842
Total Cats: 1,786
Default

no, that's not correct.

I'll repeat myself:

1Q > Input1 IN
Input1 OUT > PE1
PA0 > Relay 1 IN
Relay 1 Out > 1J&4S
Braineack is online now   Reply With Quote
Old 08-08-2013, 11:43 AM   #24
Boost Czar
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 72,842
Total Cats: 1,786
Default

Quote:
Originally Posted by Braineack View Post
no, that's not correct.

I'll repeat myself:

1Q > Input1 IN
Input1 OUT > PE1
PA0 > Relay 1 IN
Relay 1 Out > 1J&4S
Hey braineack, did you mean:

1Q > Relay1 IN
Relay1 OUT > PE1
PA0 > Input 1 IN
Input 1 Out > 1J&4S

????
Braineack is online now   Reply With Quote
Old 08-08-2013, 11:43 AM   #25
Boost Czar
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 72,842
Total Cats: 1,786
Default

Quote:
Originally Posted by Braineack View Post
Hey braineack, did you mean:

1Q > Relay1 IN
Relay1 OUT > PE1
PA0 > Input 1 IN
Input 1 Out > 1J&4S

????
no, i did not. i usually don't put outputs on input circuits. However, i do tend to put outputs on relays and inputs on inputs.
Braineack is online now   Reply With Quote
Old 08-08-2013, 12:34 PM   #26
Senior Member
Thread Starter
iTrader: (2)
 
Join Date: Jun 2012
Location: New Braunfels,TX
Posts: 1,141
Total Cats: 51
Default

Quote:
Originally Posted by Braineack View Post
no, i did not. i usually don't put outputs on input circuits. However, i do tend to put outputs on relays and inputs on inputs.

So the picture of how I wired it is fine just add the resistor?
ScottyP3821 is offline   Reply With Quote
Old 08-08-2013, 12:43 PM   #27
Boost Czar
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 72,842
Total Cats: 1,786
Default

my picture is probably wrong. go by my werds.


but yeah. when it's wired to activate the a/c without the MS in the mix, r14 is removed. Since you're sending it back to the ECU first now, you need that pull up.

I'm not exactly sure what circuit DIY used for the inputs, but I'm pretty sure that's a pull-up. you could steal one from an unused circuit on the board if you are desperate. I'm pretty sure r14 is 2.2K, but a 1K might work... I'd need to see pics of the top of the board to see what resistors might be unused and able to work. Probably there's a 2.2K reistor on the high side driver circuit that you aren't using.
Braineack is online now   Reply With Quote
Old 08-08-2013, 01:03 PM   #28
Senior Member
Thread Starter
iTrader: (2)
 
Join Date: Jun 2012
Location: New Braunfels,TX
Posts: 1,141
Total Cats: 51
Default

How about I pull r 38. It is part of the nitrous driver and I don't like nitrous. the resistor is colored red red red gold and to my knowledge that would be an ideal 2.2 k candidate.
ScottyP3821 is offline   Reply With Quote
Old 08-08-2013, 01:06 PM   #29
Boost Czar
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 72,842
Total Cats: 1,786
Default

i think that's the one im talking about.
Braineack is online now   Reply With Quote
Old 08-08-2013, 01:15 PM   #30
Senior Member
Thread Starter
iTrader: (2)
 
Join Date: Jun 2012
Location: New Braunfels,TX
Posts: 1,141
Total Cats: 51
Default

Ok so I'm going to move the r38 2.2k to r14 and leave my jumper the way I have them and I should be good to go plug into the car and start without frying anything?
ScottyP3821 is offline   Reply With Quote
Old 08-08-2013, 01:27 PM   #31
Boost Czar
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 72,842
Total Cats: 1,786
Default

that's the plan.
Braineack is online now   Reply With Quote
Old 08-08-2013, 01:29 PM   #32
Senior Member
Thread Starter
iTrader: (2)
 
Join Date: Jun 2012
Location: New Braunfels,TX
Posts: 1,141
Total Cats: 51
Default



Here's what I got I removed r38 and moved it r14. Just wanted to post a pic for reference.
Attached Thumbnails
94 DIYPNP V1.5B Questions about AC-image.jpg  
ScottyP3821 is offline   Reply With Quote
Old 08-08-2013, 02:04 PM   #33
Boost Czar
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 72,842
Total Cats: 1,786
Default

while you are in there, move the two wires going to 4C and 4D to SG from GND
Braineack is online now   Reply With Quote
Old 08-08-2013, 02:07 PM   #34
Senior Member
Thread Starter
iTrader: (2)
 
Join Date: Jun 2012
Location: New Braunfels,TX
Posts: 1,141
Total Cats: 51
Default

Ok will this add any other features.
ScottyP3821 is offline   Reply With Quote
Old 08-08-2013, 02:13 PM   #35
Boost Czar
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 72,842
Total Cats: 1,786
Default

Quote:
Originally Posted by ScottyP3821 View Post
Ok will this add any other features.
it will move the sensor grounds to the sensor ground plane.
Braineack is online now   Reply With Quote
Old 08-08-2013, 03:56 PM   #36
Senior Member
Thread Starter
iTrader: (2)
 
Join Date: Jun 2012
Location: New Braunfels,TX
Posts: 1,141
Total Cats: 51
Default

Quote:
Originally Posted by Braineack View Post
it will move the sensor grounds to the sensor ground plane.
Car starts and runs like **** now with a bouncing idle before it dies. Where do I go from here.
ScottyP3821 is offline   Reply With Quote
Old 08-08-2013, 04:08 PM   #37
Senior Member
Thread Starter
iTrader: (2)
 
Join Date: Jun 2012
Location: New Braunfels,TX
Posts: 1,141
Total Cats: 51
Default

Ok accidentally forgot to plug the map in my bad but still no AC engagement.

Edit

Msq found here

https://www.miataturbo.net/megasquir...-my-msq-74292/
ScottyP3821 is offline   Reply With Quote
Old 08-08-2013, 04:10 PM   #38
Boost Czar
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 72,842
Total Cats: 1,786
Default

and you've made sure to setup the software for the correct inputs (PE1) and outputs (PA0).
Braineack is online now   Reply With Quote
Old 08-08-2013, 04:50 PM   #39
Senior Member
Thread Starter
iTrader: (2)
 
Join Date: Jun 2012
Location: New Braunfels,TX
Posts: 1,141
Total Cats: 51
Default

Got it to kick on now I guess I need to play with the idle and closed loop settings.
ScottyP3821 is offline   Reply With Quote
Old 08-08-2013, 06:24 PM   #40
Senior Member
Thread Starter
iTrader: (2)
 
Join Date: Jun 2012
Location: New Braunfels,TX
Posts: 1,141
Total Cats: 51
Default

This is such a pain in the ***. Do I have to use Closed Loop because PWM Warm up is easy and I suck at closed loop.
ScottyP3821 is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Raleigh: Fiberglass headlight scope, 1.6L ECU, AFM, Hardtop latches, more bigmackloud Miata parts for sale/trade 13 09-22-2017 01:34 PM
Time to start learning and play with tuning The Gleas MEGAsquirt 3 10-01-2015 10:30 AM
Are my coils failing? viriiguy General Miata Chat 5 09-28-2015 08:39 PM
Missing/knock at idle, can someone point me in the right direction? Mikel MEGAsquirt 4 09-28-2015 05:46 PM


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 03:50 PM.