AEM Incorrect Reading Fix Question. - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


MEGAsquirt A place to collectively sort out this megasquirt gizmo

Reply
 
 
 
LinkBack Thread Tools
Old 03-15-2011, 12:38 AM   #1
Junior Member
Thread Starter
 
Join Date: Jan 2010
Location: Atlanta GA
Posts: 167
Total Cats: 0
Default AEM Incorrect Reading Fix Question.

For whatever reason my AEM wideband has decided it no longer wants to agree with what TS says. I redid the ground and the connection to the MS but it's still off by .7-.8

So I'm going to try the fix where you change the values in the .ini file to make them agree but will this also make the MS itself more correct?

In other words, I have to set my target values well below the actual values because in TS the AFR is way below what the actual gauge is reading. So for cruising my target AFR's are at 15.4 to get EGO correction to put the car at the real (gauge) AFR to 14.7.

Will this fix actually modify the Megasquirt reading and make it agree with the gauge or will it just make it correct in TS? Because right now the EGO correction corresponds with what TS is showing and not what the gauge is showing.

Thanks.
D.dutton9512 is offline   Reply With Quote
Old 03-15-2011, 01:02 AM   #2
Elite Member
 
Join Date: Jul 2005
Posts: 6,454
Total Cats: 80
Default

There is a flaw in the AEM WB design - in my case I see a 0.3 error - beef up the ground wire, doubling it up with gauge 18 should help.
JasonC SBB is offline   Reply With Quote
Old 03-15-2011, 01:11 AM   #3
Junior Member
Thread Starter
 
Join Date: Jan 2010
Location: Atlanta GA
Posts: 167
Total Cats: 0
Default

Thanks for the advice, I'll definitely try that tomorrow. BTW, how important is it that I use the main ECU ground under the throttle body? I swapped it a few months ago from a ground under the dash but didn't notice any change.

It looks like guys have had success changing the ini file in discrepancies up to 1.0. I just want to know if changing the Tuner Studio ini file will also change the internal settings of the Megasquirt.
D.dutton9512 is offline   Reply With Quote
Old 03-15-2011, 04:15 PM   #4
Junior Member
Thread Starter
 
Join Date: Jan 2010
Location: Atlanta GA
Posts: 167
Total Cats: 0
Default

Just in case anyone else ever has this problem:

No, changing the ini settings to make the TS (or MT) software gauges match the physical gauge does not seem to change the MS settings for EGO correction.

However, beefing up the wire, as JasonC said, using solder instead of just crimping, buying ring terminals big enough to fully surround a bolt, and lightly sanding off any rust/residue, will do wonders.
D.dutton9512 is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Project Gemini - Turbo Civic on the Cheap Full_Tilt_Boogie Build Threads 59 12-15-2017 09:00 PM
OTS Bilstein to motorsports ASN conversion stoves Suspension, Brakes, Drivetrain 5 04-21-2016 04:00 PM
Back to Stock Part Out!! Turbo Parts, MS2 Enhanced 01-05, Suspension, and MOAR! StratoBlue1109 Miata parts for sale/trade 16 10-02-2015 10:39 AM
1996 Turbo Build Goldwar DIY Turbo Discussion 2 09-29-2015 10:20 AM


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 11:05 AM.