coolant temp sensor - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


MEGAsquirt A place to collectively sort out this megasquirt gizmo

Reply
 
 
 
LinkBack Thread Tools
Old 12-20-2007, 01:33 PM   #1
Hittin' Boost & Cones
Thread Starter
iTrader: (2)
 
240_to_miata's Avatar
 
Join Date: May 2007
Location: Cromwell, Connecticut
Posts: 2,572
Total Cats: 11
Default coolant temp sensor

hey guys, im almost done with my MS1 install in my 96 miata. I am using a boomslang harness and sharing the coolant sensor... i plugged in the harness and megasquirt today to check the readings on some of the guages. I was getting 17 degrees F for my coolant today.... It is about 35 degrees out and the engine hasn't run since yesterday.... im assuming this isnt accurate and its about half wat it should be. I have set up and burned the values for the rx7 coolant temp using easytherm... did i mess something up?
240_to_miata is offline   Reply With Quote
Old 12-20-2007, 02:09 PM   #2
Elite Member
iTrader: (13)
 
cjernigan's Avatar
 
Join Date: Oct 2006
Location: Atlanta, GA
Posts: 8,147
Total Cats: 6
Default

Set it up for the default RX-7 settings, then change the bias resistance for the CLT temp sensor to 1205. That should correct the 17-20* variation.
cjernigan is offline   Reply With Quote
Old 12-20-2007, 02:31 PM   #3
Elite Member
iTrader: (9)
 
Saml01's Avatar
 
Join Date: Jul 2007
Location: NYC
Posts: 5,730
Total Cats: 2
Default

^ troof. It will only be like 8 off after that.
Saml01 is offline   Reply With Quote
Old 12-20-2007, 02:42 PM   #4
Hittin' Boost & Cones
Thread Starter
iTrader: (2)
 
240_to_miata's Avatar
 
Join Date: May 2007
Location: Cromwell, Connecticut
Posts: 2,572
Total Cats: 11
Default

Thanks once again
240_to_miata is offline   Reply With Quote
Old 12-20-2007, 02:44 PM   #5
Boost Pope
iTrader: (8)
 
Joe Perez's Avatar
 
Join Date: Sep 2005
Location: Chicago (Over two miles from Wrigley Field. Fuck the Cubs. Fuck them in their smarmy goat-hole.)
Posts: 26,317
Total Cats: 1,915
Default

Quote:
Originally Posted by cjernigan View Post
change the bias resistance for the CLT temp sensor to 1205.
Are you physically changing the bias resistor on the board, or just lying to EasyTherm about it?
Joe Perez is offline   Reply With Quote
Old 12-20-2007, 02:57 PM   #6
Boost Czar
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 72,860
Total Cats: 1,788
Default

the stock resistance of the CLT is 1205, so R7 is removed.
Braineack is online now   Reply With Quote
Old 12-20-2007, 03:32 PM   #7
Elite Member
iTrader: (3)
 
Join Date: May 2006
Location: Houston, TX
Posts: 2,900
Total Cats: 0
Default

I suspect the late model NAs have a different CLT resistance curve. saml01 and myself are bothing having a problem at the moment where it reads fine at lower temps, but at high temps the MS gauge will peg at 215 before the thermostat even opens. I think the upper value in easytherm will have to be changed for our cars.
Arkmage is offline   Reply With Quote
Old 12-20-2007, 03:34 PM   #8
Boost Czar
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 72,860
Total Cats: 1,788
Default

if you have a thermometer, a stove, and a DDM you can figure it out for yourself.
Braineack is online now   Reply With Quote
Old 12-20-2007, 05:49 PM   #9
Hittin' Boost & Cones
Thread Starter
iTrader: (2)
 
240_to_miata's Avatar
 
Join Date: May 2007
Location: Cromwell, Connecticut
Posts: 2,572
Total Cats: 11
Default

its too damn cold to work outside and pull out the sensor to test it... any1 want to do it for me??? there is a pretty good chance they changed the sensors when they went to obd2 in 96...so i might be screwed. The install will be complete 2morro and ill be able to tell if mine is different or not
240_to_miata is offline   Reply With Quote
Old 12-20-2007, 05:52 PM   #10
Boost Czar
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 72,860
Total Cats: 1,788
Default

if i were smart, i'd hurry up and get my 15gb worth of factory shop manuals from my friend....


however, an easy solution is to ask jerry or matt what values they used.....
Braineack is online now   Reply With Quote
Old 12-20-2007, 06:07 PM   #11
Hittin' Boost & Cones
Thread Starter
iTrader: (2)
 
240_to_miata's Avatar
 
Join Date: May 2007
Location: Cromwell, Connecticut
Posts: 2,572
Total Cats: 11
Default

cool.. i dont know who jerry or matt are tho :-(
240_to_miata is offline   Reply With Quote
Old 12-20-2007, 06:09 PM   #12
Boost Pope
iTrader: (8)
 
Joe Perez's Avatar
 
Join Date: Sep 2005
Location: Chicago (Over two miles from Wrigley Field. Fuck the Cubs. Fuck them in their smarmy goat-hole.)
Posts: 26,317
Total Cats: 1,915
Default

Quote:
Originally Posted by Braineack View Post
the stock resistance of the CLT is 1205, so R7 is removed.
Removed and jumpered, or just removed altogether?
Joe Perez is offline   Reply With Quote
Old 12-20-2007, 06:13 PM   #13
Hittin' Boost & Cones
Thread Starter
iTrader: (2)
 
240_to_miata's Avatar
 
Join Date: May 2007
Location: Cromwell, Connecticut
Posts: 2,572
Total Cats: 11
Default

Removed
240_to_miata is offline   Reply With Quote
Old 12-20-2007, 06:30 PM   #14
Elite Member
iTrader: (3)
 
Join Date: May 2006
Location: Houston, TX
Posts: 2,900
Total Cats: 0
Default

Quote:
Originally Posted by Braineack View Post
if you have a thermometer, a stove, and a DDM you can figure it out for yourself.
plan to do just that... but haven't had time recently.
Arkmage is offline   Reply With Quote
Old 12-20-2007, 06:38 PM   #15
Boost Pope
iTrader: (8)
 
Joe Perez's Avatar
 
Join Date: Sep 2005
Location: Chicago (Over two miles from Wrigley Field. Fuck the Cubs. Fuck them in their smarmy goat-hole.)
Posts: 26,317
Total Cats: 1,915
Default

Quote:
Originally Posted by 240_to_miata_OWNER View Post
Removed
Guess I should have taken a closer look at the edited component layout picture in Brainey's sticky. It's clearly shown as not being there.
Joe Perez is offline   Reply With Quote
Old 12-20-2007, 07:54 PM   #16
Hittin' Boost & Cones
Thread Starter
iTrader: (2)
 
240_to_miata's Avatar
 
Join Date: May 2007
Location: Cromwell, Connecticut
Posts: 2,572
Total Cats: 11
Default

bac to my question:

jerry or matt... what values are u using?
240_to_miata is offline   Reply With Quote
Old 12-21-2007, 10:36 AM   #17
Supporting Vendor
 
Matt Cramer's Avatar
 
Join Date: Sep 2006
Posts: 2,266
Total Cats: 51
Default

We're using the built in bias resistors (2490 ohms). The coolant temperature sensor values we've used are 16000 ohms at -4 degrees F, 2450 ohms at 68 degrees, and 580 ohms at 140 degrees.
Matt Cramer is offline   Reply With Quote
Old 12-21-2007, 10:55 AM   #18
Elite Member
iTrader: (9)
 
Saml01's Avatar
 
Join Date: Jul 2007
Location: NYC
Posts: 5,730
Total Cats: 2
Default

Quote:
Originally Posted by Arkmage View Post
plan to do just that... but haven't had time recently.
Now that my car is running, I plan to go to the mazda dealer and pick one up and return it. Ill try to do that in the upcoming week.

Quote:
Originally Posted by Matt Cramer View Post
We're using the built in bias resistors (2490 ohms). The coolant temperature sensor values we've used are 16000 ohms at -4 degrees F, 2450 ohms at 68 degrees, and 580 ohms at 140 degrees.
For 96 - 97 cars?
Saml01 is offline   Reply With Quote
Old 12-21-2007, 11:21 AM   #19
Hittin' Boost & Cones
Thread Starter
iTrader: (2)
 
240_to_miata's Avatar
 
Join Date: May 2007
Location: Cromwell, Connecticut
Posts: 2,572
Total Cats: 11
Default

ok... and matt, this is with R7 still removed?
240_to_miata is offline   Reply With Quote
Old 12-21-2007, 01:53 PM   #20
Elite Member
iTrader: (3)
 
Join Date: May 2006
Location: Houston, TX
Posts: 2,900
Total Cats: 0
Default

Quote:
Originally Posted by 240_to_miata_OWNER View Post
ok... and matt, this is with R7 still removed?
It sounds like it's with R7 installed, so they must be running the radiator fans off of the MS instead of the stock ECU.
Arkmage is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
MSPNPPro-MM0105: Coolant Temperature Output slomiata MEGAsquirt 5 10-07-2015 02:11 PM
Expected intake temps on the track? tazswing Race Prep 20 10-03-2015 12:04 PM
Back to Stock Part Out!! Turbo Parts, MS2 Enhanced 01-05, Suspension, and MOAR! StratoBlue1109 Miata parts for sale/trade 16 10-02-2015 10:39 AM
Bad head gasket or ? shooterschmidty Engine Performance 8 09-30-2015 11:28 PM


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 09:44 AM.