cylinders 2 and 4 running rich :confused: - Miata Turbo Forum - Boost cars, acquire cats.

MEGAsquirt A place to collectively sort out this megasquirt gizmo
Sponsored by:
Sponsored by:

cylinders 2 and 4 running rich :confused:

Old 06-04-2008, 02:36 PM
  #1  
Elite Member
Thread Starter
iTrader: (24)
 
kotomile's Avatar
 
Join Date: Oct 2006
Location: Monterey, CA
Posts: 7,538
Total Cats: 40
Default cylinders 2 and 4 running rich :confused:

So I'd been wondering why in the hell my car was cruising/idling/everything pig rich (like 11.5 and richer CONSTANTLY) and thought I'd change my plugs. This is what came out, cyl 1 on left, 4 on right:

Name:  DSCN0616.jpg
Views: 38
Size:  92.9 KB
Name:  DSCN0617.jpg
Views: 22
Size:  81.1 KB

So, judging by those, I don't think it's my tune...

Here's two logs, just driving normally to and from work:
Attached Files
File Type: zip

Last edited by kotomile; 06-04-2008 at 02:57 PM.
kotomile is offline  
Old 06-04-2008, 02:53 PM
  #2  
Boost Czar
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 75,291
Total Cats: 2,154
Default

are you even getting fuel in 1 and 3?
Braineack is offline  
Old 06-04-2008, 02:58 PM
  #3  
Elite Member
Thread Starter
iTrader: (24)
 
kotomile's Avatar
 
Join Date: Oct 2006
Location: Monterey, CA
Posts: 7,538
Total Cats: 40
Default

I would think so? There's a bit of soot on them, just not as much as 2 and 4.
kotomile is offline  
Old 06-04-2008, 03:03 PM
  #4  
Ben
Supporting Vendor
iTrader: (33)
 
Ben's Avatar
 
Join Date: Jul 2006
Location: atlanta-ish
Posts: 12,651
Total Cats: 111
Default

I don't know dude, I'd clean/replace the plugs and look again in a few days.
__________________
DIYAutoTune.com Tech Support
10AE-T|BEGi S4|MSPNP-Pro EMS|Enthuza Duals|6UL|Etc
Track Rat|2001|VVT|MS3-Pro EMS|Enthuza|Exocet in Progress

Originally Posted by concealer404 View Post
Buy an MSPNP Pro, you'll feel better.
Ben is offline  
Old 06-04-2008, 03:05 PM
  #5  
Elite Member
iTrader: (9)
 
Saml01's Avatar
 
Join Date: Jul 2007
Location: NYC
Posts: 5,710
Total Cats: 2
Default

Swap injectors around.
Saml01 is offline  
Old 06-04-2008, 03:08 PM
  #6  
Elite Member
iTrader: (3)
 
Join Date: May 2006
Location: Houston, TX
Posts: 2,895
Total Cats: 0
Default

I'd try swapping your injectors around and see if the problem moves with them. You might have two leaky ones.

*edit* sam beat me to it.
Arkmage is offline  
Old 06-04-2008, 03:08 PM
  #7  
Ben
Supporting Vendor
iTrader: (33)
 
Ben's Avatar
 
Join Date: Jul 2006
Location: atlanta-ish
Posts: 12,651
Total Cats: 111
Default

maybe, but not unless/until the symptoms repeat.
identify a problem before looking for a solution.
__________________
DIYAutoTune.com Tech Support
10AE-T|BEGi S4|MSPNP-Pro EMS|Enthuza Duals|6UL|Etc
Track Rat|2001|VVT|MS3-Pro EMS|Enthuza|Exocet in Progress

Originally Posted by concealer404 View Post
Buy an MSPNP Pro, you'll feel better.
Ben is offline  
Old 06-04-2008, 03:35 PM
  #8  
Elite Member
Thread Starter
iTrader: (24)
 
kotomile's Avatar
 
Join Date: Oct 2006
Location: Monterey, CA
Posts: 7,538
Total Cats: 40
Default

I should mention the car idles like a Subaru and bucks a lot during cruise, definitely NOT smooth anymore. I remember the cylinders are batch-fired and was wondering if that might have anything to do with it.
kotomile is offline  
Old 06-04-2008, 03:44 PM
  #9  
Ben
Supporting Vendor
iTrader: (33)
 
Ben's Avatar
 
Join Date: Jul 2006
Location: atlanta-ish
Posts: 12,651
Total Cats: 111
Default

i think the batches are 1+2 & 3+4. a quick trip to madracki would tell for sure.
__________________
DIYAutoTune.com Tech Support
10AE-T|BEGi S4|MSPNP-Pro EMS|Enthuza Duals|6UL|Etc
Track Rat|2001|VVT|MS3-Pro EMS|Enthuza|Exocet in Progress

Originally Posted by concealer404 View Post
Buy an MSPNP Pro, you'll feel better.
Ben is offline  
Old 06-04-2008, 04:32 PM
  #10  
Boost Czar
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 75,291
Total Cats: 2,154
Default

spark is 23 14
fuel is 13 24
Braineack is offline  
Old 06-04-2008, 04:37 PM
  #11  
Boost Czar
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 75,291
Total Cats: 2,154
Default

I'd assume you are getting spark on all 4 since its running super as nasty rich on 2 and 3 and the way its batched....

so either you have 2 dead injectors, or two leaky injectors, or im completely wrong.
Braineack is offline  
Old 06-04-2008, 04:46 PM
  #12  
Elite Member
Thread Starter
iTrader: (24)
 
kotomile's Avatar
 
Join Date: Oct 2006
Location: Monterey, CA
Posts: 7,538
Total Cats: 40
Default

Leaky injectors would be a good explanation, but the fault in it is that it might not be that likely that both 2 and 4 started leaking simultaneously.

I just got the taillight too man, thanks!
kotomile is offline  
Old 06-05-2008, 02:14 PM
  #13  
Supporting Vendor
 
Matt Cramer's Avatar
 
Join Date: Sep 2006
Posts: 2,329
Total Cats: 62
Default

Could you post your MSQ? I'd like to take a look and see if there are any settings for different fueling on the separate injector channels.
__________________
Matt Cramer
www.diyautotune.com
Matt Cramer is offline  
Old 06-05-2008, 02:48 PM
  #14  
Boost Czar
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 75,291
Total Cats: 2,154
Default



im sure Matt speaks of this....
Braineack is offline  
Old 06-05-2008, 04:25 PM
  #15  
Elite Member
Thread Starter
iTrader: (24)
 
kotomile's Avatar
 
Join Date: Oct 2006
Location: Monterey, CA
Posts: 7,538
Total Cats: 40
Default

Originally Posted by Matt Cramer View Post
Could you post your MSQ? I'd like to take a look and see if there are any settings for different fueling on the separate injector channels.
Absolutely, at work now but I will later for sure.
kotomile is offline  
Old 06-05-2008, 04:39 PM
  #16  
Elite Member
iTrader: (3)
 
AbeFM's Avatar
 
Join Date: Aug 2006
Location: San Diego, CA
Posts: 3,044
Total Cats: 10
Default

Curious where that goes. I'm wondering if something burned out in the MS, just leaving the injectors on. That, or a short somewhere.

Did it happen suddenly? Does it always do it, or is it on and off?
AbeFM is offline  
Old 06-05-2008, 07:22 PM
  #17  
Elite Member
Thread Starter
iTrader: (24)
 
kotomile's Avatar
 
Join Date: Oct 2006
Location: Monterey, CA
Posts: 7,538
Total Cats: 40
Default

Here's the .msq \/

Abe: That's what I was thinking might possibly be the problem, but didn't want to jump to that conclusion lest it be something more simple.

It always does it, I can't remember when it started but it hasn't let up since I first noticed it happening. It's like clockwork; after startup, AFRs will be around 15:1, then climb to 17:1ish, then drop steadily to 11.5ish, sometimes 10:1 in cruise. Just measured my MPG - 16 MPG...
Attached Files
File Type: zip
15 joe perez idle.zip (5.9 KB, 63 views)
kotomile is offline  
Old 06-05-2008, 07:30 PM
  #18  
Elite Member
iTrader: (3)
 
AbeFM's Avatar
 
Join Date: Aug 2006
Location: San Diego, CA
Posts: 3,044
Total Cats: 10
Default

Oh, it doesn't happen for a while?

If you run it for a while, 20 min or something, shut it off then immediately start it again, how is it?

I wonder if it's electronics heating up....
AbeFM is offline  
Old 06-05-2008, 07:32 PM
  #19  
Boost Czar
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 75,291
Total Cats: 2,154
Default

post a log too. needs more log.
Braineack is offline  
Old 06-05-2008, 07:34 PM
  #20  
Boost Czar
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 75,291
Total Cats: 2,154
Default

your ego settings and AFR table are screwy.


RPM Based ACCEL needs to be off.


ASE table should go to 0% at 160*


timing and fuel tables at idle look crazy low.


overboost is at -5.7psi, might screw things up.
Braineack is offline  

Thread Tools
Search this Thread
Quick Reply: cylinders 2 and 4 running rich :confused:


Archive Advertising Cookie Policy Privacy Statement Terms of Service

© 2018 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.