DIYPNP idles fine, stalls when throttle applied - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


MEGAsquirt A place to collectively sort out this megasquirt gizmo

Reply
 
 
 
LinkBack Thread Tools
Old 12-17-2013, 11:15 AM   #1
Newb
Thread Starter
 
Join Date: Jan 2013
Location: Finland
Posts: 23
Total Cats: 0
Default DIYPNP idles fine, stalls when throttle applied

Hello

The car is -99 EU model. All stock. DIYPNP with alternator circuit build into proto area.
3.3.1 firmware, 99-00 base map from diyautotune. Ignition settings as instructed on diyautotune.
Also TPS calibrated, CLT, IAT and o2 calibrated as instructed. Changed Fuel req. to fit my engine, dropped from 13.0 to 12.1

I finally got my DIYPNP to start and idle. Base map provided by diyautotune had "none" idle valve selected, it was tyring to idle at ~500rpm. Adjusted the idle screw to max. and i got it at ~750 which was still quite nasty. But when pedaling the throttle RPM goes down and car dies.

Next i messed around with PWM valve settings, with open and closed loop.
Both had acceptable idle of ~1000 with "Normal, 0%=off", "FIDLE", "480hz" frequency. Changing to inverted shot RPM's up to 3k, with closed and open loop.
But again, when pedaling throttle RPM drops and engine stalls. Didint try with inverted, 3k rpm without checking the crank timing was quite scary.

Also the radiator fan is ON all the time, i went from ~70c coolant temp. to ~50c coolant temp during testing and it kept on blowing.

I have read quite a bit about idle tuning, but want to get the throttle working before i start finetuning idle.
Any idea what could be wrong? all help appreciated.

Attached .MSQ and couple datalogs from open loop, closed loop and no idle valve.
Attached Files
File Type: msq 2013-12-17_17.13.02.msq (107.5 KB, 63 views)
File Type: msl openloop2.msl (169.5 KB, 133 views)
File Type: msl no idle valve.msl (218.7 KB, 57 views)
File Type: msl closed loop.msl (181.3 KB, 156 views)
Muksimp is offline   Reply With Quote
Old 12-17-2013, 11:31 AM   #2
Boost Czar
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 72,860
Total Cats: 1,788
Default

tune your accel enrichments.
Braineack is offline   Reply With Quote
Old 12-25-2013, 08:00 PM   #3
Newb
Thread Starter
 
Join Date: Jan 2013
Location: Finland
Posts: 23
Total Cats: 0
Default

Wiring LC1 into DB15.

Do i need signal ground, or can i just use gnd next to 12v on the main board for all the grounds going to LC1?
Muksimp is offline   Reply With Quote
Old 12-26-2013, 05:14 PM   #4
Junior Member
 
Join Date: Dec 2008
Location: Ft. Lauderdale, FL
Posts: 273
Total Cats: 7
Default

Very dumb question, but do you have a vacuum line running to the DIYPNP?
MX5RACER is offline   Reply With Quote
Old 12-26-2013, 08:18 PM   #5
Newb
Thread Starter
 
Join Date: Jan 2013
Location: Finland
Posts: 23
Total Cats: 0
Default

Quote:
Originally Posted by MX5RACER View Post
Very dumb question, but do you have a vacuum line running to the DIYPNP?
Yep

Anyway original issue solved, just had to fix EV table a bit.
Muksimp is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Project Gemini - Turbo Civic on the Cheap Full_Tilt_Boogie Build Threads 58 Yesterday 10:04 PM
Expected intake temps on the track? tazswing Race Prep 20 10-03-2015 12:04 PM
Time to start learning and play with tuning The Gleas MEGAsquirt 3 10-01-2015 10:30 AM
Leaky Wilwoods mx592 Suspension, Brakes, Drivetrain 1 10-01-2015 01:45 AM
Are my coils failing? viriiguy General Miata Chat 5 09-28-2015 08:39 PM


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 02:44 AM.