DIYPNP no start on a 92 Miata - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


MEGAsquirt A place to collectively sort out this megasquirt gizmo

Reply
 
 
 
LinkBack Thread Tools
Old 10-31-2012, 10:13 PM   #1
Junior Member
Thread Starter
 
Join Date: Oct 2010
Location: Wake Forest, NC
Posts: 175
Total Cats: 0
Default DIYPNP no start on a 92 Miata

1.6L, N/A
GM IAT

Tried starting it tonight on the DIYPNP dole, no dice. Well, it did start the first time but idled rough and died. Never refired after that. Starts fine on the stock ECU. Starter will roll over a few times, and then its like it binds up.

Admittedly, I am a bit lost. Massaging tables is easy for me, getting one to start and idle worth a damn is not. Also, I am not that familiar with the MS software at this point, but getting better. Since its my racecar, I am in no hurry but advice would be more than welcome. Starting log and tune attached.
Attached Files
File Type: msq 2012-10-31_17.53.12.msq (78.9 KB, 84 views)
File Type: msl 2012-10-31_17.57.26.msl (73.0 KB, 85 views)
cucamelsmd15 is offline   Reply With Quote
Old 11-01-2012, 09:15 AM   #2
Boost Czar
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 72,900
Total Cats: 1,792
Default

Was it built acording to the documents on diyautotune.com?
Braineack is offline   Reply With Quote
Old 11-01-2012, 09:20 AM   #3
Boost Czar
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 72,900
Total Cats: 1,792
Default

I see your problem.

Under Basic Setup > Tach Input/Ignition Settings

You have "Basic Trigger" instead of "4G63"

Then change "Falling Edge" to "Rising Edge"



Under Startup/Idle > Cranking Settings

Change the Crnaking RPM from "500" to "300"




Under Startup/Idle > Cranking Pulse

Change the "112%" value on the 110 row back to around "200%"






I'm not sure why the Trigger options were changed from the default map provided on the diyautotune.com documents, but that's why it wont start. It's probably trying to fire on the wrong pulse and pushing the pistons down on the upward stroke and fighting the starter.
Braineack is offline   Reply With Quote
Old 11-01-2012, 09:21 AM   #4
Junior Member
Thread Starter
 
Join Date: Oct 2010
Location: Wake Forest, NC
Posts: 175
Total Cats: 0
Default

I didn't build it, but based on what I've seen of the guts, I'd say yes. Its a pretty basic box which has start and run before in another 92.

That said, I think my ignition settings are fucked. I just noticed they say basic trigger, not 4g63, along with the other associated settings. II'll update those this evening and report back.

Edit: yeah, we are on the same page. Fighting the starter is exactly what its doing.
cucamelsmd15 is offline   Reply With Quote
Old 11-01-2012, 10:42 PM   #5
Junior Member
Thread Starter
 
Join Date: Oct 2010
Location: Wake Forest, NC
Posts: 175
Total Cats: 0
Default

Started tonight. Warmed up, ran the trigger wizard. Idled like ***. Leaned out the fuel and gave it a little bump in timing in the idle cells. Idles at 850 like a bauce.

Will upload log in the morning. Need to tinker with warmup enrichment, which I can also post, but those seem to be pretty good.

Closed loop idle next?
cucamelsmd15 is offline   Reply With Quote
Old 11-02-2012, 08:46 AM   #6
Junior Member
Thread Starter
 
Join Date: Oct 2010
Location: Wake Forest, NC
Posts: 175
Total Cats: 0
Default

Log with idle and a few revs.
Attached Files
File Type: msl 2012-11-01_21.09.23.msl (1.16 MB, 76 views)
cucamelsmd15 is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
elesjuan's mediocre 95 Miata adventure (google fiber edition) elesjuan Build Threads 8 02-16-2016 09:36 PM
DIYPNP Won't Stay Running huesmann MEGAsquirt 19 09-16-2015 08:11 PM
Project DDoS: '99 "Budget" boost build ProjectDDoS Build Threads 1 09-09-2015 02:52 PM
New here, saying hi, here's what I'm workin with. SuperSneakySecretSquirrel Meet and Greet 5 09-06-2015 09:30 PM


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 01:21 AM.