EasyTherm 5.0 - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


MEGAsquirt A place to collectively sort out this megasquirt gizmo

Reply
 
 
 
LinkBack Thread Tools
Old 09-19-2008, 03:18 PM   #1
Boost Pope
Thread Starter
iTrader: (8)
 
Joe Perez's Avatar
 
Join Date: Sep 2005
Location: Delicious and Moist.
Posts: 26,322
Total Cats: 1,918
Default EasyTherm 5.0

Just a quick heads-up: EasyTherm 5.0 (beta) is out: http://home.comcast.net/~whaussmann/...m5_install.exe

There is much awesomeness in the new version. The UI is totally different- IAT and CLT are on separate pages, so you can load different defaults for each, and use different units (F vs. C) for each. And if you enter custom sensor data, you can then save it as a default for later use.
Joe Perez is online now   Reply With Quote
Old 09-19-2008, 03:38 PM   #2
Elite Member
iTrader: (21)
 
paul's Avatar
 
Join Date: Jun 2006
Location: Point Pleasant, NJ
Posts: 2,957
Total Cats: 2
Default

thank you
paul is offline   Reply With Quote
Old 10-31-2008, 01:50 AM   #3
Junior Member
 
Join Date: Jul 2005
Location: Hillsborough, NC
Posts: 273
Total Cats: 0
Default

Hmm... tried to install it but didn't get anywhere. First it installed cygwin, but I already had cygwin installed, so it installed an older version on top of what was there. After that, it just quit. What normally happens after the cygwin installation?
JustinHoMi is offline   Reply With Quote
Old 10-31-2008, 10:45 AM   #4
Elite Member
iTrader: (9)
 
Saml01's Avatar
 
Join Date: Jul 2007
Location: NYC
Posts: 5,730
Total Cats: 2
Default

Now if only this application could except an excel file consisting of temp and resistance values to use to extrapolate the best temp curve values to use for the most accurate readings.
Saml01 is offline   Reply With Quote
Old 10-31-2008, 10:09 PM   #5
Junior Member
 
Join Date: Jul 2005
Location: Hillsborough, NC
Posts: 273
Total Cats: 0
Default

I figured out my problem. There is a bug in the easytherm installer. If you have a file called "setup.exe" in the same folder as the easytherm installer, then it will launch setup.exe instead.
JustinHoMi is offline   Reply With Quote
Old 11-01-2008, 03:52 PM   #6
Junior Member
iTrader: (4)
 
Join Date: Jul 2007
Location: Indianapolis, IN
Posts: 113
Total Cats: 0
Default

This is so much better. Finally got my settings together. Work flow is much more streamlined than the old version. Thanks!
sotaku is offline   Reply With Quote
Old 12-18-2008, 01:01 AM   #7
Junior Member
 
Join Date: Sep 2007
Posts: 108
Total Cats: 0
Default

I am moving back to 10G and am going to try ET 5.0 (actually the first time I have used anything other than the pre-built packages so ET 5.0 is my first try at EasyTherm).


This looks straightforward but I wanted to clarify something; when it asks for the original .s19 file, shall I point it to the .s19 file in the top level 10G folder (There are 2 .s19's, one at the top level, the other in the src subfolder)? It may not matter but I wanted to be sure before I push the button.

Also, is there any problem pointing to the 10G folder for the original .s19 file and also pointing to the mtCfg folder in that same 10G directory for the new files? (or should I duplicate the 10G folder with one as the source and the other the new project)?

{I am using the DIYAutotune software installation package for my software and once I run EasyTherm I will just rename the .s19 load the fw using the standard utility (and reload my .msq).}

As usual, thanks for your help.
aseer is offline   Reply With Quote
Old 12-18-2008, 01:23 AM   #8
Boost Pope
Thread Starter
iTrader: (8)
 
Joe Perez's Avatar
 
Join Date: Sep 2005
Location: Delicious and Moist.
Posts: 26,322
Total Cats: 1,918
Default

Huh? Sounds like a funny directory structure you've got there.

When you download the regular HR10g distribution, there is only one .s19 file, at the top level. The contents of src\ are, as the name implies, sources. Binaries don't belong there. The only file you need out of src\ is kpafactor4250.inc, which needs to go into Program Files\MegaSquirt\MegaTune2.25\mtCfg\. Also, I don't think I've ever seen a mtCfg\ directory inside an hr10x distribution. It really sounds to me like you're looking at the default DIY files, which unless you've got a '96 or '97, are not HR code.

However, at the end of the day, only a couple of things are actually important here.
  • Start with a known-clean copy of HR10G. You might want to download a fresh one: http://ys3al35l.googlepages.com/hr_10g.zip
  • Place the EasyTherm output files into a new, clearly labeled folder so you can keep track of them
  • Remember to copy over the kpafactor.inc and msns-extra.ini from the distribution, and the matfactor, thermfactor, and airdenfactor.inc from Easytherm, into Program Files\MegaSquirt\MegaTune2.25\mtCfg\
Joe Perez is online now   Reply With Quote
Old 12-18-2008, 02:15 AM   #9
Junior Member
 
Join Date: Sep 2007
Posts: 108
Total Cats: 0
Default

Quote:
Originally Posted by Joe Perez View Post
Huh? Sounds like a funny directory structure you've got there.

When you download the regular HR10g distribution, there is only one .s19 file, at the top level. The contents of src\ are, as the name implies, sources. Binaries don't belong there. The only file you need out of src\ is kpafactor4250.inc, which needs to go into Program Files\MegaSquirt\MegaTune2.25\mtCfg\. Also, I don't think I've ever seen a mtCfg\ directory inside an hr10x distribution. It really sounds to me like you're looking at the default DIY files, which unless you've got a '96 or '97, are not HR code.

However, at the end of the day, only a couple of things are actually important here.
  • Start with a known-clean copy of HR10G. You might want to download a fresh one: http://ys3al35l.googlepages.com/hr_10g.zip
  • Place the EasyTherm output files into a new, clearly labeled folder so you can keep track of them
  • Remember to copy over the kpafactor.inc and msns-extra.ini from the distribution, and the matfactor, thermfactor, and airdenfactor.inc from Easytherm, into Program Files\MegaSquirt\MegaTune2.25\mtCfg\
Thanks for responding. The directory structure is as I described. I just uninstalled and redid the installation, I pulled it from:
MegaSquirt Software and Firmware - MegaTune - MSnS-E
the 06-16-08 package described at the top of the page (there is a 10G directory that seems fully populated, and there are two .s19 files, one at the top level, one in the src subfolder (though they have different creation dates). However if all I have to do is duplicate the 10G directory and copy over the files, that seems pretty straightforward too.

Dave
(this is still relatively new to me but the file structure I described is what came from installing that package - twice)
aseer is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
SUPER Important Megasquirt Threads cjernigan MEGAsquirt 24 05-06-2014 03:59 AM
Software Installation Aussie Driver Useful Saved Posts 17 07-01-2011 03:18 PM
Inaccurate IAT Calibration for MSPNP9093 Running No AFM Flash zzyx7 MEGAsquirt 0 01-24-2009 01:41 AM
Easytherm, MSPNP, firmware Q's Dlaitini MEGAsquirt 4 07-01-2008 01:37 PM
Easy therm trouble greenday3437 MEGAsquirt 6 05-28-2007 12:23 AM


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 11:05 PM.