Hrm ECU resets - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


MEGAsquirt A place to collectively sort out this megasquirt gizmo

Reply
 
 
 
LinkBack Thread Tools
Old 11-26-2006, 02:55 PM   #1
Elite Member
Thread Starter
iTrader: (1)
 
Join Date: Jun 2006
Location: Warrington/Birmingham
Posts: 2,658
Total Cats: 39
Default Hrm ECU resets

I've finally got my TPS to work, except now I think i've buggered something up!

Before I start tearing into my wiring again, I've tepped into, and not cut the stock TPS lines (TPS Ref is red and TPS sig is Red/black)

whenever i've driving if i completly back off the accelerator the ECU switches off until i apply the accellerator. wtf?

it doesn't do this out of gear though.....

I'm sure I'll figure out the problem tomorrow, but just though i'd sound out any ideas here first!

thanks
richyvrlimited is offline   Reply With Quote
Old 11-26-2006, 11:50 PM   #2
Junior Member
 
Join Date: Aug 2006
Location: Ridgecrest, Ca
Posts: 308
Total Cats: 0
Default

Do you need the TPS ref for anything? If your ECU and MS share the same ground then you should be able to use just the signal. The ECU doesn't like much draw on the 5v TPS ref source.

Not sure why being in gear changes things. Maybe it's a momentary drop and when your in gear your inertia pushes through it. Check logs?
arga is offline   Reply With Quote
Old 11-27-2006, 04:31 AM   #3
Elite Member
Thread Starter
iTrader: (1)
 
Join Date: Jun 2006
Location: Warrington/Birmingham
Posts: 2,658
Total Cats: 39
Default

Quote:
Originally Posted by arga View Post
Do you need the TPS ref for anything? If your ECU and MS share the same ground then you should be able to use just the signal. The ECU doesn't like much draw on the 5v TPS ref source.

Not sure why being in gear changes things. Maybe it's a momentary drop and when your in gear your inertia pushes through it. Check logs?
yeah I'd like to use TPS AE and the flood clear mode. plus I'm ---- and If i know something should work, i'd like it to

thanks, i'll try snipping the TPS Ref line first.
richyvrlimited is offline   Reply With Quote
Old 11-27-2006, 05:53 AM   #4
Elite Member
Thread Starter
iTrader: (1)
 
Join Date: Jun 2006
Location: Warrington/Birmingham
Posts: 2,658
Total Cats: 39
Default

Good advice arga, cut the TPS Vref line and everything worked

seems strange that the TPS works though, as i'd tried just connecting pin 22 to the line it's currently connected to and it didn't work....

ah well works now, thanks!
richyvrlimited is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Raleigh: Fiberglass headlight scope, 1.6L ECU, AFM, Hardtop latches, more bigmackloud Miata parts for sale/trade 13 09-22-2017 01:34 PM
3rd Time's a Charm...hopefully. zephyrusaurai Meet and Greet 2 09-28-2015 11:59 PM
Are my coils failing? viriiguy General Miata Chat 5 09-28-2015 08:39 PM
ME221 Now has Autotune and Long Term Fuel Trim Tables Motorsport-Electronics ECUs and Tuning 0 09-05-2015 09:02 AM


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 12:48 AM.