I put the MS in MSM. - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


MEGAsquirt A place to collectively sort out this megasquirt gizmo

Reply
 
 
 
LinkBack Thread Tools
Old 07-14-2008, 10:47 AM   #1
Elite Member
Thread Starter
iTrader: (21)
 
paul's Avatar
 
Join Date: Jun 2006
Location: Point Pleasant, NJ
Posts: 2,957
Total Cats: 2
Default I put the MS in MSM.

So yesterday I finally got around to installing an MSI v3.57 in a friend's 04 MSM.

Ordered the MSI from DIY and the harness extension from Boomslang. Combined the db37 and harness extension a couple weeks ago leaving the fuel injector and spark wiring intact. This way we could hook up the MS to make sure it was monitor everything correctly before proceeding. Best way to do it if you are going parallel as it helps a lot if something is wrong. Like when we first started it up we had no tach in MT. If MS was controlling spark and fuel at that point the car wouldn't have started and I wouldn't have known where to begin. This at least narrowed it down to something between the NA CAS I installed and the software. Turned out to be a software thing that I fixed by flashing new firmware.

Installed a GM IAT sensor in the FM elbow before the TB and ran it's own wiring directly to the MS. This way the factory wiring is untouched and I didn't have to mess around with undocumented bias resistor values to calibrate the sensor.

Next step was switching the fueling over to MS. Left the current injectors in, again to narrow down causes of problems if we ran into any. Car ran fine. Took it out for some tuning. Found the small 254cc 94 injectors(long story*see abbreviated version below) were way undersized and seeing 100% duty cycle up top.

So next we installed his recently cleaned RX7 460s. For anyone who hasn't done injectors on an NB you might not think it's a big deal but Mazda really fucked us in this respect, especially on the MSM. Changing injectors is an hour job for me on an NB head and I've done it multiple times. Adjusted the required fuel accordingly and change the cranking pulse widths to what I thought would suffice, I just took 60% of the current values that were working with 254cc injectors. Took a lil longer than usual to start the car, I attributed it to there being no fuel in the fuel rail or injectors. Took the car out for some tuning. When we got back Evan shut the car off early in the driveway. Tried to restart it but it wouldn't. Called who I thought was a friend(23c Jason) since he runs a squirted 01 with 460s for his cranking pulswsidths. He refused because him and Evan are in a flamewar. So I started adding to the higher temp pulsewidths to get the car started. SUCCESS! Then I remembered I had an old MSQ of Chads so I changed the rest of the values to match his 99/00 with 550s. Really didn't have another choice since we couldn't wait for the car to cool to ambient temp. Hopefully he was able to get the car started this morning, I'm sure I would have heard from him if not.

So at this point the MS is handling fueling with 460cc injectors. The next 2 things are switching the spark over to MS and hooking up the EBC. It was getting late, 10pm, so I was only gonna do 1. Figured it was safer to do EBC because it was less involved and if it didn't work he could still leave. If spark didn't work I'd have to redo the harness.

Connected the boost control solenoid, set up some values in MT, and left to get some Ralph's Italian Ice(best italian ice on the planet) with the girlfriend before they closed because she wasn't too happy that I had been outside all day doing "miata ****".

Now time for tuning EBC. I like to do the opposite of what Brain recommends and start with low duty cycles and adjust accordingly. That took a little longer than it normally does because Evan had a habit of lifting early. Ended up setting the boost to about 12 which we hit at 3000rpm out to redline, which is currently 7200 on the otherwise 6500rpm limited MSM.

Another day I will tackle moving the spark over to MS but as of right now Evan is ecstatic with the car.


Just got an email from Evan as I am typing this: "Car fired up without any hesitation and drove great this morning. "


* Evan had "upgraded" his injectors to Supra green tops(305cc) last summer. Had one fail earlier this year and got a replacement. A few weeks ago he had another failure and couldn't get a replacement. I installed the only injectors I had that his ECU could drive, a set of 94 tan tops that I just removed from my daily driver after 250,000 miles.

Last edited by paul; 07-14-2008 at 11:09 AM.
paul is offline   Reply With Quote
Old 07-14-2008, 10:48 AM   #2
Elite Member
Thread Starter
iTrader: (21)
 
paul's Avatar
 
Join Date: Jun 2006
Location: Point Pleasant, NJ
Posts: 2,957
Total Cats: 2
Default

Forgot to mention. Currently the car is running LoRes. Last time I tried HiRes on a parallel install I ran into some problems so I am leaving that for another day.

Oh, and does anyone else know of another squirted MSM? Nobody over on the mazdaspeed forums thinks it'd been done before. No idea why. It's no different from any other NB really and there is no reason it shouldn't work. Lots of people think it won't since they have not had great success with EMU.
paul is offline   Reply With Quote
Old 07-14-2008, 10:52 AM   #3
Boost Czar
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 72,900
Total Cats: 1,793
Default

Quote:
Originally Posted by paul View Post

Now time for tuning EBC. I like to do the opposite of what Brain recommends and start with low duty cycles and adjust accordingly.
i only start high to simply find where my boost target RPM is. then I start low to find what DC% maintains that to redline.

Glad you had success....you shouldn't have any problems with the 10g firmware, and I bet he'd be even happier.
Braineack is offline   Reply With Quote
Old 07-14-2008, 11:03 AM   #4
Elite Member
Thread Starter
iTrader: (21)
 
paul's Avatar
 
Join Date: Jun 2006
Location: Point Pleasant, NJ
Posts: 2,957
Total Cats: 2
Default

I'm trying to remember what problem I had. I'm not sure but I think it was with the clt/iat temps afterward so i must be doing something wrong with easytherm. is the procedure exactly the same for hi and lo res or am i supposed to select hi-res in easytherm before creating the inc files?
paul is offline   Reply With Quote
Old 07-14-2008, 11:13 AM   #5
Boost Czar
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 72,900
Total Cats: 1,793
Default

it's exactly the same. im running 10g parallel. as well as newbsauce and a few others here. most mornings I see 70* AIT and 70* CLT
Braineack is offline   Reply With Quote
Old 07-14-2008, 11:37 AM   #6
Elite Member
iTrader: (9)
 
TurboTim's Avatar
 
Join Date: Jun 2006
Location: Chesterfield, NJ
Posts: 6,485
Total Cats: 248
Default

Good job Paul.

What sort of wiring changes did you have to do with the fuel injectors? The MSM is sequential and I think the Megasquirt has batch fire, right? So you just took the correct two OEM injector wires to the MS injector driver?

If MS can run COPs in sequential why can't it run the injectors? Not enough injector drivers? Or do you all run the cops like the wasted spark coils?
TurboTim is offline   Reply With Quote
Old 07-14-2008, 12:09 PM   #7
Elite Member
Thread Starter
iTrader: (21)
 
paul's Avatar
 
Join Date: Jun 2006
Location: Point Pleasant, NJ
Posts: 2,957
Total Cats: 2
Default

ran the MSI just like you would in any NA/NB(other than the Cali sequential versions). I bridged 1&3 and 2&4.

the MSI can't do sequential spark or fuel. the ms2 can do both i believe.
paul is offline   Reply With Quote
Old 07-14-2008, 01:44 PM   #8
Elite Member
iTrader: (24)
 
Join Date: Jun 2007
Location: Sherman Oaks, CA
Posts: 4,482
Total Cats: 3
Default

eh... now i need to buy one of you guys a plane ticket so you can come and help me figure out why the hell my car wont run on ait!
UrbanSoot is offline   Reply With Quote
Old 07-14-2008, 01:55 PM   #9
Supporting Vendor
 
Matt Cramer's Avatar
 
Join Date: Sep 2006
Posts: 2,266
Total Cats: 51
Default

Quote:
Originally Posted by TurboTim View Post
If MS can run COPs in sequential why can't it run the injectors? Not enough injector drivers? Or do you all run the cops like the wasted spark coils?
Not enough drivers or outputs. It won't run sequential COPs with the stock sensors with MS1 either, but MS1 can run sequential COPs with certain other types of CAS.
Matt Cramer is offline   Reply With Quote
Old 07-14-2008, 04:18 PM   #10
Junior Member
 
Join Date: Mar 2008
Location: Seattle
Posts: 244
Total Cats: 3
Default

Us guys over at Mazda-speed.com are a simple folk, we get boxed solutions from either BEGi or FM.

It's because we are stupid and lazy that we think MS was magically not going to work on our cars.

But once I heard that you, Paul, were gonna do this, I figured it would work first or second try at most.

Also, thanks to you and Jersey for shedding some light on the whole megasquirt hybrid install deal. It seems like a much better plan than going with the Hydra and dumping the stock ECU. (and a bit cheaper too, initially.)
DontPassTheFence is offline   Reply With Quote
Old 07-14-2008, 05:32 PM   #11
Senior Member
iTrader: (1)
 
Join Date: Apr 2007
Location: North Jersey
Posts: 721
Total Cats: 0
Default

nice job paul. funny to hear about how the Jason v. Evan situation came to a head.
budget racer is offline   Reply With Quote
Old 07-14-2008, 06:07 PM   #12
Junior Member
 
Join Date: Oct 2007
Location: AC, NJ
Posts: 346
Total Cats: 0
Default

Does this mean we're breaking up?
compy is offline   Reply With Quote
Old 07-14-2008, 07:35 PM   #13
Elite Member
Thread Starter
iTrader: (21)
 
paul's Avatar
 
Join Date: Jun 2006
Location: Point Pleasant, NJ
Posts: 2,957
Total Cats: 2
Default

There is no us.
paul is offline   Reply With Quote
Old 07-14-2008, 07:43 PM   #14
Senior Member
iTrader: (2)
 
Join Date: Jun 2006
Location: Springfield, NJ
Posts: 670
Total Cats: 0
Default

Quote:
Originally Posted by paul View Post
Called who I thought was a friend(23c Jason) since he runs a squirted 01 with 460s for his cranking pulswsidths. He refused because him and Evan are in a flamewar.
Although it cost us some time, in the end things turned out very well, probably even better than if we used Jason' specs.

Quote:
Originally Posted by paul View Post
I'm sure I would have heard from him if not.
Ya think?

Quote:
Originally Posted by paul View Post
The next 2 things are switching the spark over to MS and hooking up the EBC.
Also, if anyone here is interested, I'm going to wire a simple on-off switch to the power lead for the EBC. That way I can turn it off for driving in low-traction situations. I don't own another car and in the winter my MSM goes on steelies and Blizzaks. So I'm looking forward to having this makeshift "dual-stage" configuration. And yes, I can wire that all by myself ... lest anyone here read Paul's and Tim's posts too often and decide that I'm some kind of dolt.

As I posted just now on the MSM and Mob forums, here's my layman's analysis:
- With the car stock, 7.5 psi began at around 5,000 rpm, to 6,200 rev limit.
- Post-Absurdflow, 10 began at around 4,000 rpm, to 6,200 rev limit.
- Megasquirt and EBC, 13 psi begins at around 3,000 rpm, to 7,200 rev limit.

Zoom, zoom.
evank is offline   Reply With Quote
Old 07-14-2008, 07:45 PM   #15
Senior Member
iTrader: (2)
 
Join Date: Jun 2006
Location: Springfield, NJ
Posts: 670
Total Cats: 0
Default

Quote:
Originally Posted by paul View Post
Lots of people think it won't since they have not had great success with EMU.
Lots of people in MSM-land also said a 3" exhaust "won't fit" even AFTER my car got an Absurdflow.
evank is offline   Reply With Quote
Old 07-14-2008, 09:19 PM   #16
Junior Member
 
Join Date: Oct 2007
Location: AC, NJ
Posts: 346
Total Cats: 0
Default

Quote:
Originally Posted by evank View Post
Although it cost us some time, in the end things turned out very well, probably even better than if we used Jason' specs.


Can never stop talkin **** can you? I'm not going to mention any names, but I use 460 numbers from one of the top moderators here, so that is an insult to him as well. And my car starts great in any temperature.

Tuning pulsewidths is not something super hard, and not being able to do it yourself is nothing but embarassing.
compy is offline   Reply With Quote
Old 07-14-2008, 09:24 PM   #17
Senior Member
iTrader: (2)
 
Join Date: Jun 2006
Location: Springfield, NJ
Posts: 670
Total Cats: 0
Default

The main person who you hurt yesterday by not cooperating was Paul.
evank is offline   Reply With Quote
Old 07-14-2008, 10:01 PM   #18
Junior Member
 
Join Date: Oct 2007
Location: AC, NJ
Posts: 346
Total Cats: 0
Default

He wouldn't have been hurt if it wasn't for you, so don't try to blame me.
compy is offline   Reply With Quote
Old 07-14-2008, 10:03 PM   #19
Boost Czar
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 72,900
Total Cats: 1,793
Default

Quote:
Originally Posted by evank View Post
The main person who you hurt yesterday by not cooperating was Paul.
it hurt me too.
Braineack is offline   Reply With Quote
Old 07-14-2008, 10:23 PM   #20
Junior Member
iTrader: (12)
 
Join Date: Oct 2007
Location: Central, NJ
Posts: 487
Total Cats: 1
Default

Quote:
Originally Posted by paul View Post
...and left to get some Ralph's Italian Ice(best italian ice on the planet)...
MikeRiv87 is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Project Gemini - Turbo Civic on the Cheap Full_Tilt_Boogie Build Threads 59 12-15-2017 09:00 PM
Garrett Turbo, 1.8 Oil Pan, & Misc. Stuff nbdooey Miata parts for sale/trade 9 08-30-2017 10:50 PM
Back to Stock Part Out!! Turbo Parts, MS2 Enhanced 01-05, Suspension, and MOAR! StratoBlue1109 Miata parts for sale/trade 16 10-02-2015 10:39 AM
Going back to stock. Need some 1.6 parts. Trent WTB 2 10-01-2015 01:15 PM
Low oil pressure after 1.8 swap and new turbo setup JesseTheNoob DIY Turbo Discussion 15 09-30-2015 03:44 PM


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 07:15 AM.