idle dip after light rev - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


MEGAsquirt A place to collectively sort out this megasquirt gizmo

Reply
 
 
 
LinkBack Thread Tools
Old 11-09-2015, 07:23 PM   #1
Junior Member
Thread Starter
 
Join Date: Apr 2013
Location: Elgin, SC
Posts: 359
Total Cats: -4
Default idle dip after light rev

So this was fine still I started messing with the accel pump, but I put it back to where it was and I still have this issue. I burned it and saved it. Basically if I'm idling and give a slight rev, like 10% tps, it will stall out trying to get back to idle. This also happens sometimes after I start it back up, it will start then die. But sometimes it starts and idles up for a few seconds, and returns to normal 950 I have it set at. I've tried playing with the IAC PIDs, and it seems to have made it better, but the next rev I give it it stalls back out. Can someone help me out? Also if 2 threads is too much can a mod merge this with my other one, thanks.
Attached Files
File Type: msl idledip.msl (465.9 KB, 97 views)
File Type: msq CurrentTune.msq (177.0 KB, 110 views)
whinin is offline   Reply With Quote
Old 11-09-2015, 07:54 PM   #2
Junior Member
Thread Starter
 
Join Date: Apr 2013
Location: Elgin, SC
Posts: 359
Total Cats: -4
Default

gonna try this tomorrow

https://www.miataturbo.net/megasquir...it-miss-84668/

hope it helps me out
whinin is offline   Reply With Quote
Old 11-09-2015, 09:28 PM   #3
Sadfab Union President
iTrader: (3)
 
Join Date: May 2014
Location: Kansas
Posts: 2,690
Total Cats: 113
Default

It looks to me as if your car is taking ~35% idle duty to run 900rpm, but your initial values are 2-3% under that.

So, it do what you ask of it. Returns to an idle duty too low, then compensates. It can manage one or two throttle blips, but by then it's too rich to recover from the third.

So that's my suggestion, increase initial idle values.
deezums is offline   Reply With Quote
Old 11-09-2015, 09:49 PM   #4
Junior Member
Thread Starter
 
Join Date: Apr 2013
Location: Elgin, SC
Posts: 359
Total Cats: -4
Default

Awesome, loaded and saved on laptop. Tomorrow I will report back, I increased initial values by 3 across the board.
whinin is offline   Reply With Quote
Old 11-10-2015, 07:43 PM   #5
Junior Member
Thread Starter
 
Join Date: Apr 2013
Location: Elgin, SC
Posts: 359
Total Cats: -4
Default

Damn thing was actually way worse, the starter has never gotten such a work out. I tested the idle speeds and pw for the valve, it will idle all the way down to about 500 rpm at 26 pwm, and all the way up to 2000 at 50 pwm. I stopped at these values, it was still changing with raising or lowering the pwm.

So I set my idle to 950, changed my idle initial values, and messed with my PID settings. It will catch itself now, and doesn't idle up and down like it did this morning. But it still dips too low after a slight rev.
Attached Files
File Type: msq CurrentTune.msq (177.0 KB, 104 views)
File Type: msl 2ndidle.msl (195.6 KB, 58 views)
whinin is offline   Reply With Quote
Old 11-10-2015, 07:52 PM   #6
Junior Member
 
Join Date: Feb 2014
Location: Chicago, IL
Posts: 95
Total Cats: 1
Default

I came across the same issue when I first installed megasquirt on my car, fixed it with messing with timing at low rpm/kpa I believe, but I have horrible memory.
AdrianD2 is offline   Reply With Quote
Old 11-10-2015, 08:29 PM   #7
Newb
 
Join Date: Oct 2015
Location: Southern California
Posts: 27
Total Cats: 0
Default

Your PID settings look like they need work, you have 80%D gain and only 15% I gain.

Try something around the ranges of 25/80/0
HexRX is offline   Reply With Quote
Old 11-10-2015, 09:41 PM   #8
Junior Member
Thread Starter
 
Join Date: Apr 2013
Location: Elgin, SC
Posts: 359
Total Cats: -4
Default

Yeah I messed with my timing, it was set at 17.5 15 17.5. So as to kind of 'cup' the idle in case it dipped. I adjusted it down to around 12.5, and it improved stable idle, it didn't bounce up and down anymore. I will mess with the PID settings a bit more and try what was suggested, thanks!
whinin is offline   Reply With Quote
Old 11-10-2015, 10:32 PM   #9
Junior Member
Thread Starter
 
Join Date: Apr 2013
Location: Elgin, SC
Posts: 359
Total Cats: -4
Default

Going this route.

https://www.miataturbo.net/megasquir...8/#post1249695

Will be messing with it saturday before I work on the FD, driving the 96 till then. Can't stand this damn idle...
whinin is offline   Reply With Quote
Old 11-14-2015, 06:34 PM   #10
Junior Member
Thread Starter
 
Join Date: Apr 2013
Location: Elgin, SC
Posts: 359
Total Cats: -4
Default

Got it smooth now, and even when I make adjustments to the idle VE table now, I got it to idle well around 12.5-13.0 afr, where it was around 10.5-11.0 woot!
whinin is offline   Reply With Quote
Old 11-14-2015, 06:43 PM   #11
Junior Member
Thread Starter
 
Join Date: Apr 2013
Location: Elgin, SC
Posts: 359
Total Cats: -4
Default

Found out I had a vacuum leak about the size of the IAC hose on the I/C pipe. Put a cap on it and tightened it down (it had a cap before but I don't think I had a clamp on it, derp). This thing spools up like crazy now. As you saw, it spooled around 5k at 10lbs then tapered, now it spools at 3500 at 14lbs and I hit the overboost protection I had set, it scared the crap out of me. Whoops.

whinin is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Are these scratches and clearance between the piston and cilinderwall normal? Vincentmiata Engine Performance 13 11-10-2015 05:40 PM
Main relay - Car won't start .one lane General Miata Chat 6 11-10-2015 12:46 PM
Valve Overlap for Turbo engines? What adjustments have you made? 2manyhobyz DIY Turbo Discussion 2 11-09-2015 10:10 PM
Veterans Day 2015 SALE at Fab9Tuning! Nov 9th to 11th Save on EVERYTHING! FAB Fab9 Tuning - Miata Performance Parts 0 11-09-2015 03:39 PM
Megasquirt wont A/C Idle up Goldwar MEGAsquirt 2 11-03-2015 04:01 PM


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 08:33 PM.