Megasquirt 64 bit error message - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


MEGAsquirt A place to collectively sort out this megasquirt gizmo

Reply
 
 
 
LinkBack Thread Tools
Old 01-23-2010, 07:02 PM   #1
I'm Miserable!
Thread Starter
iTrader: (11)
 
Join Date: Apr 2008
Location: Texas, 'Murica
Posts: 2,505
Total Cats: 7
Default Megasquirt 64 bit error message

Hi everyone, i am trying to install a pnp on my 95 with out mass air flow. Anyways, when i go to load up the firmware, it says that it isnt operational with my version of windows. (i am running Vista). Do you have any ideas, do i have to download any more software? Are there different versions im not aware of, i checked the site, the Faqs on here, and did a search on m.net and here. Also, of course i consulted the manual. Any ideas?
chicksdigmiatas is offline   Reply With Quote
Old 01-24-2010, 10:45 PM   #2
I'm Miserable!
Thread Starter
iTrader: (11)
 
Join Date: Apr 2008
Location: Texas, 'Murica
Posts: 2,505
Total Cats: 7
Default

nothing so far?
chicksdigmiatas is offline   Reply With Quote
Old 01-25-2010, 10:39 AM   #3
Ben
Supporting Vendor
iTrader: (33)
 
Ben's Avatar
 
Join Date: Jul 2006
Location: atlanta-ish
Posts: 12,689
Total Cats: 99
Default

How about grabbing a screen shot of the error message?
Ben is offline   Reply With Quote
Old 01-25-2010, 04:16 PM   #4
I'm Miserable!
Thread Starter
iTrader: (11)
 
Join Date: Apr 2008
Location: Texas, 'Murica
Posts: 2,505
Total Cats: 7
Default

Screenshots...
Attached Thumbnails
Megasquirt 64 bit error message-mserror.jpg   Megasquirt 64 bit error message-mserror2.jpg  
chicksdigmiatas is offline   Reply With Quote
Old 01-25-2010, 04:23 PM   #5
Boost Czar
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 72,867
Total Cats: 1,790
Default

needs posting at msextra.com
Braineack is offline   Reply With Quote
Old 01-25-2010, 10:38 PM   #6
Junior Member
 
Join Date: Sep 2009
Location: Kennewick, WA
Posts: 67
Total Cats: 0
Default

Just borrow someone elses laptop that is 32-bit to flash then megatune will work on anything.
ubenpdon is offline   Reply With Quote
Old 01-25-2010, 11:19 PM   #7
Junior Member
 
Join Date: Aug 2006
Location: Cedar City, UT
Posts: 228
Total Cats: 4
Default

try right clicking the program, going into propertys and setting compatibilty to make it run in windows XP mode maybe?

it did not install the program in your "program files" folder did it? all my 32 bit apps i have go into the "program files x86" folder for me
Dlaitini is offline   Reply With Quote
Old 01-27-2010, 09:33 PM   #8
Senior Member
iTrader: (3)
 
Join Date: Mar 2007
Posts: 567
Total Cats: 1
Default

fu.... I just got this same lame *** message on my computer
slutz4 is offline   Reply With Quote
Old 01-28-2010, 12:01 AM   #9
Senior Member
iTrader: (3)
 
Join Date: Mar 2007
Posts: 567
Total Cats: 1
Default

if anyone has this problem, heres the solution.


Megasquirt pnp 64 bit error? - MX-5 Miata Forum
slutz4 is offline   Reply With Quote
Old 01-28-2010, 01:47 AM   #10
Junior Member
 
Join Date: Sep 2009
Location: Kennewick, WA
Posts: 67
Total Cats: 0
Default

Quote:
Originally Posted by slutz4 View Post
if anyone has this problem, heres the solution.


Megasquirt pnp 64 bit error? - MX-5 Miata Forum
Aww, yes..... another problem solved with search. Handy.
ubenpdon is offline   Reply With Quote
Old 01-28-2010, 10:13 AM   #11
Ben
Supporting Vendor
iTrader: (33)
 
Ben's Avatar
 
Join Date: Jul 2006
Location: atlanta-ish
Posts: 12,689
Total Cats: 99
Default

Did the fix work?
Ben is offline   Reply With Quote
Old 01-28-2010, 03:25 PM   #12
Senior Member
iTrader: (3)
 
Join Date: Mar 2007
Posts: 567
Total Cats: 1
Default

Ill let you know shortly. I just got home from work.
slutz4 is offline   Reply With Quote
Old 01-28-2010, 03:48 PM   #13
Senior Member
iTrader: (3)
 
Join Date: Mar 2007
Posts: 567
Total Cats: 1
Default

Its giving me an error message once the download firmware dos screen loads up that wont let me use the program

It says its Not a valid Win32 application.

Name:  errormessage.jpg
Views: 3
Size:  78.1 KB
slutz4 is offline   Reply With Quote
Old 02-01-2010, 12:55 AM   #14
I'm Miserable!
Thread Starter
iTrader: (11)
 
Join Date: Apr 2008
Location: Texas, 'Murica
Posts: 2,505
Total Cats: 7
Default

Got the same message, i posted it on m.net
chicksdigmiatas is offline   Reply With Quote
Old 02-01-2010, 04:09 AM   #15
DXO
Junior Member
iTrader: (2)
 
Join Date: Jul 2008
Location: Kannapolis, NC
Posts: 229
Total Cats: 1
Default

this problem is caused by the choose command the flashing script uses. if someone were to remove, or bypass, the comm port selection and just hard code a specific port in it should work.

Ill take a swing at it. What comm port are you using?

_____________________
OK the aabove would work, the fix is to replace CHOICE.COM(16bit) in \src with a 32/64-bit version. Preferably choice.exe

Attached is a copy of the newer version of choice.exe(one named "choice.exe" and the other "choice.com", both are the same file). Drop them into the src folder(C:\Program Files\MegaSquirt\[version]\src) and see how it runs. Only other problem I see is download.exe not being compatible with 32-bit, but we will see.



EDIT AGAIN:
Or you could just listen to the people at M.net, they seem to have ti fixed.
Attached Files
File Type: zip CHOICE.zip (42.1 KB, 51 views)

Last edited by DXO; 02-01-2010 at 04:32 AM.
DXO is offline   Reply With Quote
Old 02-01-2010, 08:00 AM   #16
I'm Miserable!
Thread Starter
iTrader: (11)
 
Join Date: Apr 2008
Location: Texas, 'Murica
Posts: 2,505
Total Cats: 7
Default

Quote:
Originally Posted by DXO View Post
this problem is caused by the choose command the flashing script uses. if someone were to remove, or bypass, the comm port selection and just hard code a specific port in it should work.

Ill take a swing at it. What comm port are you using?

_____________________
OK the aabove would work, the fix is to replace CHOICE.COM(16bit) in \src with a 32/64-bit version. Preferably choice.exe

Attached is a copy of the newer version of choice.exe(one named "choice.exe" and the other "choice.com", both are the same file). Drop them into the src folder(C:\Program Files\MegaSquirt\[version]\src) and see how it runs. Only other problem I see is download.exe not being compatible with 32-bit, but we will see.



EDIT AGAIN:
Or you could just listen to the people at M.net, they seem to have ti fixed.
Thats why we got the new error message, there were 2 choice files in that link you put here, i will deal with it when i get back home from work, i gotta run now. COM1 btw
chicksdigmiatas is offline   Reply With Quote
Old 02-01-2010, 11:16 PM   #17
I'm Miserable!
Thread Starter
iTrader: (11)
 
Join Date: Apr 2008
Location: Texas, 'Murica
Posts: 2,505
Total Cats: 7
Default

Is that what it should look like with no cable hooked up? I have never seen it correctly.
Attached Thumbnails
Megasquirt 64 bit error message-msfixed.jpg  
chicksdigmiatas is offline   Reply With Quote
Old 02-01-2010, 11:39 PM   #18
DXO
Junior Member
iTrader: (2)
 
Join Date: Jul 2008
Location: Kannapolis, NC
Posts: 229
Total Cats: 1
Default

I have been playing around with it on my desktop (64bit) and just as stated before it does not work. After replacing the CHOICE.COM file it proceeds to work correctly. With no cable hooked up, when choosing a com port it will still continue to the next screen for you to choose if you are upgrading from the standard code or not. So it should work with just replacing the CHOICE.COM file. In my opinion this should have been included before.

Side note... What USB>Serial cable are you using that has 64bit drivers?
DXO is offline   Reply With Quote
Old 02-01-2010, 11:53 PM   #19
I'm Miserable!
Thread Starter
iTrader: (11)
 
Join Date: Apr 2008
Location: Texas, 'Murica
Posts: 2,505
Total Cats: 7
Default

chicksdigmiatas is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
My solution for Oiltemp and Oilpressure input into Megasuirt (MS3) Zaphod MEGAsquirt 41 01-24-2016 01:25 PM
Any pnp megasquirt for 2001 Big_gumby WTB 0 09-30-2015 04:34 PM
1996 Turbo Build Goldwar DIY Turbo Discussion 2 09-29-2015 10:20 AM


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 01:23 PM.