Ms installation issues. - Page 3 - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


MEGAsquirt A place to collectively sort out this megasquirt gizmo

Reply
 
 
 
LinkBack Thread Tools
Old 12-27-2007, 08:51 PM   #41
Elite Member
iTrader: (13)
 
cjernigan's Avatar
 
Join Date: Oct 2006
Location: Atlanta, GA
Posts: 8,147
Total Cats: 6
Default

Well when i built your MS i could have included a modification for Fan control so we could turn them on at a lower temp. Didn't think you would be needing it with a PWR and the FCM fans/shroud. It's a little late for all that now though. As of now the only way I know for you to turn your fans on at a earlier temp would be to wire in a inline switch to turn them on manually or get in the diagnostic box and jumper them on all the time. Pretty sure that can be done.

If you want i can line you and Manny up on how to modify the MS for fan control. It's not very hard, and it takes a couple electronic components but if I put them in the mail when i got back you could get it done sometime this spring no problem.
cjernigan is offline   Reply With Quote
Old 12-27-2007, 08:52 PM   #42
Elite Member
iTrader: (3)
 
AbeFM's Avatar
 
Join Date: Aug 2006
Location: San Diego, CA
Posts: 3,048
Total Cats: 8
Default

Quote:
Originally Posted by Spaniard View Post
Coolant temps showed 215*. Not happy with that one. I heard the fans come into operation only when the MS read that temp. Not happy with that.
You might want to get the seal, too, though you can RTV it in, but when you take out the 180 thermo, you'll likely wreck the old paper seal. The real reason for the NAPA part is not that it's 160, but that it opens REALLY WIDE.

Original/Mazda_New/NAPA
If I could find a 180 that opened as wide as my 160 does, I'd get that.
Addtional pics:
http://abefm.smugmug.com/gallery/1807308


Quote:
Originally Posted by Spaniard View Post
The info on how to unhook the WG is good but at my age I really don't need to do that. I've also got the Knocksense sensor installed (granted in the wrong location, right next to the CAS and I'll also get to changing it soon) but one thing I did which I really like and I'll take some pics and show them just in case anyone else wants to do it was to put the led on a small hole I made to the 2 gauge pod I have installed. Love that location, it scares the hell out of me.
Oh, yeah, that's one of the least clean things in my car, just sitting there in front of the guages. It works well, really gets my attention. I'm afraid to put the new one in, since I'll lose my carefully selected setting on the trim pot. I'm sure I'll figure it out.

Pulling the WG is great - there's SO much more of the off-boost map you can readily tune that way. It takes about 15 seconds with a cold motor. Just pull the c-clip and lift the arm off.



It's unhooked here (so is the turbo, this will ALSO limit boost. :-P)

Quote:
Originally Posted by Spaniard View Post
Finally, whenever you can, please post some pics on the WUE. It makes sense but I'd like to know more.
The three status LED's can be used as general outputs (at least on the MS-II), you MS-I guys use them to run your ignition (two of them) leaving the third for "spark C" - on mine, I have the output powering the solenoids which close my fans.

I put a 2.2 k-ohm resistor in, and they weren't working really well. Recommended was 1k. Now I have 470 ohms and they work perfect. Basically, all I do is use an output of the MS to power the relays, and turn the fans on, then I select what temp I want them to come on at. I think the MS table is off (temps were reporting high!).
AbeFM is offline   Reply With Quote
Old 12-27-2007, 08:59 PM   #43
Elite Member
iTrader: (13)
 
cjernigan's Avatar
 
Join Date: Oct 2006
Location: Atlanta, GA
Posts: 8,147
Total Cats: 6
Default

ABE, he's running an external Tial WG. There is no actuator arm to release.
cjernigan is offline   Reply With Quote
Old 12-27-2007, 09:14 PM   #44
Elite Member
iTrader: (39)
 
Zabac's Avatar
 
Join Date: Sep 2007
Location: High Point NC
Posts: 4,854
Total Cats: 8
Default

nothing smart to say here, but congrats to you Rafa for getting everything sorted out, im very happy for you, i cant wait myself to get my car fired up with MS
Cheers
Zabac is offline   Reply With Quote
Old 12-27-2007, 09:16 PM   #45
Elite Member
Thread Starter
iTrader: (22)
 
Join Date: Dec 2006
Location: Sunny Spanish speaking Non US Caribbean
Posts: 3,257
Total Cats: 3
Default

Quote:
Originally Posted by cjernigan View Post
Well when i built your MS i could have included a modification for Fan control so we could turn them on at a lower temp. Didn't think you would be needing it with a PWR and the FCM fans/shroud. It's a little late for all that now though. As of now the only way I know for you to turn your fans on at a earlier temp would be to wire in a inline switch to turn them on manually or get in the diagnostic box and jumper them on all the time. Pretty sure that can be done.

If you want i can line you and Manny up on how to modify the MS for fan control. It's not very hard, and it takes a couple electronic components but if I put them in the mail when i got back you could get it done sometime this spring no problem.
Ok, the first option I can take care right now. In fact the Opel Corsa Manny drives is wired that way. I'll do that for the time being.

About the second option; do you think RadioShack would have those electronic components? plenty of those here plus the General Manager is a very close friend of mine. I can ask him the favor to order the components if they carry them. I'm sure between Manny and me we can safely take care of that.

I have to read Abe's post. I'll have questions.

Thanks,
Rafa is offline   Reply With Quote
Old 12-27-2007, 09:17 PM   #46
Elite Member
Thread Starter
iTrader: (22)
 
Join Date: Dec 2006
Location: Sunny Spanish speaking Non US Caribbean
Posts: 3,257
Total Cats: 3
Default

Quote:
Originally Posted by whaaamx5 View Post
nothing smart to say here, but congrats to you Rafa for getting everything sorted out, im very happy for you, i cant wait myself to get my car fired up with MS
Cheers
Thanks Dan, I appreciate your assistance. Smart enough for me.
Rafa is offline   Reply With Quote
Old 12-27-2007, 09:30 PM   #47
Elite Member
Thread Starter
iTrader: (22)
 
Join Date: Dec 2006
Location: Sunny Spanish speaking Non US Caribbean
Posts: 3,257
Total Cats: 3
Default

Hey Abe, I checked your link. I agree with your concept. I'm not sure if I'll be able to get a 180* one but I'll check some local shops. I want some info on the specific NAPA part so I can contact them. I like that one. Let me know what parts I should order.

Another thing I'm going to do tomorrow morning is to install the real water temp I bought (it's an Autometer and that ****** was expensive!). I hate the one in my car. When it finally reacts my car is already overheating
Rafa is offline   Reply With Quote
Old 12-27-2007, 09:33 PM   #48
Elite Member
iTrader: (3)
 
AbeFM's Avatar
 
Join Date: Aug 2006
Location: San Diego, CA
Posts: 3,048
Total Cats: 8
Default

What year is your car? You can "linearlize" your guage. It's a big pain in the butt, but it looks good when you do it. Basically, get the stock guage to respond to what the sender is saying. It takes some soldering, some experimentation, etc.

Shoot, I don't have the part number, when I went to Vista all my old email didn't come with me (someone have a PST to anything-else converter??)... But go on miata.net and search "NAPA 160" or similar and you'll find it soon enough. I was on the miatapower.net list for a while and I know it's on there.
-Abe.
AbeFM is offline   Reply With Quote
Old 12-27-2007, 09:36 PM   #49
Elite Member
iTrader: (13)
 
cjernigan's Avatar
 
Join Date: Oct 2006
Location: Atlanta, GA
Posts: 8,147
Total Cats: 6
Default

You can get the components to do the Fan mod at radioshack Rafa. These two links have parts lists and directions on how to complete it.
https://www.miataturbo.net/forum/sho...18&postcount=3
http://www.diyautotune.com/tech_arti...#Add_Output_v3
cjernigan is offline   Reply With Quote
Old 12-27-2007, 09:47 PM   #50
Elite Member
Thread Starter
iTrader: (22)
 
Join Date: Dec 2006
Location: Sunny Spanish speaking Non US Caribbean
Posts: 3,257
Total Cats: 3
Default

Quote:
Originally Posted by cjernigan View Post
You can get the components to do the Fan mod at radioshack Rafa. These two links have parts lists and directions on how to complete it.
https://www.miataturbo.net/forum/sho...18&postcount=3
http://www.diyautotune.com/tech_arti...#Add_Output_v3
And afterwards you don't want me to call you my "guru"

I'll read both very carefully and get back to you with my questions but I'll wait a few days to do it. In the meantime I'm going to do the same thing I did with my son's Opel. Those fans are going to be working overtime for a few days!

Thanks guys. It's almost 10 pm and I haven't slept well in quite some time. FWIW Chad, as far as I know you've helped turbo the first Miata in DR. You all should be very proud.

In a few days I'll start a thread to convey my feelings. In the meantime:

THANKS FROM THE BOTTOM OF MY HEART AND HAPPY NEW YEAR! I feel like I should give you a rest for a few days.

p.s. Chad, you should also be proud of the fact that Cristian has faced issues of his own in the last 2 days and he had no input on the cops conversion or starting my car. I'm running it at 93 octane with toluene as a booster.

Happy trails,

Rafa
Rafa is offline   Reply With Quote
Old 12-27-2007, 09:53 PM   #51
Elite Member
iTrader: (13)
 
cjernigan's Avatar
 
Join Date: Oct 2006
Location: Atlanta, GA
Posts: 8,147
Total Cats: 6
Default

Quote:
Originally Posted by AbeFM View Post
What year is your car? You can "linearlize" your guage. It's a big pain in the butt, but it looks good when you do it. Basically, get the stock guage to respond to what the sender is saying. It takes some soldering, some experimentation, etc.

Shoot, I don't have the part number, when I went to Vista all my old email didn't come with me (someone have a PST to anything-else converter??)... But go on miata.net and search "NAPA 160" or similar and you'll find it soon enough. I was on the miatapower.net list for a while and I know it's on there.
-Abe.
I think the part number for the 160* thermostat at Napa is #BA 1430687

Abe, i'm in dire need of some temp gauge linearization help. When I did it i followed some odd instructions on m.net and now i have a gauge that sits in the middle and never moves. From the time i turn the car on to the time i turn it off nothing changes. Do you have a certain writeup you followed, or added to. I remember you saying you used a POT, but i could be mistaken.
cjernigan is offline   Reply With Quote
Old 12-27-2007, 10:43 PM   #52
Elite Member
iTrader: (3)
 
AbeFM's Avatar
 
Join Date: Aug 2006
Location: San Diego, CA
Posts: 3,048
Total Cats: 8
Default

Sigh, again, not having access to my old email is killing me.

The be all end all article was by Wally from miatapower and miata.net: http://www.gravitydesign.net/saturn/miata/mtglp.cfm

But I guess his site is down. Shoot. I'd go asking him about it, he did have a write up I used. But if you dig around on my site, you should get which pins to use.

http://abefm.smugmug.com/gallery/3923107#227732361 If you're careful you should figure out where I've put stuff, and mayve with the full size versions get an idea of the values.

I do know the pot ended up at almost a dead short, so using a smaller one would work. Also, use a high current power supply, I was shocked at how much current this thing drank.

But in the end, I could adjust both the offset and the scale. Worked quite well.

Looking at the pics, there's TWO pots. There's also a zener diode I removed, that's what makes it NON linear.
AbeFM is offline   Reply With Quote
Old 12-27-2007, 11:03 PM   #53
Elite Member
iTrader: (13)
 
cjernigan's Avatar
 
Join Date: Oct 2006
Location: Atlanta, GA
Posts: 8,147
Total Cats: 6
Default

Thanks so much for the pictures. I don't have a extra thermocouple but I know my fan's come on around 207-210* and I know my coolant reading in MS is within plus or minus 3* of that it seems. I think I can handle all that. Just have to find small POTs like you used.
cjernigan is offline   Reply With Quote
Old 12-28-2007, 06:01 PM   #54
Elite Member
Thread Starter
iTrader: (22)
 
Join Date: Dec 2006
Location: Sunny Spanish speaking Non US Caribbean
Posts: 3,257
Total Cats: 3
Default

Chad, we finally got the car to 8psi of boost without detonation. Ignition was very retarded. Thanks, I know that was you trying to take care of my car. I appreciate it. We also changed the VE table, the overboost protection and the rev limiter to 7400. Don't worry I'm babying it.

A couple extra little things. The fans were not working because the fuse was blown. Changed it this morning but the fans will only come in after the MS reads something like 209*. Too high and they immediately come in when I turn the A/C on. I'm running 93 octane based on the Toluene mix. The other thing was the MS not reading AFR; they had connected it to the Lambda at the shop, when they changed it to the O2 sensor it started reading it. I still have to change the LC-1 to the one WOT sent me. I'll also be moving the bung further away from the turbo.

Thanks for everything.

Rafa
Rafa is offline   Reply With Quote
Old 12-28-2007, 06:42 PM   #55
Boost Czar
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 72,872
Total Cats: 1,790
Default

Quote:
Originally Posted by Spaniard View Post
...only come in after the MS reads something like 209*. Too high ...

Rafa

welcome to every miata ever.
Braineack is offline   Reply With Quote
Old 12-28-2007, 06:55 PM   #56
Elite Member
iTrader: (13)
 
cjernigan's Avatar
 
Join Date: Oct 2006
Location: Atlanta, GA
Posts: 8,147
Total Cats: 6
Default

Once you do the fan mod you'll be able to turn them on and off when ever you like.

For now you should be fine though. Glad it's running well.
cjernigan is offline   Reply With Quote
Old 12-28-2007, 07:26 PM   #57
Elite Member
Thread Starter
iTrader: (22)
 
Join Date: Dec 2006
Location: Sunny Spanish speaking Non US Caribbean
Posts: 3,257
Total Cats: 3
Default

Quote:
Originally Posted by Braineack View Post
welcome to every miata ever.
You mean every turbo miata ever, right?

Thanks for everything.
Rafa is offline   Reply With Quote
Old 12-28-2007, 07:30 PM   #58
Elite Member
Thread Starter
iTrader: (22)
 
Join Date: Dec 2006
Location: Sunny Spanish speaking Non US Caribbean
Posts: 3,257
Total Cats: 3
Default

Quote:
Originally Posted by cjernigan View Post
Once you do the fan mod you'll be able to turn them on and off when ever you like.

For now you should be fine though. Glad it's running well.
That won't be for quite some time. Even Manny is scared of that one. I got to find someone with a good electronics base. No way I am going to allow just anyone to open my MS.

BTW, I figure I'll be visiting the Dyno on the first or second week of 2008.
Rafa is offline   Reply With Quote
Old 12-28-2007, 07:35 PM   #59
Boost Czar
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 72,872
Total Cats: 1,790
Default

Quote:
Originally Posted by Spaniard View Post
You mean every turbo miata ever, right?

Thanks for everything.

stock fans kick on at 207*, which is why your's kicked on at 207* now you just have a gauge that tells you that...
Braineack is offline   Reply With Quote
Old 12-28-2007, 07:49 PM   #60
Elite Member
iTrader: (3)
 
AbeFM's Avatar
 
Join Date: Aug 2006
Location: San Diego, CA
Posts: 3,048
Total Cats: 8
Default

Quote:
Originally Posted by Spaniard View Post
That won't be for quite some time. Even Manny is scared of that one. I got to find someone with a good electronics base. No way I am going to allow just anyone to open my MS.

BTW, I figure I'll be visiting the Dyno on the first or second week of 2008.
Don't be so afraid, soldering isn't that big a deal. Building your own jimstim is excelent practice. Really the fan mod is pretty simple
AbeFM is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Buzzing from driver side of engine bay? (MS3 install) nick470 MEGAsquirt 7 06-16-2017 02:53 PM
OTS Bilstein to motorsports ASN conversion stoves Suspension, Brakes, Drivetrain 5 04-21-2016 04:00 PM
Back to Stock Part Out!! Turbo Parts, MS2 Enhanced 01-05, Suspension, and MOAR! StratoBlue1109 Miata parts for sale/trade 16 10-02-2015 10:39 AM
Walbro 255lph Fuel Pump $50 lsc224 Miata parts for sale/trade 2 10-01-2015 10:17 AM
Low oil pressure after 1.8 swap and new turbo setup JesseTheNoob DIY Turbo Discussion 15 09-30-2015 03:44 PM


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 04:35 AM.