MS noob question - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


MEGAsquirt A place to collectively sort out this megasquirt gizmo

Reply
 
 
 
LinkBack Thread Tools
Old 08-27-2010, 07:29 PM   #1
Senior Member
Thread Starter
iTrader: (12)
 
absRTP's Avatar
 
Join Date: Sep 2009
Location: Montreal, Canada
Posts: 582
Total Cats: 0
Default MS noob question

Hi everybody

I'm about to finally instal my megasquirt in my car,
I build it in April but did'nt have the time to work on it until last month or so

So here we go

a little overview of my set up:

-1990 miata 1.6L
-MS1 PCB3.0 standalone (TIP120 modz)
-190lph hp walbro fuel pump
-LC-1 WB
-460cc redtop injectors
-Garrett T25



SO I have a question....


When I installed my MS I followed the megamanual and the tutorial

so I installed Q12 with the TIP 126.

But I found this last week on the miataturbo.wikidot.com

Quote:
To drive the 1.6L fuel pump

Since the stock ECU does not trigger the fuel pump, but the AFM does, we need a circuit to be able to prime and drive it properly. We back-feed 12v into the fuel pump relay to make it happen. You must remove ST_SIG fuse else you will short out the circuit.



For this circuit you can use one of the tip125s you do not typically utilize: q12 or q9.

Connect the banded end of D4 to VTEC_Out_to_MS.
Connect the VTEC_Out to your harness going to 1C.
You can use s19 for your 12v source.

You MUST remove ST_Sig fuse under the hood or you will burn up the transistor!!!

or can I just use the "green wire trick" from the dash to the MS directly?



THanks
absRTP is offline   Reply With Quote
Old 08-28-2010, 12:29 PM   #2
Boost Czar
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 72,819
Total Cats: 1,780
Default

you can just use the green wire trick...

I just don't like running extra wires.
Braineack is online now   Reply With Quote
Old 08-28-2010, 06:24 PM   #3
Senior Member
Thread Starter
iTrader: (12)
 
absRTP's Avatar
 
Join Date: Sep 2009
Location: Montreal, Canada
Posts: 582
Total Cats: 0
Default

ok thank you
absRTP is offline   Reply With Quote
Old 08-31-2010, 12:45 PM   #4
Senior Member
Thread Starter
iTrader: (12)
 
absRTP's Avatar
 
Join Date: Sep 2009
Location: Montreal, Canada
Posts: 582
Total Cats: 0
Default

anothet question,

I searched everywhere, but I'm not sure of what I found....

What should I do to make my tach work, bringing the outer ring signal from the cas to the cluster?

Bringing the megasquirt signal to the cluster?

Or.... jumping something in diagnostic box with a resistor or something....

I have read too much stuff and I cannot remember what was for a 1990....


Thank you
absRTP is offline   Reply With Quote
Old 08-31-2010, 12:54 PM   #5
Boost Czar
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 72,819
Total Cats: 1,780
Default

put a 1K 1/4 watt resistor in your diagnostics box between IG- and B+

the stock ECU used to provide this pullup to power the tach signal, since we removed the ECU, we removed the pull-up, this replaces it.
Braineack is online now   Reply With Quote
Old 08-31-2010, 01:02 PM   #6
Senior Member
Thread Starter
iTrader: (12)
 
absRTP's Avatar
 
Join Date: Sep 2009
Location: Montreal, Canada
Posts: 582
Total Cats: 0
Default

thanks alot Brain!
absRTP is offline   Reply With Quote
Old 09-01-2010, 10:10 AM   #7
Senior Member
Thread Starter
iTrader: (12)
 
absRTP's Avatar
 
Join Date: Sep 2009
Location: Montreal, Canada
Posts: 582
Total Cats: 0
Default

back with the fuel pump mod, can I use a TIP 126 instead of a 125??

I looked at the datasheet and there is not so much difference...
absRTP is offline   Reply With Quote
Old 09-01-2010, 10:11 AM   #8
Boost Czar
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 72,819
Total Cats: 1,780
Default

yes. tip125/126/127
Braineack is online now   Reply With Quote
Old 09-01-2010, 10:16 AM   #9
Senior Member
Thread Starter
iTrader: (12)
 
absRTP's Avatar
 
Join Date: Sep 2009
Location: Montreal, Canada
Posts: 582
Total Cats: 0
Default

good, I'm just gonna keep the 126 I used in this location
absRTP is offline   Reply With Quote
Old 09-01-2010, 10:16 AM   #10
I'm Miserable!
 
Join Date: Jun 2009
Location: albany, ga
Posts: 1,869
Total Cats: 3
Default

hmm I have a 92 using a MS1 and I didn't have to touch anything for keeping the stock tach working fine, works without adding any mods to the MS for tach and messing with the car
hmm
Techsalvager is offline   Reply With Quote
Old 09-01-2010, 10:19 AM   #11
Senior Member
Thread Starter
iTrader: (12)
 
absRTP's Avatar
 
Join Date: Sep 2009
Location: Montreal, Canada
Posts: 582
Total Cats: 0
Default

Quote:
Originally Posted by Techsalvager View Post
hmm I have a 92 using a MS1 and I didn't have to touch anything for keeping the stock tach working fine, works without adding any mods to the MS for tach and messing with the car
hmm
running boomslang or standalone?
absRTP is offline   Reply With Quote
Old 09-01-2010, 10:20 AM   #12
I'm Miserable!
 
Join Date: Jun 2009
Location: albany, ga
Posts: 1,869
Total Cats: 3
Default

Quote:
Originally Posted by absRTP View Post
running boomslang or standalone?
complete standalone
Techsalvager is offline   Reply With Quote
Old 09-01-2010, 10:21 AM   #13
Senior Member
Thread Starter
iTrader: (12)
 
absRTP's Avatar
 
Join Date: Sep 2009
Location: Montreal, Canada
Posts: 582
Total Cats: 0
Default

interesting....
absRTP is offline   Reply With Quote
Old 09-01-2010, 10:24 AM   #14
I'm Miserable!
 
Join Date: Jun 2009
Location: albany, ga
Posts: 1,869
Total Cats: 3
Default

just for info, running a MS1 pcb v1.01
But I don't see why that matters, as I believe that the stock dash 1.6 tach runs off either the coilpacks or iginitor
Techsalvager is offline   Reply With Quote
Old 09-01-2010, 10:25 AM   #15
Boost Czar
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 72,819
Total Cats: 1,780
Default

You can lose the tach if you damage your ignitor.
Braineack is online now   Reply With Quote
Old 09-02-2010, 09:23 PM   #16
Senior Member
Thread Starter
iTrader: (12)
 
absRTP's Avatar
 
Join Date: Sep 2009
Location: Montreal, Canada
Posts: 582
Total Cats: 0
Default

another question. yeppy!


should I solder the grounds together from pin 10 to 16?

absRTP is offline   Reply With Quote
Old 09-03-2010, 05:27 AM   #17
Junior Member
iTrader: (6)
 
Join Date: Aug 2008
Location: New Zealand
Posts: 250
Total Cats: 3
Default

You dont need to as MS doesn't use these pins


click here to view
ogwazza is offline   Reply With Quote
Old 09-03-2010, 09:09 AM   #18
Senior Member
Thread Starter
iTrader: (12)
 
absRTP's Avatar
 
Join Date: Sep 2009
Location: Montreal, Canada
Posts: 582
Total Cats: 0
Default

ok thanks, 'cause I saw other poeple soldering them together... maybe just to be safe....
absRTP is offline   Reply With Quote
Old 09-03-2010, 10:08 AM   #19
Boost Czar
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 72,819
Total Cats: 1,780
Default

pins 1-2-7-8-9-10-11-12-13-14-15-16 are already connected together. on most installs I simply run 4 individual grounds out the the 4 oem ground wires.
Braineack is online now   Reply With Quote
Old 09-03-2010, 10:19 AM   #20
Senior Member
Thread Starter
iTrader: (12)
 
absRTP's Avatar
 
Join Date: Sep 2009
Location: Montreal, Canada
Posts: 582
Total Cats: 0
Default

randomly running ground to small group? like 7-8-9, 10-11-12, 13-14-15-16, 16-17-18

?

seems good for me
absRTP is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Raleigh: Fiberglass headlight scope, 1.6L ECU, AFM, Hardtop latches, more bigmackloud Miata parts for sale/trade 13 09-22-2017 01:34 PM
15x10 - 15x11 6UL @ 949 Racing emilio700 Wheels and Tires 151 06-02-2017 03:36 PM
1994 Spec Miata Race Car SM/SM2/SSM For Sale Quinn Cars for sale/trade 6 10-23-2016 08:58 AM
Low oil pressure after 1.8 swap and new turbo setup JesseTheNoob DIY Turbo Discussion 15 09-30-2015 03:44 PM
NA Seat Sliders and Seat Belt Receivers skipstr Miata parts for sale/trade 2 09-28-2015 11:53 PM


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 01:30 PM.