MS2 fan control - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


MEGAsquirt A place to collectively sort out this megasquirt gizmo

Reply
 
 
 
LinkBack Thread Tools
Old 06-25-2012, 04:12 PM   #1
Junior Member
Thread Starter
 
Join Date: Jan 2011
Posts: 81
Total Cats: 0
Default MS2 fan control

Hi,

I have a MS2 built by reverant. When I switch on the ignition the fan starts and does not stop. (engine cold). At approx 80-84 deg C the thermostat opens and coolant flows into the radiator. As far as I can see in the output port settings the fan is switch on/off depending on the coolant temp. I have had overheating problems on track and don't know if my fan is contributing to them. Its probably a airflow through my rad problem, but I would like to know how to control the fan anyway.

Can anyone help
Attached Thumbnails
MS2 fan control-outputs.jpg  
andrew is offline   Reply With Quote
Old 06-25-2012, 04:13 PM   #2
Boost Czar
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 72,887
Total Cats: 1,792
Default

enhanced unit?
Braineack is online now   Reply With Quote
Old 06-25-2012, 04:31 PM   #3
Supporting Vendor
iTrader: (10)
 
Reverant's Avatar
 
Join Date: Jun 2006
Location: Athens, Greece
Posts: 5,440
Total Cats: 198
Default

What's the serial number on the unit?
Reverant is offline   Reply With Quote
Old 06-25-2012, 04:48 PM   #4
Junior Member
Thread Starter
 
Join Date: Jan 2011
Posts: 81
Total Cats: 0
Default

Wow, that was quick Reverant. I can't get to the car today to check the serial no. but i did take these pics of inside a while ago. It was built for stuart-oxford on mx5nutz about sept last year. If this dosn't help I will get the serial tomorrow.

Thanks again for quick response.
Attached Thumbnails
MS2 fan control-imag0691.jpg   MS2 fan control-imag0692.jpg  
andrew is offline   Reply With Quote
Old 06-25-2012, 05:00 PM   #5
Supporting Vendor
iTrader: (10)
 
Reverant's Avatar
 
Join Date: Jun 2006
Location: Athens, Greece
Posts: 5,440
Total Cats: 198
Default

Did you happen to load another person's basemap by any chance? Fan control on this unit is on the Warmup LED.
Reverant is offline   Reply With Quote
Old 06-25-2012, 05:19 PM   #6
Junior Member
Thread Starter
 
Join Date: Jan 2011
Posts: 81
Total Cats: 0
Default

Eh, yes actually and I thought it worked perfectly. So what does the warmup out do? Will I change anything?
andrew is offline   Reply With Quote
Old 06-25-2012, 05:26 PM   #7
Boost Czar
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 72,887
Total Cats: 1,792
Default

copy settings from accel led to warmup led.
Braineack is online now   Reply With Quote
Old 06-25-2012, 05:27 PM   #8
Junior Member
Thread Starter
 
Join Date: Jan 2011
Posts: 81
Total Cats: 0
Default

Just noticed I also have coolant settings in PAO too
Attached Thumbnails
MS2 fan control-pao.jpg  
Attached Files
File Type: msq 2012-05-24_11.5afrmap.msq (79.8 KB, 92 views)
andrew is offline   Reply With Quote
Old 06-25-2012, 05:38 PM   #9
Boost Czar
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 72,887
Total Cats: 1,792
Default

this is why loading random maps is stupid
Braineack is online now   Reply With Quote
Old 06-25-2012, 06:25 PM   #10
Junior Member
Thread Starter
 
Join Date: Jan 2011
Posts: 81
Total Cats: 0
Default

Quote:
Originally Posted by Braineack View Post
copy settings from accel led to warmup led.
Ok, but this makes me wonder what the accel led does and what should it settings be.

I agree with not loading other peoples maps, but the map I had didn't start the car. I found this map on here, it was the very same spec car so I tried it. It started and apart from this I have had no problems.
andrew is offline   Reply With Quote
Old 06-25-2012, 06:28 PM   #11
Senior Member
iTrader: (8)
 
Join Date: Jun 2010
Location: Navarre, FL
Posts: 1,127
Total Cats: 39
Default

look on the board and see what ALED etc is wired to. that will tell you what it (might) be used for.
aaronc7 is offline   Reply With Quote
Old 06-25-2012, 07:13 PM   #12
Boost Czar
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 72,887
Total Cats: 1,792
Default

its one your spark outputs. it's overriding anything set in the outputs...
Braineack is online now   Reply With Quote
Old 06-26-2012, 03:01 AM   #13
Supporting Vendor
iTrader: (10)
 
Reverant's Avatar
 
Join Date: Jun 2006
Location: Athens, Greece
Posts: 5,440
Total Cats: 198
Default

Accel LED and Injection LED are spark outputs on ALL of my units, Enhanced or not.
Reverant is offline   Reply With Quote
Old 06-26-2012, 05:29 PM   #14
Junior Member
Thread Starter
 
Join Date: Jan 2011
Posts: 81
Total Cats: 0
Default

Quote:
Originally Posted by Braineack View Post
copy settings from accel led to warmup led.
Great, did this and its working perfect. Thanks.
andrew is offline   Reply With Quote
Old 07-20-2012, 03:06 PM   #15
Tour de Franzia
iTrader: (6)
 
hustler's Avatar
 
Join Date: Jun 2006
Location: Republic of Dallas
Posts: 29,114
Total Cats: 351
Default

Two questions:
Why are none of my outputs checked "enabled"?
I can simply lower RPM value to zero and the fan will run when the engine is not running but key is on "ACC", right?
Quote:
Originally Posted by Braineack View Post
this is why loading random maps is stupid
404.invert.spark
hustler is offline   Reply With Quote
Old 07-20-2012, 03:14 PM   #16
Boost Czar
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 72,887
Total Cats: 1,792
Default

1. if you have a a reverant enhanced ms2, he doesn't use the MS2 cpu to control the fan.

2. not sure, in ms3 we have a parameter under the fan control section that allows you to enable to fan with power or not.
Braineack is online now   Reply With Quote
Old 07-21-2012, 03:58 AM   #17
Supporting Vendor
iTrader: (10)
 
Reverant's Avatar
 
Join Date: Jun 2006
Location: Athens, Greece
Posts: 5,440
Total Cats: 198
Default

Quote:
Originally Posted by hustler View Post
Two questions:
Why are none of my outputs checked "enabled"?
I can simply lower RPM value to zero and the fan will run when the engine is not running but key is on "ACC", right?

404.invert.spark
I have moved fan control from the MS processor board, to my expansion board.

This saves 2 outputs on the MS, which are free for you to use on anything else, like programmable outputs or sequential ignition.
Reverant is offline   Reply With Quote
Old 07-21-2012, 11:57 AM   #18
Tour de Franzia
iTrader: (6)
 
hustler's Avatar
 
Join Date: Jun 2006
Location: Republic of Dallas
Posts: 29,114
Total Cats: 351
Default

Quote:
Originally Posted by Reverant View Post
I have moved fan control from the MS processor board, to my expansion board.

This saves 2 outputs on the MS, which are free for you to use on anything else, like programmable outputs or sequential ignition.
Do I have any adjustability? When I get the MS3, it's imperative that I can run the fans when the engine is off, key is on, and I'm at or below 190.
hustler is offline   Reply With Quote
Old 07-21-2012, 12:04 PM   #19
Supporting Vendor
iTrader: (10)
 
Reverant's Avatar
 
Join Date: Jun 2006
Location: Athens, Greece
Posts: 5,440
Total Cats: 198
Default

They are not adjustable on the current model, they are on the next-gen.
Reverant is offline   Reply With Quote
Old 07-24-2012, 03:35 PM   #20
Junior Member
iTrader: (5)
 
Join Date: Mar 2012
Location: Gilbert, Az
Posts: 337
Total Cats: 26
Default

Quote:
Originally Posted by Reverant View Post
They are not adjustable on the current model, they are on the next-gen.
What is the default fan behavior of your expansion board?

I'm planning on getting my Reverant MS2v3 setup in the next week or so, if the fans are identical to stock then I'd like to perform the "parallel fan" wiring mod. If not and the 2nd A/C fan will switch on at a pre-determined temp without the A/C active then the mod would be un-necessary.

Thanks!
SJP0tato is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Another Cast Manifold Corky Bell Prefabbed Turbo Kits 18 11-22-2016 10:01 PM
My solution for Oiltemp and Oilpressure input into Megasuirt (MS3) Zaphod MEGAsquirt 41 01-24-2016 01:25 PM
1991 special edition with hard top full part out JC, NJ russian Miata parts for sale/trade 6 10-08-2015 04:01 PM
Back to Stock Part Out!! Turbo Parts, MS2 Enhanced 01-05, Suspension, and MOAR! StratoBlue1109 Miata parts for sale/trade 16 10-02-2015 10:39 AM


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 02:16 PM.