MS2 Sync Loss/Fuel Pump Relay Reset - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


MEGAsquirt A place to collectively sort out this megasquirt gizmo

Reply
 
 
 
LinkBack Thread Tools
Old 12-10-2013, 10:15 PM   #1
Supporting Vendor
Thread Starter
iTrader: (1)
 
Join Date: May 2010
Location: San Diego
Posts: 491
Total Cats: 39
Default MS2 Sync Loss/Fuel Pump Relay Reset

For some time now, my car has moments where it will suddenly drop in RPM, AFRs spike, you hear the fuel pump relay under the dash click and it keeps on going. Sometimes I can go a week without this happening, sometimes it will happen repeatedly in a 20 minute span. After a failure at ACS I discovered when I relocated my MS2 from under the passenger foot-well the glove box my fuel pump wire broke loose from my DB37 to my ECU plug. During the troubleshooting I replaced my CAS with another new-used unit before I noticed the wire. After re-soldering the wire my car started to act normal again.

Now during warm up I am getting a mis-fire(AFR spikes rich) which I am attributing to very old plugs/wires(replacing these tomorrow). Second shortly after the car warms up a bit you hear the fuel pump relay click, AFR's go lean, and it keeps going, sometimes only once other times it will happen repeatedly. I replaced the fuel pump today in case mine was going and inspected all of the wires in the surrounding area, they all look fine. I also have a used fuel pump relay in the mail to swap. I have already cleaned the grounds in the engine bay and wiggled all the wires while the car is running and found nothing loose. I also made to sure keep my CAS wiring as far away from the coilpack as possible as I know that can cause issues occasionally.

I attached the composite logger file & my MSQ. The sync loss occurs at page 95 of the .csv. If I am reading it correctly it looks like its a sync error 11 & 17? Does anyone have any input?
Attached Files
File Type: msq 2013-12-10_17.53.39.msq (84.3 KB, 50 views)
File Type: csv 2013-12-10_17.44.57.csv (1.06 MB, 41 views)
Lincoln Logs is online now   Reply With Quote
Old 12-11-2013, 06:55 PM   #2
Supporting Vendor
Thread Starter
iTrader: (1)
 
Join Date: May 2010
Location: San Diego
Posts: 491
Total Cats: 39
Default

I replaced the plugs & wires this morning and everything seems to have worked itself out.
Lincoln Logs is online now   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Back to Stock Part Out!! Turbo Parts, MS2 Enhanced 01-05, Suspension, and MOAR! StratoBlue1109 Miata parts for sale/trade 16 10-02-2015 10:39 AM
Walbro 255lph Fuel Pump $50 lsc224 Miata parts for sale/trade 2 10-01-2015 10:17 AM
Bad head gasket or ? shooterschmidty Engine Performance 8 09-30-2015 11:28 PM
Are my coils failing? viriiguy General Miata Chat 5 09-28-2015 08:39 PM


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 02:13 PM.