MS3 Starts/Runs rough, Rich as $%#$ nothing helps - Page 2 - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


MEGAsquirt A place to collectively sort out this megasquirt gizmo

Reply
 
 
 
LinkBack Thread Tools
Old 02-06-2014, 03:29 PM   #21
Junior Member
Thread Starter
iTrader: (-2)
 
Join Date: Nov 2012
Posts: 242
Total Cats: -42
Default

Nope, stock injectors... Car runs great on stock ecu
Gt2560rMiata is offline   Reply With Quote
Old 03-08-2014, 05:15 AM   #22
Junior Member
Thread Starter
iTrader: (-2)
 
Join Date: Nov 2012
Posts: 242
Total Cats: -42
Default

update - sent ecu back to REV, it has 2 fried injector drivers.
Gt2560rMiata is offline   Reply With Quote
Old 03-11-2014, 01:35 PM   #23
Newb
 
Join Date: Oct 2012
Posts: 31
Total Cats: -2
Default

Was gonna say stuck injectors because of recent problems I had, but glad you figured it out
bleezy is offline   Reply With Quote
Old 03-11-2014, 03:08 PM   #24
Senior Member
 
Join Date: Mar 2006
Location: Schwarzenberg, Germany
Posts: 1,497
Total Cats: 81
Default

Might have a solution for your problem... Upgraded to 1.3 release code and had the same symptoms - car running rich as ****. Solution was the MAP sensor calibration - the settings for

At total vacuum % was set to 147 and the Rate % was set to -47 - in the newer firmwares (I think this applies to 1.2.3 too) this should both be 0.

Reset this and the car ran fine again.

Edit: I missed the part with the fried injector drivers - I leave the rest in here anyway, as it might help someone else.

Greets
Zaphod is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Buzzing from driver side of engine bay? (MS3 install) nick470 MEGAsquirt 7 06-16-2017 02:53 PM
Momo Supercup seat jpreston Miata parts for sale/trade 2 05-17-2016 01:51 AM
My solution for Oiltemp and Oilpressure input into Megasuirt (MS3) Zaphod MEGAsquirt 41 01-24-2016 01:25 PM
WTB MP62 (Hotside) (NB2) Rick02R WTB 3 01-03-2016 08:18 PM
Odd Steering issue interestedofold Suspension, Brakes, Drivetrain 5 09-29-2015 02:42 PM


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 02:18 PM.