MS3 and wiring in a knock sensor unit - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


MEGAsquirt A place to collectively sort out this megasquirt gizmo

Reply
 
 
 
LinkBack Thread Tools
Old 12-26-2012, 10:26 PM   #1
Junior Member
Thread Starter
iTrader: (5)
 
Join Date: Nov 2010
Location: Maine
Posts: 407
Total Cats: -19
Default MS3 and wiring in a knock sensor unit

Hey guys,
Hoping someone will chime in soon on this. I'm finshing up installing a knock sensor module into my MS3. I've run into a stopping point and need some input. I need to wire up the K1 & K2 pads on the knock sensor module to the mainboard. I just can't figure out where to connect the two wires. I've read the forums, I've read the install page from DIY.

Any help will be great, pics are even better

I have mainboard version 3.0
MS3 basic board 1.3
MSX daughter board

Thanks,
Drew
tuckermon is offline   Reply With Quote
Old 12-26-2012, 10:31 PM   #2
Boost Czar
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 72,860
Total Cats: 1,788
Default

Megasquirt-3 MS3 - knock module

k1 goes to the knock sensor.
Braineack is offline   Reply With Quote
Old 12-26-2012, 10:39 PM   #3
Junior Member
Thread Starter
iTrader: (5)
 
Join Date: Nov 2010
Location: Maine
Posts: 407
Total Cats: -19
Default

Ok, I guess my next question is, is this in the wiring harness? Is the K1 soldered to the mainboard like the install states, if so, where.

I've read the link you posted, is states that the K1 and K2 wires goes to the knock sensor inputs, those look like they go the db15 pins 10 (K1) and pin 11 (K2). But I don't have a DB15 on the mainboard.
tuckermon is offline   Reply With Quote
Old 12-26-2012, 10:47 PM   #4
Boost Czar
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 72,860
Total Cats: 1,788
Default

use the spare inputs 1-4 on your mainboard.

for example, in your harness, you could wire the knock sensor to spare 1 and spare 2.

you can then run, inside the MS, spare 1 to k1 and spare 2 to ground.
Braineack is offline   Reply With Quote
Old 12-26-2012, 11:19 PM   #5
Junior Member
Thread Starter
iTrader: (5)
 
Join Date: Nov 2010
Location: Maine
Posts: 407
Total Cats: -19
Default

Please correct me if I'm wrong here, but doesn't the MSM have a knock sensor from the factory? Would that already be wired to the oem harness?
tuckermon is offline   Reply With Quote
Old 12-27-2012, 12:31 AM   #6
Murderator
iTrader: (76)
 
18psi's Avatar
 
Join Date: Apr 2008
Posts: 36,185
Total Cats: 2,582
Default

yes and yes
18psi is offline   Reply With Quote
Old 12-27-2012, 10:40 AM   #7
Boost Czar
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 72,860
Total Cats: 1,788
Default

did you not build your own ms3? this is very simple stuff here.


just wire the knock sensor to k1 via any of the spare inputs.
Braineack is offline   Reply With Quote
Old 12-27-2012, 11:14 AM   #8
Junior Member
Thread Starter
iTrader: (5)
 
Join Date: Nov 2010
Location: Maine
Posts: 407
Total Cats: -19
Default

No, rev built me a msm ms3 unit. I know its simple stuff here, just want to do it right and not guess at it and possibly be wrong. I guess my question needs to be detailed a bit more. Since the knock sensor is wired into the factory harness, what pin do I need to connect to the pigtail harness between the oem connectors and the MS3, I have no problem doing the wiring, but I don't know what pin from the oem harness needs to be connected to the "spare" or open pin on the MS3 harness. I'm not trying to reinvent the wheel here, just trying to figure out what pin from the oem wiring harness I need to use to run into the MS3 harness and then in turn solder from the DB connector to the K1 & K2 pads on the knock sensor board.
tuckermon is offline   Reply With Quote
Old 12-27-2012, 11:18 AM   #9
Boost Czar
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 72,860
Total Cats: 1,788
Default

4M:




youd have to ask reverant if you have any spare inputs. or if he already wired the knock sensor in the harness.
Attached Thumbnails
MS3 and wiring in a knock sensor unit-01-05-ecu-pins2.jpg  
Braineack is offline   Reply With Quote
Old 12-27-2012, 11:52 AM   #10
Supporting Vendor
iTrader: (10)
 
Reverant's Avatar
 
Join Date: Jun 2006
Location: Athens, Greece
Posts: 5,440
Total Cats: 198
Default

Connect K1 to SPR4.

Then connect pin #6 on the bottom 37-way connector of the MS to pin 4M on the OEM harness.

You didn't tell me that you were going to install the knock module or I would have prewired everything for you.
Reverant is offline   Reply With Quote
Old 12-27-2012, 03:03 PM   #11
Junior Member
Thread Starter
iTrader: (5)
 
Join Date: Nov 2010
Location: Maine
Posts: 407
Total Cats: -19
Default

Thanks Rev,
That's what I needed to know. I reviewed our emails and I did talk to you about me adding the knock sensor and compatibility with the new board. No big deal, I'll use your info and wire it up. Thank you again for everything.

tuckermon is offline   Reply With Quote
Old 12-27-2012, 03:07 PM   #12
Supporting Vendor
iTrader: (10)
 
Reverant's Avatar
 
Join Date: Jun 2006
Location: Athens, Greece
Posts: 5,440
Total Cats: 198
Default

Ouch, my bad. Is there a free white wire coming from the connector?
Reverant is offline   Reply With Quote
Old 12-27-2012, 03:33 PM   #13
Junior Member
Thread Starter
iTrader: (5)
 
Join Date: Nov 2010
Location: Maine
Posts: 407
Total Cats: -19
Default

No big deal. as for a white wire, no. I have red, yellow, gray, brown, and green. I just ran the wire from K1 to SPR4 and disassembled the MS end connector and see that pin 4 is free for use, but I noticed that the oem end of the cable is epoxied, so access the the pins is not available. I figured I'd just have to tap into the original wire. Any info on color or location on the oem connection from the car?
tuckermon is offline   Reply With Quote
Old 12-27-2012, 04:00 PM   #14
Supporting Vendor
iTrader: (10)
 
Reverant's Avatar
 
Join Date: Jun 2006
Location: Athens, Greece
Posts: 5,440
Total Cats: 198
Default

Yup, I've prewired it. Connect K1 to SPR1.
Reverant is offline   Reply With Quote
Old 12-27-2012, 04:30 PM   #15
Junior Member
Thread Starter
iTrader: (5)
 
Join Date: Nov 2010
Location: Maine
Posts: 407
Total Cats: -19
Default

Great. Thank you. It's all wired up and ready to go.
tuckermon is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Buzzing from driver side of engine bay? (MS3 install) nick470 MEGAsquirt 7 06-16-2017 02:53 PM
My solution for Oiltemp and Oilpressure input into Megasuirt (MS3) Zaphod MEGAsquirt 41 01-24-2016 01:25 PM
WTB MP62 (Hotside) (NB2) Rick02R WTB 3 01-03-2016 08:18 PM
Back to Stock Part Out!! Turbo Parts, MS2 Enhanced 01-05, Suspension, and MOAR! StratoBlue1109 Miata parts for sale/trade 16 10-02-2015 10:39 AM
Another Alternator thread ihiryu General Miata Chat 9 09-28-2015 11:22 AM


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 10:47 PM.