is this normal? - Miata Turbo Forum - Boost cars, acquire cats.

MEGAsquirt A place to collectively sort out this megasquirt gizmo
Sponsored by:
Sponsored by:

is this normal?

Old 12-04-2009, 06:41 PM
  #1  
Junior Member
Thread Starter
 
Join Date: Aug 2006
Location: Cedar City, UT
Posts: 236
Total Cats: 4
Question is this normal?

after starting up the car my MAP is around 33 kpa, then slowly drops to around 26 after it is fully warmed up

I'm also getting a little bit of oil smoke at startup, but im thinking because i dont have a restrictor for the turbo, possibly the oil pressure is peakign at 90psi its pushing past the seals? It too is fine once warmed up

i dont think that the weather here (salt lake - 10F last night) is a factor except in the amout of time it takes to get up to temp
Dlaitini is offline  
Old 12-04-2009, 07:00 PM
  #2  
Boost Czar
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 75,291
Total Cats: 2,154
Default

during ASE, itll stick to a certain MAP then decay out. tune it.

if its a new turbo install it will smoke a bit.
Braineack is offline  
Old 12-04-2009, 11:30 PM
  #3  
Junior Member
Thread Starter
 
Join Date: Aug 2006
Location: Cedar City, UT
Posts: 236
Total Cats: 4
Default

the turbo has been installed for about a year and a half now, the head was off last feburary and had new valves and valve guides installed, they and head machined to match , and 4 brand new pistons installed (bent intake valve and hole in piston 4 made this possible)

would the high oil pressure when cold (90psi on the stock guage) push oil past the seals? i have the begi-s kit so the sensor is reading off the same place that the oil feed for the turbo is. Its only for the first 10 secs or so. Ill check later, after the car has sat, to see if im getting oil in the combustion chamber from something else leaking.

im just hoping there is not another bent valve, i have few posts a long while ago that had me askign about really rough runnign till the car had hit exactly 160 degrees not sure whay it happened at that exact temp, so far this has not started to do that (hopefuly its something much easyer to fix) but ill also do a compression check and see if thats affected too.

Thanks
Dlaitini is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
bigmackloud
Miata parts for sale/trade
13
09-22-2017 01:34 PM
navalhawkeye
MEGAsquirt
9
10-07-2015 08:10 PM
shooterschmidty
Engine Performance
8
09-30-2015 11:28 PM
psyber_0ptix
MEGAsquirt
4
09-22-2015 10:35 AM
Der_Idiot
Engine Performance
14
09-16-2015 10:30 PM


Thread Tools
Search this Thread
Quick Reply: is this normal?


Archive Advertising Cookie Policy Privacy Statement Terms of Service

© 2018 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.