Problems idling - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


MEGAsquirt A place to collectively sort out this megasquirt gizmo

Reply
 
 
 
LinkBack Thread Tools
Old 05-05-2008, 10:41 PM   #1
Senior Member
Thread Starter
iTrader: (1)
 
miataspeed1point6's Avatar
 
Join Date: Feb 2006
Location: Detroit
Posts: 1,235
Total Cats: 0
Default Problems idling

The good news is that the MS is running the car and is communicating with my laptop. The bad news is the rough idle, and I'm not sure what to change.

Setup:
Braineack ms with MSPNP map
stock injectors
AFPR set to the same I had before ms
no AFM

I loaded the MSPNP map but its chugging and rough below 2k rpm. After 2k it seems to be just fine. The MS a/f gauge says I'm idling at 19.34. I'm using 0-5v linear innovate o2. Right now it puffs black smoke and I can tell it isn't happy. I have the MS vacuum line T'd into the stock FPR.

It actually idles alright with the ms vacuum line unplugged, just lots more black smoke. (I always forget to put that back on).

I'm new to this still so I'm unsure if I need to change the fuel map or idle settings. I want to poke around the settings while the car is running, but it can't be good for it to run like this.
miataspeed1point6 is offline   Reply With Quote
Old 05-05-2008, 10:44 PM   #2
Elite Member
iTrader: (3)
 
Mach929's Avatar
 
Join Date: Oct 2004
Location: lansdale PA
Posts: 2,500
Total Cats: 0
Default

try adding more fuel in your idle cells, but puffing black smoke at 19:1 has me confused
Mach929 is offline   Reply With Quote
Old 05-05-2008, 10:54 PM   #3
Senior Member
Thread Starter
iTrader: (1)
 
miataspeed1point6's Avatar
 
Join Date: Feb 2006
Location: Detroit
Posts: 1,235
Total Cats: 0
Default

Me too. Maybe from running rich higher in the rpm band? How much should I add at a time?

Sorry of this has been covered before. When I search there are so many different setups that I'm not sure which settings apply to me.
miataspeed1point6 is offline   Reply With Quote
Old 05-05-2008, 11:13 PM   #4
Boost Czar
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 72,899
Total Cats: 1,792
Default

it's rich, recalibrate the o2 sensor.
Braineack is offline   Reply With Quote
Old 05-05-2008, 11:48 PM   #5
Elite Member
iTrader: (3)
 
Join Date: May 2006
Location: Houston, TX
Posts: 2,900
Total Cats: 0
Default

Quote:
Originally Posted by Braineack View Post
it's rich, recalibrate the o2 sensor.
the O2 is probably fine... it's probably so rich that it's misfiring, hence reading lean.
Arkmage is offline   Reply With Quote
Old 05-10-2008, 02:40 PM   #6
Senior Member
Thread Starter
iTrader: (1)
 
miataspeed1point6's Avatar
 
Join Date: Feb 2006
Location: Detroit
Posts: 1,235
Total Cats: 0
Default

It idles a hell of a lot better now! I used the white dot and the post to the left of the timing marks as a rough guide to set the timing, with the engine shaking so badly I couldn't see the TDC mark at all.

The trigger angle was set to 65, changed that to 40 and it at least idles by itself nice and steady at 850rpm. I'm letting it warm up right now and then I'm going to set the timing closer.
miataspeed1point6 is offline   Reply With Quote
Old 05-10-2008, 03:34 PM   #7
Senior Member
Thread Starter
iTrader: (1)
 
miataspeed1point6's Avatar
 
Join Date: Feb 2006
Location: Detroit
Posts: 1,235
Total Cats: 0
Default

I went out and reset the timing closer to 10 degrees now that I can see the mark. I did set it while the engine was hot, I know thats bad. It idles at about 1k and has a slight mis, it doesn't stumble much but it's there. When I went from -10 to 10 it pours fuel, so I'm sure one of the plugs could be toast.

It seemed changing the trigger angle closer to 65 to set the timing seemed to make it idle worse. Should I adjust the CAS instead, or will that have the same results?

I did not recalibrate the o2 yet, I will when I swap exhausts. I'm getting the same 19.x afr at idle.

Not sure if I'm missing anything obvious or if any other settings need adjustment.
miataspeed1point6 is offline   Reply With Quote
Old 05-10-2008, 04:22 PM   #8
Boost Czar
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 72,899
Total Cats: 1,792
Default

post your map, whats you injectors and all that jazz?

on your fuel map, make all the first 6 cells (3 up two over), the same value.
Braineack is offline   Reply With Quote
Old 05-10-2008, 05:10 PM   #9
Senior Member
Thread Starter
iTrader: (1)
 
miataspeed1point6's Avatar
 
Join Date: Feb 2006
Location: Detroit
Posts: 1,235
Total Cats: 0
Default

The map is the PNP map, I haven't changed any settings. Only thing I changed was the trigger angle. Injectors are stock, still have the AFPR in there.

On the fuel map I should use the setting in the lower left on those 6 cells? I haven't touched those yet either.

If you still need to see it I can post my map when I get back home tonight.
miataspeed1point6 is offline   Reply With Quote
Old 05-11-2008, 07:46 PM   #10
Senior Member
Thread Starter
iTrader: (1)
 
miataspeed1point6's Avatar
 
Join Date: Feb 2006
Location: Detroit
Posts: 1,235
Total Cats: 0
Default

Went out today and tried to start it. Runs like **** again. Hopefully pipefather can come over and help sort it out. I'm going to swap exhausts and recalibrate the LC-1 and swap out the plugs while I'm at it. So much for this being easy.
miataspeed1point6 is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
My solution for Oiltemp and Oilpressure input into Megasuirt (MS3) Zaphod MEGAsquirt 41 01-24-2016 01:25 PM
Back to Stock Part Out!! Turbo Parts, MS2 Enhanced 01-05, Suspension, and MOAR! StratoBlue1109 Miata parts for sale/trade 16 10-02-2015 10:39 AM
Time to start learning and play with tuning The Gleas MEGAsquirt 3 10-01-2015 10:30 AM
Leaky Wilwoods mx592 Suspension, Brakes, Drivetrain 1 10-01-2015 01:45 AM
Low oil pressure after 1.8 swap and new turbo setup JesseTheNoob DIY Turbo Discussion 15 09-30-2015 03:44 PM


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 04:49 PM.